2014上海網路賽1004||hdu5045 contest【狀態壓縮dp】

MissZhou要努力發表於2016-04-22

Description

In the ACM International Collegiate Programming Contest, each team consist of three students. And the teams are given 5 hours to solve between 8 and 12 programming problems.

On Mars, there is programming contest, too. Each team consist of N students. The teams are given M hours to solve M programming problems. Each team can use only one computer, but they can’t cooperate to solve a problem. At the beginning of the ith hour, they will get the ith programming problem. They must choose a student to solve this problem and others go out to have a rest. The chosen student will spend an hour time to program this problem. At the end of this hour, he must submit his program. This program is then run on test data and can’t modify any more.

Now, you have to help a team to find a strategy to maximize the expected number of correctly solved problems.

For each problem, each student has a certain probability that correct solve. If the ith student solve the j th problem, the probability of correct solve is Pij .

At any time, the different between any two students’ programming time is not more than 1 hour. For example, if there are 3 students and there are 5 problems. The strategy {1,2,3,1,2}, {1,3,2,2,3} or {2,1,3,3,1} are all legal. But {1,1,3,2,3},{3,1,3,1,2} and {1,2,3,1,1} are all illegal.

You should find a strategy to maximize the expected number of correctly solved problems, if you have know all probability
 

Input

The first line of the input is T (1 ≤ T ≤ 20), which stands for the number of test cases you need to solve.

The first line of each case contains two integers N ,M (1 ≤ N ≤ 10,1 ≤ M ≤ 1000),denoting the number of students and programming problem, respectively.

The next N lines, each lines contains M real numbers between 0 and 1 , the j th number in the i th line is P ij .
 

Output

For each test case, print a line “Case #t: ”(without quotes, t means the index of the test case) at the beginning. Then a single real number means the maximal expected number of correctly solved problems if this team follow the best strategy, to five digits after the decimal point. Look at the output for sample input for details.
 

Sample Input

1 2 3 0.6 0.3 0.4 0.3 0.7 0.9
 

Sample Output

Case #1: 2.20000

恕本人才疏學淺,實在沒有看明白網路流的寫法==而且都說了n<=10明顯是狀壓啊==

題意:m小時之間每個小時有新出的一個題供n個人中的一個人做,每個人做出的概率已知,每一時刻任意兩個人做出的題數之差不得多於1個,問最多答題的個數

之前的狀壓都是三重迴圈是同一個數來的,然而這個題讓我重新認識了狀壓QAQ

1.狀壓讀數的話一定要從0開始啊啊啊,要不取狀態值會很費勁的

2.做過狀壓都知道,第一重迴圈和第三重迴圈都是正常的數,第二重迴圈是狀態。從“湊數”的角度看,第二重迴圈和第三重迴圈也得是n,第一重迴圈是m。從正常的解釋來看,第一重迴圈推的是每個題,第二重迴圈是某人做過哪些題,第三重迴圈是找一個人做當前的題

關於st==(1<<n)-1  st=0這句話是說“因為每兩個人之間答題數目不能超過1,所以當狀態達到1 << n - 1,即所有人都答過一題時,將重置為0。"

#include <iostream>
#include<cstring>
#include<cstdio>
using namespace std;
double num[11][1009],dp[1<<13][1009];
int n,m;
int main()
{
    //freopen("cin.txt","r",stdin);
    int t,cas=1;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d",&n,&m);
        for(int i=0;i<n;i++)
            for(int j=0;j<m;j++)
                scanf("%lf",&num[i][j]);
        for(int j=0;j<=m;j++)
            for(int i=0;i<(1<<n);i++)
                dp[i][j]=-1.0;
        dp[0][0]=0;
        for(int i=0;i<m;i++)
        {
            for(int j=0;j<(1<<n);j++)// 0
            {
                if(dp[j][i]<0) continue;
                for(int k=0;k<n;k++)
                {
                    if(j&(1<<k))continue;
                    int st=j|(1<<k);
                    if(st==(1<<n)-1) st=0;
                    dp[st][i+1]=max(dp[st][i+1],dp[j][i]+num[k][i]);
                }
            }
        }

        double ans=0.0;
        for(int i=0;i<(1<<n);i++)
            if(ans<dp[i][m]) ans=dp[i][m];
        printf("Case #%d: %.5lf\n",cas++,ans);
    }
    return 0;
}



相關文章