POJ 3335-Rotating Scoreboard(計算幾何-半平面交順時針模板)

kewlgrl發表於2017-04-16
Rotating Scoreboard
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 6963   Accepted: 2769

Description

This year, ACM/ICPC World finals will be held in a hall in form of a simple polygon. The coaches and spectators are seated along the edges of the polygon. We want to place a rotating scoreboard somewhere in the hall such that a spectator sitting anywhere on the boundary of the hall can view the scoreboard (i.e., his line of sight is not blocked by a wall). Note that if the line of sight of a spectator is tangent to the polygon boundary (either in a vertex or in an edge), he can still view the scoreboard. You may view spectator's seats as points along the boundary of the simple polygon, and consider the scoreboard as a point as well. Your program is given the corners of the hall (the vertices of the polygon), and must check if there is a location for the scoreboard (a point inside the polygon) such that the scoreboard can be viewed from any point on the edges of the polygon.

Input

The first number in the input line, T is the number of test cases. Each test case is specified on a single line of input in the form n x1 y1 x2 y2 ... xn yn where n (3 ≤ n ≤ 100) is the number of vertices in the polygon, and the pair of integers xi yi sequence specify the vertices of the polygon sorted in order.

Output

The output contains T lines, each corresponding to an input test case in that order. The output line contains either YES or NO depending on whether the scoreboard can be placed inside the hall conforming to the problem conditions.

Sample Input

2
4 0 0 0 1 1 1 1 0
8 0 0  0 2  1 2  1 1  2 1  2 2  3 2  3 0

Sample Output

YES
NO

Source


       順時針給出N個點的座標,計算其是否存在多邊形的核,即使得在核的地方放置一個攝像機能看到N個座標點構成的多邊形區域的任何一個角落。

#include<iostream>
#include<cstdio>
#include<iomanip>
#include<cmath>
#include<cstdlib>
#include<cstring>
#include<map>
#include<algorithm>
#include<vector>
#include<queue>
using namespace std;
#define INF 0xfffffff
#define MAXN 275000
const double eps=1e-8;
const int maxn=105;

int dq[maxn],top,bot,pn,order[maxn],ln;
struct Point
{
    double x,y;
} p[maxn];

struct Line
{
    Point a,b;
    double angle;
} l[maxn];

int dblcmp(double k)
{
    if(fabs(k)<eps) return 0;
    return k>0?1:-1;
}

double multi(Point p0,Point p1,Point p2)
{
    return (p1.x-p0.x)*(p2.y-p0.y)-(p1.y-p0.y)*(p2.x-p0.x);
}

bool cmp(int u,int v)
{
    int d=dblcmp(l[u].angle-l[v].angle);
    if (!d) return dblcmp(multi(l[u].a,l[v].a,l[v].b))<0;//大於0取向量左半部分為半平面,小於0,取右半部分
    return d<0;
}

void getIntersect(Line l1,Line l2,Point& p)
{
    double dot1,dot2;
    dot1=multi(l2.a,l1.b,l1.a);
    dot2=multi(l1.b,l2.b,l1.a);
    p.x=(l2.a.x*dot2+l2.b.x*dot1)/(dot2+dot1);
    p.y=(l2.a.y*dot2+l2.b.y*dot1)/(dot2+dot1);
}

bool judge(Line l0,Line l1,Line l2)
{
    Point p;
    getIntersect(l1,l2,p);
    return dblcmp(multi(p,l0.a,l0.b))>0;//大於小於符號與上面cmp()中註釋處相反
}

void addLine(double x1,double y1,double x2,double y2)
{
    l[ln].a.x=x1;
    l[ln].a.y=y1;
    l[ln].b.x=x2;
    l[ln].b.y=y2;
    l[ln].angle=atan2(y2-y1,x2-x1);
    order[ln]=ln;
    ln++;
}

void halfPlaneIntersection()
{
    sort(order,order+ln,cmp);
    int j=0;
    for(int i=1; i<ln; i++)
        if(dblcmp(l[order[i]].angle-l[order[j]].angle)>0)
            order[++j]=order[i];
    ln=j+1;
    dq[0]=order[0];
    dq[1]=order[1];
    bot=0;
    top=1;
    for(int i=2; i<ln; i++)
    {
        while(bot<top&&judge(l[order[i]],l[dq[top-1]],l[dq[top]])) top--;
        while(bot<top&&judge(l[order[i]],l[dq[bot+1]],l[dq[bot]])) bot++;
        dq[++top]=order[i];
    }
    while(bot<top&&judge(l[dq[bot]],l[dq[top-1]],l[dq[top]])) top--;
    while(bot<top&&judge(l[dq[top]],l[dq[bot+1]],l[dq[bot]])) bot++;
}

bool isThereACore()
{
    if (top-bot>1) return true;
    return false;
}

int main()
{
#ifdef ONLINE_JUDGE
#else
    freopen("G:/cbx/read.txt","r",stdin);
    //freopen("G:/cbx/out.txt","w",stdout);
#endif
    while(~scanf("%d",&pn))
    {
        if(pn==0) break;
        ln=0;
        for(int i=0; i<pn; i++)
            scanf("%lf%lf",&p[i].x,&p[i].y);
        for(int i=0; i<pn-1; i++)
            addLine(p[i].x,p[i].y,p[i+1].x,p[i+1].y);
        addLine(p[pn-1].x,p[pn-1].y,p[0].x,p[0].y);
        halfPlaneIntersection();
        if(isThereACore()) printf("1\n");
        else printf("0\n");
    }
    return 0;
}


相關文章