POJ 2503-Babelfish(STL-map)

kewlgrl發表於2017-02-09

Babelfish
Time Limit: 3000MS   Memory Limit: 65536K
Total Submissions: 42442   Accepted: 18013

Description

You have just moved from Waterloo to a big city. The people here speak an incomprehensible dialect of a foreign language. Fortunately, you have a dictionary to help you understand them.

Input

Input consists of up to 100,000 dictionary entries, followed by a blank line, followed by a message of up to 100,000 words. Each dictionary entry is a line containing an English word, followed by a space and a foreign language word. No foreign word appears more than once in the dictionary. The message is a sequence of words in the foreign language, one word on each line. Each word in the input is a sequence of at most 10 lowercase letters.

Output

Output is the message translated to English, one word per line. Foreign words not in the dictionary should be translated as "eh".

Sample Input

dog ogday
cat atcay
pig igpay
froot ootfray
loops oopslay

atcay
ittenkay
oopslay

Sample Output

cat
eh
loops

Hint

Huge input and output,scanf and printf are recommended.

Source


題目意思:

有一個簡易詞典,輸入的第一個串是英語,第二個串是外來詞。

然後輸入一些外來詞,根據詞典,將其翻譯成英語。


解題思路:

使用STL中的map就很簡單,其中外來詞是關鍵字。

注意詞典輸入完畢時以空行結尾,所以可以用gets一次讀一行,再根據空格分隔;

也可以用sscanf(str,"%s%s",str1,str2);


#include<iostream>
#include<cstdio>
#include<iomanip>
#include<cmath>
#include<cstdlib>
#include<cstring>
#include <map>
#include<algorithm>
using namespace std;

map<string,string> m;

int main()
{
    char str[15],str1[15],str2[15];//原串和分割後的兩個串
    string s;
    while(gets(str)&&str[0]!='\0')
    {
        memset(str1,'\0',sizeof(str1));
        memset(str2,'\0',sizeof(str2));
        int i,j,cnt=0;
        for(i=0; i<strlen(str); ++i)
        {
            if(str[i]==' ') break;//根據空格分隔兩個字串
            else str1[i]=str[i];//第一個字串
        }
        for(j=i+1; j<strlen(str); ++j)
            str2[cnt++]=str[j];//第二個字串
        m[str2]=str1;//第二個字串是關鍵字,存入map
    }
    while(cin>>s)
    {
        if(m[s].size()) cout<<m[s]<<endl;//如果存在則對應大小不為0
        else cout<<"eh"<<endl;//不存在
    }
    return 0;
}


相關文章