POJ - 1125 Stockbroker Grapevine(Java)

Cymbals發表於2018-03-15

Stockbrokers are known to overreact to rumours. You have been contracted to develop a method of spreading disinformation amongst the stockbrokers to give your employer the tactical edge in the stock market. For maximum effect, you have to spread the rumours in the fastest possible way.

Unfortunately for you, stockbrokers only trust information coming from their “Trusted sources” This means you have to take into account the structure of their contacts when starting a rumour. It takes a certain amount of time for a specific stockbroker to pass the rumour on to each of his colleagues. Your task will be to write a program that tells you which stockbroker to choose as your starting point for the rumour, as well as the time it will take for the rumour to spread throughout the stockbroker community. This duration is measured as the time needed for the last person to receive the information.
Input
Your program will input data for different sets of stockbrokers. Each set starts with a line with the number of stockbrokers. Following this is a line for each stockbroker which contains the number of people who they have contact with, who these people are, and the time taken for them to pass the message to each person. The format of each stockbroker line is as follows: The line starts with the number of contacts (n), followed by n pairs of integers, one pair for each contact. Each pair lists first a number referring to the contact (e.g. a ‘1’ means person number one in the set), followed by the time in minutes taken to pass a message to that person. There are no special punctuation symbols or spacing rules.

Each person is numbered 1 through to the number of stockbrokers. The time taken to pass the message on will be between 1 and 10 minutes (inclusive), and the number of contacts will range between 0 and one less than the number of stockbrokers. The number of stockbrokers will range from 1 to 100. The input is terminated by a set of stockbrokers containing 0 (zero) people.

Output
For each set of data, your program must output a single line containing the person who results in the fastest message transmission, and how long before the last person will receive any given message after you give it to this person, measured in integer minutes.
It is possible that your program will receive a network of connections that excludes some persons, i.e. some people may be unreachable. If your program detects such a broken network, simply output the message “disjoint”. Note that the time taken to pass the message from person A to person B is not necessarily the same as the time taken to pass it from B to A, if such transmission is possible at all.
Sample Input
3
2 2 4 3 5
2 1 2 3 6
2 1 2 2 2
5
3 4 4 2 8 5 3
1 5 8
4 1 6 4 10 2 7 5 2
0
2 2 5 1 5
0
Sample Output
3 2
3 10

超簡易題意:
輸出一名滿足下列條件的經紀人編號:

1、能聯絡到其他所有經紀人

2、聯絡速度最快(最短路)

再輸出這位經紀人聯絡最慢那一位的編號。

因為要求任意兩點間的最短路,所以用佛洛依德演算法,一口氣生成所有最短路,然後按題意篩選。具體看程式碼註釋吧。
ac程式碼:

public class Main {
    static int[][] dis = new int[105][105];
    static final int INF = 100000;

    public static void main(String[] args) {
        Scanner reader = new Scanner(System.in);
        int n = reader.nextInt();
        while (n != 0) {
            for (int i = 0; i < 100; i++) {
                Arrays.fill(dis[i], INF);
            }
            for (int i = 0; i < n; i++) {
                int know = reader.nextInt();
                for (int j = 0; j < know; j++) {
                    dis[i][reader.nextInt() - 1] = reader.nextInt();
                }
            }
            System.out.println(floyd(n));
            n = reader.nextInt();
        }
    }

    public static String floyd(int n) {
        for (int k = 0; k < n; k++) {
            for (int i = 0; i < n; i++) {
                for (int j = 0; j < n; j++) {
                    boolean cantGoThrough = i == j || dis[i][k] == INF || dis[k][j] == INF;
                    if (cantGoThrough) {
                        continue;
                    }
                    dis[i][j] = Math.min(dis[i][j], dis[i][k] + dis[k][j]);
                }
            }
        }
        // 開始篩選
        int key = 0, ans = INF;
        for (int i = 0; i < n; i++) {
            int max = 0;
            for (int j = 0; j < n; j++) {
                if (i != j && dis[i][j] > max) {// 如果不能傳播到所有人,自然會記錄到一個INF,自動無視
                    max = dis[i][j];
                }
            }
            // System.out.println(max);
            if (max < ans) {// 最大值都小了,其他的不用比了,選最大值最小那個記錄下來
                ans = max;
                key = i;
            }
        }
        return ans == INF ? "disjoint" : (key + 1) + " " + ans;
    }
}

相關文章