POJ 1408-Fishnet(計算幾何-根據交點求多邊形面積)

kewlgrl發表於2017-02-05

Fishnet
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 2225   Accepted: 1401

Description

A fisherman named Etadokah awoke in a very small island. He could see calm, beautiful and blue sea around the island. The previous night he had encountered a terrible storm and had reached this uninhabited island. Some wrecks of his ship were spread around him. He found a square wood-frame and a long thread among the wrecks. He had to survive in this island until someone came and saved him. 

In order to catch fish, he began to make a kind of fishnet by cutting the long thread into short threads and fixing them at pegs on the square wood-frame. He wanted to know the sizes of the meshes of the fishnet to see whether he could catch small fish as well as large ones. 

The wood frame is perfectly square with four thin edges on meter long: a bottom edge, a top edge, a left edge, and a right edge. There are n pegs on each edge, and thus there are 4n pegs in total. The positions of pegs are represented by their (x,y)-coordinates. Those of an example case with n=2 are depicted in figures below. The position of the ith peg on the bottom edge is represented by (ai,0). That on the top edge, on the left edge and on the right edge are represented by (bi,1), (0,ci) and (1,di), respectively. The long thread is cut into 2n threads with appropriate lengths. The threads are strained between (ai,0) and (bi,1),and between (0,ci) and (1,di) (i=1,...,n). 

You should write a program that reports the size of the largest mesh among the (n+1)2 meshes of the fishnet made by fixing the threads at the pegs. You may assume that the thread he found is long enough to make the fishnet and the wood-frame is thin enough for neglecting its thickness. 
 

Input

The input consists of multiple sub-problems followed by a line containing a zero that indicates the end of input. Each sub-problem is given in the following format. 

a1 a2 ... an 
b1 b2 ... bn 
c1 c2 ... cn 
d1 d2 ... dn 
you may assume 0 < n <= 30, 0 < ai,bi,ci,di < 1

Output

For each sub-problem, the size of the largest mesh should be printed followed by a new line. Each value should be represented by 6 digits after the decimal point, and it may not have an error greater than 0.000001.

Sample Input

2
0.2000000 0.6000000
0.3000000 0.8000000
0.1000000 0.5000000
0.5000000 0.6000000
2
0.3333330 0.6666670
0.3333330 0.6666670
0.3333330 0.6666670
0.3333330 0.6666670
4
0.2000000 0.4000000 0.6000000 0.8000000
0.1000000 0.5000000 0.6000000 0.9000000
0.2000000 0.4000000 0.6000000 0.8000000
0.1000000 0.5000000 0.6000000 0.9000000
2
0.5138701 0.9476283
0.1717362 0.1757412
0.3086521 0.7022313
0.2264312 0.5345343
1
0.4000000
0.6000000
0.3000000
0.5000000
0

Sample Output

0.215657
0.111112
0.078923
0.279223
0.348958

Source


題目意思:

有一個1×1的木質方格,邊框上有釘子,下上左右分別標記為abcd,分別給出這四個方向的N個釘子的座標ai、bi、ci和di,則其座標分別是(ai,0)(bi,1),(0,ci)和(1,di)。

將對應的ai和bi、ci和di位置上的釘子用網線連起來,編織成一個漁網,求漁網中被網線分割成的四邊形網眼的最大面積。


解題思路:

求出網線之間形成的交點座標,用二維陣列儲存起來,然後列舉每個四邊形的四個頂點,計算其面積。


#include<iostream>
#include<cstdio>
#include<iomanip>
#include<cmath>
using namespace std;
const int INF=1e9;
const int MAXN=40;
const double eps=1e-3;

struct point
{
    double x,y;
} ;
point a[MAXN], b[MAXN], c[MAXN], d[MAXN];
double det(double x1,double y1,double x2,double y2)
{
    return x1*y2-x2*y1;
}
double cir(point A,point B,point C,point D)//計算 AB x CD
{
    return det(B.x-A.x, B.y-A.y, D.x-C.x, D.y-C.y);
}
double Area(point A,point B,point C,point D)
{
    return fabs(0.5*cir(A,B,A,C))+fabs(0.5*cir(A,B,A,D));
}
point intersection(point A,point B,point C,point D)//求AB與CD的交點
{
    point p;
    double area1=cir(A,B,A,C);
    double area2=cir(A,B,A,D);
    p.x=(area2*C.x-area1*D.x)/(area2-area1);//交點計算公式
    p.y=(area2*C.y-area1*D.y)/(area2-area1);
    return p;
}

int main()
{
#ifdef ONLINE_JUDGE
#else
    freopen("F:/cb/read.txt","r",stdin);
    //freopen("F:/cb/out.txt","w",stdout);
#endif
    ios::sync_with_stdio(false);
    cin.tie(0);
    int n;
    a[0].x=a[0].y=b[0].x=b[0].y=c[0].x=c[0].y=d[0].x=d[0].y=0;
    point p[MAXN][MAXN];//(n+2)*(n+2)個交點
    while(cin>>n&&n)
    {
        p[0][0].x=p[0][0].y=0;
        p[0][n+1].x=1,p[0][n+1].y=0;
        p[n+1][0].x=0,p[n+1][0].y=1;
        p[n+1][n+1].x=p[n+1][n+1].y=1;
        double ans=-1;//面積
        for(int i=0; i<4; ++i)
            for(int j=1; j<=n; ++j)
            {
                double t;
                cin>>t;
                switch(i)
                {
                case 0:
                    a[j].x=t;
                    a[j].y=0;
                    p[0][j].x=t;
                    p[0][j].y=0;
                    break;
                case 1:
                    b[j].x=t;
                    b[j].y=1;
                    p[n+1][j].x=t;
                    p[n+1][j].y=1;
                    break;
                case 2:
                    c[j].x=0;
                    c[j].y=t;
                    p[j][0].x=0;
                    p[j][0].y=t;
                    break;
                case 3:
                    d[j].x=1;
                    d[j].y=t;
                    p[j][n+1].x=1;
                    p[j][n+1].y=t;
                    break;
                }
            }
        int k=1,l=1;
        for(int i=1; i<n+1; ++i)//計算交點
        {
            for(int j=1; j<n+1; ++j)
            {
                p[i][j]=intersection(a[k],b[k],c[l],d[l]);
                ++k;
            }
            k=1;
            ++l;
        }
        for(int i=0; i<n+1; ++i)//四個一組計算面積
        {
            for(int j=0; j<n+1; ++j)
            {
                /*cout<<i<<" "<<j<<" 點="<<"("<<p[i][j].x<<","<<p[i][j].y<<") ";
                cout<<"("<<p[i][j+1].x<<","<<p[i][j+1].y<<") ";
                cout<<"("<<p[i+1][j].x<<","<<p[i+1][j].y<<") ";
                cout<<"("<<p[i+1][j+1].x<<","<<p[i+1][j+1].y<<") "<<endl;*/
                //double ar=Area(p[i][j],p[i][j+1],p[i+1][j],p[i+1][j+1]);
                double ar=Area(p[i][j],p[i+1][j+1],p[i+1][j],p[i][j+1]);
                //cout<<ar<<endl;
                if(ar>ans) ans=ar;
            }
        }
        //cout<<"答案:";
        cout<<fixed<<setprecision(6)<<ans<<endl;
    }
    return 0;
}
/*
2
0.2000000 0.6000000
0.3000000 0.8000000
0.1000000 0.5000000
0.5000000 0.6000000
2
0.3333330 0.6666670
0.3333330 0.6666670
0.3333330 0.6666670
0.3333330 0.6666670
4
0.2000000 0.4000000 0.6000000 0.8000000
0.1000000 0.5000000 0.6000000 0.9000000
0.2000000 0.4000000 0.6000000 0.8000000
0.1000000 0.5000000 0.6000000 0.9000000
2
0.5138701 0.9476283
0.1717362 0.1757412
0.3086521 0.7022313
0.2264312 0.5345343
1
0.4000000
0.6000000
0.3000000
0.5000000
0
*/


相關文章