1114 Family Property (25分)

baixiaofei567發表於2020-11-09

This time, you are supposed to help us collect the data for family-owned property. Given each person’s family members, and the estate(房產)info under his/her own name, we need to know the size of each family, and the average area and number of sets of their real estate.

Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N (≤1000). Then N lines follow, each gives the infomation of a person who owns estate in the format:

ID Father Mother k Child
​1
​​ ⋯Child
​k
​​ M
​estate
​​ Area

where ID is a unique 4-digit identification number for each person; Father and Mother are the ID’s of this person’s parents (if a parent has passed away, -1 will be given instead); k (0≤k≤5) is the number of children of this person; Child
​i
​​ 's are the ID’s of his/her children; M
​estate
​​ is the total number of sets of the real estate under his/her name; and Area is the total area of his/her estate.

Output Specification:
For each case, first print in a line the number of families (all the people that are related directly or indirectly are considered in the same family). Then output the family info in the format:

ID M AVG
​sets
​​ AVG
​area
​​

where ID is the smallest ID in the family; M is the total number of family members; AVG
​sets
​​ is the average number of sets of their real estate; and AVG
​area
​​ is the average area. The average numbers must be accurate up to 3 decimal places. The families must be given in descending order of their average areas, and in ascending order of the ID’s if there is a tie.

Sample Input:
10
6666 5551 5552 1 7777 1 100
1234 5678 9012 1 0002 2 300
8888 -1 -1 0 1 1000
2468 0001 0004 1 2222 1 500
7777 6666 -1 0 2 300
3721 -1 -1 1 2333 2 150
9012 -1 -1 3 1236 1235 1234 1 100
1235 5678 9012 0 1 50
2222 1236 2468 2 6661 6662 1 300
2333 -1 3721 3 6661 6662 6663 1 100
Sample Output:
3
8888 1 1.000 1000.000
0001 15 0.600 100.000
5551 4 0.750 100.000

並查集,不熟練,但是會熟練的,這裡的合併,是將根結點大的合併到根結點小的,因為最後輸出的是集合中最小的那個結點,所以我們不妨將最小的這個結點直接設為根結點。
如果父母還健在,就把它們分別和兒子所在的塊union,如果有孩子,把孩子也和自己合併。最後遍歷結點陣列,定義id為當前結點的塊的根結點int id = findFather(data[i].id);,將其id設為id,其餘均賦值並將flag設為true,這樣就知道這個是根結點了。再次遍歷,如果這個結點被訪問過了(輸入的父母孩子和當前結點均設為已訪問),那麼當前結點所在塊的根結點的people++,用於求當前塊人數,cnt用來記錄總人數,如果當前結點的flag為true,cnt++。記錄集合數
最後將根結點的num/people,area也是,記得將num1.0再除people,一定要1,0!!並強制轉換為double

#include<iostream>
#include<algorithm>
#include<cstdio>
using namespace std;
const int maxn = 10010;
struct DATA{
    int id, fa, mo, num, area;
    int child[10];
}data[1005];
struct node{
    int id, people = 0;
    double number = 0.0, area = 0.0;
    bool flag = false;//看是否為根結點
}ans[maxn];
int father[maxn];
bool vis[maxn] = {false};
void init(){
    for(int i = 0; i < maxn; i++){
        father[i] = i;
    }
}

bool cmp(node a, node b){
    if(a.area != b.area) return a.area>b.area;
    else return a.id < b.id;
}

int findFather(int v){
    int a = v;
    while(v != father[v]){
        v = father[v];
    }
    //路徑壓縮
    while(a!=father[a]){
        int f = father[a];
        father[a] = v;
        a = f;
    }
    return v;
}

void Union(int a, int b){
    int faA = findFather(a);
    int faB = findFather(b);
    if(faA < faB){
        father[faB] = faA;
    }
    else{
        father[faA] = faB;
    }
}

int main(){
    int n, k, cnt = 0;
    cin>>n;
    init();
    for(int i = 0; i < n; i++){
        cin>>data[i].id>>data[i].fa>>data[i].mo>>k;
        vis[data[i].id] = true;
        if(data[i].fa != -1){
            vis[data[i].fa] = true;
            Union(data[i].id,data[i].fa);
        }
        if(data[i].mo != -1){
            vis[data[i].mo] = true;
            Union(data[i].id, data[i].mo);
        }
        for(int j = 0; j < k; j++){
            cin>>data[i].child[j];
            Union(data[i].id, data[i].child[j]);
            vis[data[i].child[j]] = true;
        }
        cin>>data[i].num>>data[i].area;
    }
    for(int i = 0; i < n; i++){
        int id = findFather(data[i].id);
        ans[id].id = id;
        ans[id].number += data[i].num;
        ans[id].area += data[i].area;
        ans[id].flag = true;
    }
    for(int i = 0; i < maxn; i++){
        if(vis[i] == true){
            ans[findFather(i)].people++;
        }
        if(ans[i].flag == true){
            cnt++;
        }
    }
    for(int i = 0; i < maxn; i++){
        if(ans[i].flag == true){
            ans[i].number = (double)(ans[i].number * 1.0/ ans[i].people);
            ans[i].area = (double)(ans[i].area * 1.0/ ans[i].people);
        }
    }
    sort(ans, ans + maxn,cmp);
    cout<<cnt<<endl;
    for(int i = 0; i < cnt; i++){
        printf("%04d %d %.3f %.3f\n", ans[i].id, ans[i].people, ans[i].number, ans[i].area);
    }
    return 0;
}

相關文章