PTA Hashing (25分)

0k-ok發表於2020-09-24

我們活在這個世界上,沒有一件事是虛空而生的,你站在光裡背後就會有陰影,站在黑暗裡心中也可能有光明,所以我們必須得承認,有一部分人或許喪失了初心,但也有一部分人用生命來踐行諾言。

The task of this problem is simple: insert a sequence of distinct positive integers into a hash table, and output the positions of the input numbers. The hash function is defined to be H(key)=key%TSize where TSize is the maximum size of the hash table. Quadratic probing (with positive increments only) is used to solve the collisions.

Note that the table size is better to be prime. If the maximum size given by the user is not prime, you must re-define the table size to be the smallest prime number which is larger than the size given by the user.

Input Specification:

Each input file contains one test case. For each case, the first line contains two positive numbers: MSize (≤10​4​​) and N (≤MSize) which are the user-defined table size and the number of input numbers, respectively. Then N distinct positive integers are given in the next line. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the corresponding positions (index starts from 0) of the input numbers in one line. All the numbers in a line are separated by a space, and there must be no extra space at the end of the line. In case it is impossible to insert the number, print "-" instead.

Sample Input:

4 4
10 6 4 15

Sample Output:

0 1 4 -
#include <iostream>
#include <cstdio>
#include <algorithm>
#include <string>
#include <cstring>
#include <cstdlib>
#include <cmath>
#include <stack>
#include <queue>
#include <set>
#include <map>
#include <vector>
#include <ctime>
#include <cctype>
#include <bitset>
#include <utility>
#include <sstream>
#include <complex>
#include <iomanip>
#include <numeric>
#include<unordered_set>
#include <climits>//INT_MAX
#define PP pair<ll,int>
#define inf 0x3f3f3f3f
#define llinf 0x3f3f3f3f3f3f3f3fll
#define dinf 1000000000000.0
#define PI 3.1415926
//#include<bits/stdc++.h>
typedef long long ll;
using namespace std;
const int N=1e5+10;
const int maxn=120000;
bool isPrime(int n)
{
    if(n<=1)
        return false;
    int sqr=(int)sqrt(1.0*n);
    for(int i=2; i<=sqr; i++)
    {
        if(n%i==0)
            return false;
    }
    return true;
}

bool hs[maxn];
int main()
{
    int n,T,a;
    scanf("%d%d",&T,&n);
    while(isPrime(T)==false)
        T++;
    for(int i=0; i<n; i++)
    {
        scanf("%d",&a);
        int m=a%T;
        if(hs[m]==false)
        {
            hs[m]=true;
            if(i==0)
                printf("%d",m);
            else \
                printf(" %d",m);
        }
        else
        {
            int ls;
            for(ls=1; ls<T; ls++)
            {
                m=(a+ls*ls)%T;
                if(hs[m]==false)
                {
                    hs[m]=true;
                    if(i==0)
                        printf("%d",m);
                    else
                        printf(" %d",m);
                    break;
                }
            }
            if(ls>=T)
            {
                if(i>0)
                    printf(" ");
                printf("-");
            }
        }
    }
    return 0;
}