7-1 Hashing

rebloom000發表於2020-11-30

The task of this problem is simple: insert a sequence of distinct positive integers into a hash table, and output the positions of the input numbers. The hash function is defined to be H(key)=key%TSize where TSize is the maximum size of the hash table. Quadratic probing (with positive increments only) is used to solve the collisions.

Note that the table size is better to be prime. If the maximum size given by the user is not prime, you must re-define the table size to be the smallest prime number which is larger than the size given by the user.

Input Specification:

Each input file contains one test case. For each case, the first line contains two positive numbers: MSize (<=104) and N (<=MSize) which are the user-defined table size and the number of input numbers, respectively. Then N distinct positive integers are given in the next line. All the numbers in a line are separated by a space. MSize (<=104) and N (<=MSize) which are the user-defined table size and the number of input numbers, respectively. Then N distinct positive integers are given in the next line. All the numbers in a line are separated by a space.​​) and N (MSize) which are the user-defined table size and the number of input numbers, respectively. Then N distinct positive integers are given in the next line. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the corresponding positions (index starts from 0) of the input numbers in one line. All the numbers in a line are separated by a space, and there must be no extra space at the end of the line. In case it is impossible to insert the number, print "-" instead.

Sample Input:

4 4
10 6 4 15
 

Sample Output:

0 1 4 -

 

題目大意:

給出大小為m的雜湊表長,以及n個數。要求將元素按讀入的順序插入至雜湊表中,並用二次探測法解決衝突問題,如果衝突無法解決則輸出 -

解決思路:

先解決表長不為素數的問題,再解決雜湊表的插入問題,二次探測法的公式為 (key + step * step) % size,該題最後會卡一下空格輸出的格式

程式碼實現:

 

#include<iostream>
using namespace std;
int n,size;
int temp;
bool judge[10100]={false};
void cubeinsert(int key)
{
    for(int i = 0; i < size; i ++)
    {
        int index = (key + i * i) % size;//二次探測法公式(key + step * step) % size 
        if(!judge[index])
        {
            cout<<index;
            judge[index] = true;
            return;
        }
    }
    cout<<'-';
}
bool isprime(int n)//判斷素數 
{
    if (n <= 1) return false;
    for (int i = 2; i * i <= n; i++)
        if (n % i == 0) return false;
    return true;
}
int main()
{
    cin>>size>>n;
    while(!isprime(size))
    {
        size++;
    }
    
    for(int i = 0; i < n; i ++)
    {
        cin>>temp;
        if(i != 0) cout << ' ';//測試卡輸出格式 
        cubeinsert(temp);
    }
    return 0;
}