HDU 6055 Regular polygon(幾何)
Regular polygon
Time Limit: 3000/1000 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others)Total Submission(s): 643 Accepted Submission(s): 232
Problem Description
On a two-dimensional plane, give you n integer points. Your task is to figure out how many different regular polygon these points can make.
Input
The input file consists of several test cases. Each case the first line is a numbers N (N <= 500). The next N lines ,each line contain two number Xi and Yi(-100 <= xi,yi <= 100), means the points’ position.(the data assures no two points share the same position.)
Output
For each case, output a number means how many different regular polygon these points can make.
Sample Input
4
0 0
0 1
1 0
1 1
6
0 0
0 1
1 0
1 1
2 0
2 1
Sample Output
1
2
Source
題意:
給你n個點,問你可以確定幾個不同的正多邊形。
POINT:
一頓瞎猜成功知道了只有正方形的情況。之後反正只有500個點,就遍歷2個點,可以確定2個正方形,看看另外2對頂點存不存在就行了,別忘記/8去重。
因為mp陣列來記錄地圖上有沒有點,並且把負點都加了200來變正,那麼點在判斷的時候其實會超出地圖一倍。
比如(0,300)和(300,300) 你得判斷(300,600)-(0,600)和(0,0)-(300,0)有沒有點,所以陣列要開大,乾脆開一千。還有就是點為負的情況去掉,也會陣列越界。上面的點都處理變正了,不需要考慮負點。
#include <iostream>
#include <string.h>
#include <stdio.h>
#include <algorithm>
using namespace std;
#define LL long long
int mp[1000][1000];
int x[555],y[555];
int main()
{
int n;
while(~scanf("%d",&n))
{
memset(mp,0,sizeof mp);
for(int i=1;i<=n;i++)
{
scanf("%d %d",&x[i],&y[i]);
x[i]+=200,y[i]+=200;
mp[x[i]][y[i]]=1;
}
int ans=0;
for(int i=1;i<=n;i++)
{
for(int j=1;j<=n;j++)
{
if(i==j) continue;
int a=x[i]-x[j];
int b=y[i]-y[j];
if(x[i]-b>=0&&y[i]+a>=0&&x[j]-b>=0&&y[j]+a>=0&&mp[x[i]-b][y[i]+a]&&mp[x[j]-b][y[j]+a])
{
ans++;
}
if(x[i]+b>=0&&y[i]-a>=0&&x[j]+b>=0&&y[j]-a>=0&&mp[x[i]+b][y[i]-a]&&mp[x[j]+b][y[j]-a])
ans++;
}
}
printf("%d\n",ans/8);
}
}
相關文章
- Points on Cycle (hdu1700,幾何)
- hdu5365 簡單幾何問題
- hdu 2150- Pipe-解析幾何
- HDU3400 Line belt (幾何+三分)
- HDU5972Regular Number(ShiftAnd演算法 bitset)演算法
- 第九章第九題(幾何:正多邊形)(Geometry: regular polygons)Go
- HDU 4643 GSM(計算幾何求線段的中垂線)
- HDU 1077Catching Fish(簡單計算幾何)
- HDU 4606 Occupy Cities (計算幾何+最短路+最小路徑覆蓋)
- 平面幾何
- 計算幾何
- polygonGo
- 計算幾何 —— 二維幾何基礎 —— 距離度量方法
- 計算幾何:模板
- CF18A 幾何
- 美國人的幾何
- 計算幾何模板
- 幾何本質初步猜想
- [筆記] 計算幾何筆記
- 寵物醫療,成色幾何?
- 二維幾何基礎
- 異構幾何問題
- 幾道經典的幾何作圖趣題
- three.js 幾何體(二)JS
- three.js 幾何體(三)JS
- 幾何庫從零開始
- 【計算幾何】向量表示
- geogebra幾何畫圖工具用法
- 【總結】計算幾何模板
- 二維幾何常用運算
- 二維計算幾何模板
- IV.4 代數幾何
- 【計算幾何】線段相交
- Kite(幾何+鏡面對稱)
- 三維計算幾何模板
- 貴國上網速度幾何?
- IT認證價值幾何 (轉)
- Something about 計算幾何