POJ1330 Nearest Common Ancestors【LCA】
Nearest Common Ancestors
Time Limit: 1000MS | Memory Limit: 10000K | |
Total Submissions: 34625 | Accepted: 17570 |
Description
A rooted tree is a well-known data structure in computer science and engineering. An example is shown below:
In the figure, each node is labeled with an integer from {1, 2,...,16}. Node 8 is the root of the tree. Node x is an ancestor of node y if node x is in the path between the root and node y. For example, node 4 is an ancestor of node 16. Node 10 is also an ancestor of node 16. As a matter of fact, nodes 8, 4, 10, and 16 are the ancestors of node 16. Remember that a node is an ancestor of itself. Nodes 8, 4, 6, and 7 are the ancestors of node 7. A node x is called a common ancestor of two different nodes y and z if node x is an ancestor of node y and an ancestor of node z. Thus, nodes 8 and 4 are the common ancestors of nodes 16 and 7. A node x is called the nearest common ancestor of nodes y and z if x is a common ancestor of y and z and nearest to y and z among their common ancestors. Hence, the nearest common ancestor of nodes 16 and 7 is node 4. Node 4 is nearer to nodes 16 and 7 than node 8 is.
For other examples, the nearest common ancestor of nodes 2 and 3 is node 10, the nearest common ancestor of nodes 6 and 13 is node 8, and the nearest common ancestor of nodes 4 and 12 is node 4. In the last example, if y is an ancestor of z, then the nearest common ancestor of y and z is y.
Write a program that finds the nearest common ancestor of two distinct nodes in a tree.
Input
The input consists of T test cases. The number of test cases (T) is given in the first line of the input file. Each test case starts with a line containing an integer N , the number of nodes in a tree, 2<=N<=10,000. The nodes are labeled with integers 1, 2,..., N. Each of the next N -1 lines contains a pair of integers that represent an edge --the first integer is the parent node of the second integer. Note that a tree with N nodes has exactly N - 1 edges. The last line of each test case contains two distinct integers whose nearest common ancestor is to be computed.
Output
Print exactly one line for each test case. The line should contain the integer that is the nearest common ancestor.
Sample Input
2
16
1 14
8 5
10 16
5 9
4 6
8 4
4 10
1 13
6 15
10 11
6 7
10 2
16 3
8 1
16 12
16 7
5
2 3
3 4
3 1
1 5
3 5
Sample Output
4
3
Source
題目連結:POJ1330 Nearest Common Ancestors
題解:LCA模板題,使用倍增演算法
AC的C++程式碼:
#include<iostream>
#include<vector>
#include<cstring>
using namespace std;
const int N=10010;
vector<int>g[N];
int depth[N],f[N][20],in[N];
void dfs(int rt,int fa)
{
depth[rt]=depth[fa]+1;
f[rt][0]=fa;
for(int i=1;i<20;i++)
f[rt][i]=f[f[rt][i-1]][i-1];
for(int i=0;i<g[rt].size();i++)
dfs(g[rt][i],rt);
}
int LCA(int a,int b)
{
if(depth[a]>depth[b])
swap(a,b);
for(int i=19;i>=0;i--)
if(depth[b]-(1<<i)>=depth[a])
b=f[b][i];
if(a==b)
return a;
for(int i=19;i>=0;i--)
if(f[b][i]!=f[a][i])
b=f[b][i],a=f[a][i];
return f[b][0];
}
int main()
{
int t,n,a,b;
scanf("%d",&t);
while(t--){
scanf("%d",&n);
for(int i=0;i<=n;i++)
g[i].clear();
memset(in,0,sizeof(in));
for(int i=1;i<n;i++){
scanf("%d%d",&a,&b);
g[a].push_back(b);
in[b]++;//b的入度加一
}
depth[0]=-1;
int rt=0;
//尋找根結點
for(int i=1;i<=n&&rt==0;i++)
if(!in[i])
rt=i;
dfs(rt,0);
scanf("%d%d",&a,&b);
printf("%d\n",LCA(a,b));
}
return 0;
}
相關文章
- HDU 1330 Nearest Common Ancestors(求兩個點的最近公共祖先)REST
- lca
- 求 LCA
- D - K-th NearestREST
- RMQ求lcaMQ
- DFN 序求 LCA
- LCA + 樹上倍增
- LCA(倍增與Tarjan)
- LCA學習筆記筆記
- 樹上公共祖先(LCA)
- Lca相關演算法演算法
- 淺談倍增法求解LCA
- [LeetCode] 2192. All Ancestors of a Node in a Directed Acyclic GraphLeetCode
- Amazon OA2 K-Nearest Point C++RESTC++
- common.cssCSS
- Lowest Common Ancestor
- Note - ICML24 - Approximate Nearest Neighbor Search with Window FiltersAPPRESTFilter
- 貨車運輸(LCA+最大生成樹)
- C# Common utilsC#
- Common Probability Distributions
- Common LISP Hints 中文Lisp
- 【Lca 倍增】codeforces 832D Misha, Grisha and Underground
- 機器學習演算法(三):K近鄰(k-nearest neighbors)初探機器學習演算法REST
- 2.3.2 Application Common ObjectsAPPObject
- IRRATIONAL APPEAL TO COMMON BELIEFAPP
- Common threads: Awk by examplethread
- Html language common symbolic entitiesHTMLSymbol
- B-A Bit More Common
- ch13_common_class
- 2024牛客多校第一場A Bit Common & A Bit More Common
- 【Lca 線上st演算法】hdu 2586 How far away ?演算法
- 2.2.5 Overview of Common and Local Objects in a CDBViewObject
- 2.2.2 Overview of Common and Local Users in a CDBView
- Leetcode Longest Common PrefixLeetCode
- common-IO.jar相關JAR
- [LeetCode]Longest Common PrefixLeetCode
- apache common-io.jar FileUtilsApacheJAR
- 小議 Common Lisp 的名字Lisp