Game with points(數學,難度中)

御史大夫發表於2012-08-29

Game with points

Time Limit:500MS   

Memory Limit:65536KB    64bit IO Format:%I64d & %I64u

Description

Recently Petya has discovered new game with points. Rules of the game are quite simple. First, there is onlyone point A0 with coordinates (0, 0). Then Petya have to draw N another points. Points must be drawnconsequently and each new point must be connected with exactly one of the previous points by a segment.Let's decribe the game process more formally. At the i-th step Petya chooses the position of the point Ai (notnecessarily with integer coordinates). Than he chooses one of the previously drawn points in order to connect it with thepoint Ai. Lets call this point B. The following conditions must be held: Point Ai must not coincide with any of the previous points.Point Ai must not lie on the previously drawn segments.Segment AiB must not have common points with previously drawn segments, except possibly the point B.Segment AiB must not cover any of the previous points, except the point B. Length of the segment AiB must not exceed 1. After drawing each point Petya computes two values.The largest number of segments which share a common point. The largest euclid distance between some pair of points. After each step Petya gains the score which is equal to the product of these values.Find out which is the maximal score Petya can gain after the whole game.

Input

Input contains single integer number N (0 ≤ N ≤ 1000).

Output

Output the maximal score that Petya can gain. Your answer must be accurate up to 10-3.

Sample Input

sample input
sample output
2
5.000

sample input
sample output
4
20.000


設第i步具有公共點的最大線段數為m, 點間距離最大值為l,則該步所新增的線段要麼使m加1,要麼使l加1,這樣才能確保最終答案最大。當滿足

(m + 1) * l >= m * (l + 1)時,使m加1更優,否則使l加1更優。注意特殊情況i = 2,因為在這一步能使m和l同時加1.

此題輸出小數有誤導成分,實際上答案是整數,再化做小數輸出即可。

AC CODE:

//Memory: 935 KB 		Time: 31 MS
//Language: GNU CPP (MinGW, GCC 4) 		Result: Accepted

#include <iostream>
#include <string>
#include <cstdio>
#include <cmath>
#include <cstring>
#include <algorithm>
#include <map>
#define LL long long
#define MAXI 2147483647
#define MAXL 9223372036854775807
#define eps (1e-8)
#define dg(i) cout << "*" << i << endl;
using namespace std;

int main()
{
    int l, m, n;
    double ans;
    while(scanf("%d", &n) != EOF)
    {
        if(!n) ans = 0.0;
        else if(n == 1) ans = 1.0;
        else if(n == 2) ans = 5.0;
        else
        {
            ans = 5.0;
            l = 2;
            m = 2;
            while(n-- > 2)
            {
                if(l <= m)
                {
                    l++;
                    ans += (1.0 * l * m);
                }
                else
                {
                    m++;
                    ans += (1.0 * l * m);
                }
            }
        }
        printf("%.3lf\n", ans);
    }
    return 0;
}



相關文章