Binary Tree Traversals(HDU1710)二叉樹的簡單應用

尋找&星空の孩子發表於2013-08-23

 

Binary Tree Traversals

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 2681    Accepted Submission(s): 1178

Problem Description
A binary tree is a finite set of vertices that is either empty or consists of a root r and two disjoint binary trees called the left and right subtrees. There are three most important ways in which the vertices of a binary tree can be systematically traversed or ordered. They are preorder, inorder and postorder. Let T be a binary tree with root r and subtrees T1,T2.
In a preorder traversal of the vertices of T, we visit the root r followed by visiting the vertices of T1 in preorder, then the vertices of T2 in preorder.
In an inorder traversal of the vertices of T, we visit the vertices of T1 in inorder, then the root r, followed by the vertices of T2 in inorder.
In a postorder traversal of the vertices of T, we visit the vertices of T1 in postorder, then the vertices of T2 in postorder and finally we visit r.
Now you are given the preorder sequence and inorder sequence of a certain binary tree. Try to find out its postorder sequence.
 
Input
The input contains several test cases. The first line of each test case contains a single integer n (1<=n<=1000), the number of vertices of the binary tree. Followed by two lines, respectively indicating the preorder sequence and inorder sequence. You can assume they are always correspond to a exclusive binary tree.
 
Output
For each test case print a single line specifying the corresponding postorder sequence.
 
Sample Input
9
1 2 4 7 3 5 8 9 6
4 7 2 1 8 5 9 3 6
 
Sample Output
7 4 2 8 9 5 6 3 1
 
 
#include<iostream>
using namespace std;

typedef struct tree// typedef定義型別,這裡為結構體型;
{
    int num;
    struct tree *left;
    struct tree *right;
};

tree *root;

tree *creat(int *a,int *b,int n)//用前序歷遍和中序歷遍得到的資料,確定唯一樹

{
    tree *k;
    int i;
    for(i=0;i<n;i++)
    {
        if(*a==b[i])//當在中序歷遍中找到了根節點後
        {
            k=(tree *)malloc(sizeof(tree));
            k->num=b[i];
            k->left=creat(a+1,b,i);//中序歷遍中在根節點左邊的都是左子樹上的
            k->right=creat(a+i+1,b+i+1,n-i-1);//在根節點右邊的,都是右子樹上的,右子樹需要從i+1開始;
            //因為他的根的左半隻有i個數,加上自己所有就要把指標指向a+i+1的地方了,

//            printf("%d\n",h->data );直接輸出於是後續,不過要判斷不成立的情況,所以不行不過我想可以用陣列裝起來;
            return k;
        }
    }
    return NULL;//沒有對應找到的話,就返回NULL
}

void houxu(tree *h)
{
    if(h!=NULL)
    {
        houxu(h->left);
        houxu(h->right);
        if(root==h)//後序歷遍最後歷遍根節點
        {
            printf("%d\n",h->num);
        }
        else
        {
            printf("%d ",h->num);
        }
    }
}
int main()
{
    tree *h;
    int a[1001],b[1001],n,i;
    while(scanf("%d",&n)!=EOF&&n)
    {
        for(i=0;i<n;i++)
            scanf("%d",&a[i]);
        for(i=0;i<n;i++)
            scanf("%d",&b[i]);
        h=creat(a,b,n);
        root=h;
        houxu(h);
    }
}

 

 

相關文章