POJ 3253Fence Repair(哈夫曼&優先佇列)

果7發表於2014-01-10
Fence Repair
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 21545   Accepted: 6875

Description

Farmer John wants to repair a small length of the fence around the pasture. He measures the fence and finds that he needs N (1 ≤ N ≤ 20,000) planks of wood, each having some integer length Li (1 ≤ Li ≤ 50,000) units. He then purchases a single long board just long enough to saw into the N planks (i.e., whose length is the sum of the lengths Li). FJ is ignoring the "kerf", the extra length lost to sawdust when a sawcut is made; you should ignore it, too.

FJ sadly realizes that he doesn't own a saw with which to cut the wood, so he mosies over to Farmer Don's Farm with this long board and politely asks if he may borrow a saw.

Farmer Don, a closet capitalist, doesn't lend FJ a saw but instead offers to charge Farmer John for each of the N-1 cuts in the plank. The charge to cut a piece of wood is exactly equal to its length. Cutting a plank of length 21 costs 21 cents.

Farmer Don then lets Farmer John decide the order and locations to cut the plank. Help Farmer John determine the minimum amount of money he can spend to create the N planks. FJ knows that he can cut the board in various different orders which will result in different charges since the resulting intermediate planks are of different lengths.

Input

Line 1: One integer N, the number of planks 
Lines 2..N+1: Each line contains a single integer describing the length of a needed plank

Output

Line 1: One integer: the minimum amount of money he must spend to make N-1 cuts

Sample Input

3
8
5
8

Sample Output

34

Hint

He wants to cut a board of length 21 into pieces of lengths 8, 5, and 8. 
The original board measures 8+5+8=21. The first cut will cost 21, and should be used to cut the board into pieces measuring 13 and 8. The second cut will cost 13, and should be used to cut the 13 into 8 and 5. This would cost 21+13=34. If the 21 was cut into 16 and 5 instead, the second cut would cost 16 for a total of 37 (which is more than 34).


題目意思是給你一根很長的木頭,把他切成n塊,每塊的長度為a[i],切長度為x的木塊需要花費x元,問最小花費。如上所示,很顯然初始長度為8+5+8=21,那麼先把它切成16和5的花費21元,然後再切16切成8+8需要花費16元,所以總共花費為37元。但是如果先切成8和13就會花費21+13=34元。利用哈夫曼思想,每次找兩個最小的然後變成一個數插入到陣列中去。開始使用的是模擬排序,但是時間500ms左右。

後面使用優先佇列做的,時間瞬間降到了16MS,優先佇列定義為priority_queue <ll,vector<ll>,greater<ll> > mq;  使用less是遞減的,greater遞增。

模擬AC程式碼:
#include<iostream>
#include<cmath>
#include<cstdio>
#include<algorithm>
using namespace std;
long long a[20002];

int main()
{
    int n,i;
    long long res,tmp;
    while (cin >> n)
    {
        for (i = 0; i < n; i++)
            scanf("%I64d",&a[i]);

        int t = 0;

        res=0;
        sort(a,a+n);

        while (t < n)
        {
            tmp = a[t] + a[t+1];
            if(t==n-2)
            {
                res += tmp;
                break;
            }

            for(i=t+2;i<n;i++)
            {
                if(tmp < a[i])      //插入
                {
                    a[i-1] = tmp;
                    break;
                }
                else
                    a[i-1] = a[i];
            }
            if(i==n)
                a[i-1] = tmp;
            t++;
            res += tmp;
        }
        cout << res << endl;
    }
    return 0;
}

/*
3
8
5
8
*/

//380K  454MS


使用STL priority_queue程式碼:
#include<iostream>
#include<cmath>
#include<cstdio>
#include<algorithm>
#include<queue>
typedef long long ll;
using namespace std;

priority_queue <ll,vector<ll>,greater<ll> > mq;

int main()
{
    int n,i;
    ll res,tmp,p1,p2;
    while(cin>>n)
    {
        res=0;
        while(!mq.empty())   //先清空
            mq.pop();
        while(n--)
        {
            scanf("%lld",&tmp);
            mq.push(tmp);
        }

        while(mq.size()>1)
        {
            p1=mq.top(); mq.pop();
            p2=mq.top(); mq.pop();
            res+=p1+p2;
            mq.push(p1+p2);
        }
        cout<<res<<endl;
    }
    return 0;
}

//508K 16MS


相關文章