POJ 3253Fence Repair(哈夫曼&優先佇列)
Time Limit: 2000MS | Memory Limit: 65536K | |
Total Submissions: 21545 | Accepted: 6875 |
Description
Farmer John wants to repair a small length of the fence around the pasture. He measures the fence and finds that he needs N (1 ≤ N ≤ 20,000) planks of wood, each having some integer length Li (1 ≤ Li ≤ 50,000) units. He then purchases a single long board just long enough to saw into the N planks (i.e., whose length is the sum of the lengths Li). FJ is ignoring the "kerf", the extra length lost to sawdust when a sawcut is made; you should ignore it, too.
FJ sadly realizes that he doesn't own a saw with which to cut the wood, so he mosies over to Farmer Don's Farm with this long board and politely asks if he may borrow a saw.
Farmer Don, a closet capitalist, doesn't lend FJ a saw but instead offers to charge Farmer John for each of the N-1 cuts in the plank. The charge to cut a piece of wood is exactly equal to its length. Cutting a plank of length 21 costs 21 cents.
Farmer Don then lets Farmer John decide the order and locations to cut the plank. Help Farmer John determine the minimum amount of money he can spend to create the N planks. FJ knows that he can cut the board in various different orders which will result in different charges since the resulting intermediate planks are of different lengths.
Input
Lines 2..N+1: Each line contains a single integer describing the length of a needed plank
Output
Sample Input
3 8 5 8
Sample Output
34
Hint
The original board measures 8+5+8=21. The first cut will cost 21, and should be used to cut the board into pieces measuring 13 and 8. The second cut will cost 13, and should be used to cut the 13 into 8 and 5. This would cost 21+13=34. If the 21 was cut into 16 and 5 instead, the second cut would cost 16 for a total of 37 (which is more than 34).
#include<iostream>
#include<cmath>
#include<cstdio>
#include<algorithm>
using namespace std;
long long a[20002];
int main()
{
int n,i;
long long res,tmp;
while (cin >> n)
{
for (i = 0; i < n; i++)
scanf("%I64d",&a[i]);
int t = 0;
res=0;
sort(a,a+n);
while (t < n)
{
tmp = a[t] + a[t+1];
if(t==n-2)
{
res += tmp;
break;
}
for(i=t+2;i<n;i++)
{
if(tmp < a[i]) //插入
{
a[i-1] = tmp;
break;
}
else
a[i-1] = a[i];
}
if(i==n)
a[i-1] = tmp;
t++;
res += tmp;
}
cout << res << endl;
}
return 0;
}
/*
3
8
5
8
*/
//380K 454MS
#include<iostream>
#include<cmath>
#include<cstdio>
#include<algorithm>
#include<queue>
typedef long long ll;
using namespace std;
priority_queue <ll,vector<ll>,greater<ll> > mq;
int main()
{
int n,i;
ll res,tmp,p1,p2;
while(cin>>n)
{
res=0;
while(!mq.empty()) //先清空
mq.pop();
while(n--)
{
scanf("%lld",&tmp);
mq.push(tmp);
}
while(mq.size()>1)
{
p1=mq.top(); mq.pop();
p2=mq.top(); mq.pop();
res+=p1+p2;
mq.push(p1+p2);
}
cout<<res<<endl;
}
return 0;
}
//508K 16MS
相關文章
- 哈夫曼樹
- 哈夫曼編碼
- Sunscreen POJ - 3614(防曬油) 貪心-優先佇列佇列
- 哈夫曼樹及其編碼
- Java 樹結構實際應用 二(哈夫曼樹和哈夫曼編碼)Java
- PHP優先佇列PHP佇列
- 6.6 哈夫曼樹及其應用
- 哈夫曼樹學習筆記筆記
- 最優二叉樹(哈夫曼樹)Java實現二叉樹Java
- 優先佇列的學習記錄--例題:Expedition(POJ2431)佇列
- 資料結構與演算法——赫夫曼樹(哈夫曼樹)資料結構演算法
- STL 優先佇列 用法佇列
- 淺談優先佇列佇列
- 堆與優先佇列佇列
- 哈夫曼編碼 —— Lisp 與 Python 實現LispPython
- Task A2 哈夫曼樹的應用
- 優先佇列和堆排序佇列排序
- 01揹包優先佇列優化佇列優化
- 資料結構-哈夫曼樹(python實現)資料結構Python
- 重學資料結構之哈夫曼樹資料結構
- 哈夫曼樹及其應用(檔案壓縮)
- 佇列 優先順序佇列 python 程式碼實現佇列Python
- 棧,佇列,優先順序佇列簡單介面使用佇列
- 【資料結構X.11】程式碼實現 哈夫曼樹的建立,建立,構造,實現哈夫曼編碼資料結構
- NO GAME NO LIFE(優先佇列/最小堆)GAM佇列
- 優先佇列的比較器佇列
- 封裝優先順序佇列封裝佇列
- 資料結構與演算法:哈夫曼樹資料結構演算法
- 曼哈頓距離與切比雪夫距離
- 三、資料結構演算法-棧、佇列、優先佇列、雙端佇列資料結構演算法佇列
- STL優先佇列最小堆最大堆佇列
- leetcode621——優先佇列的思路LeetCode佇列
- 從哈夫曼編碼中我們學到了什麼?
- 演算法面試(三) 優先佇列演算法面試佇列
- 二叉堆實現優先佇列佇列
- 手擼優先佇列——二叉堆佇列
- C++ STL 優先佇列 (priority_queue)C++佇列
- .NET 6 優先佇列 PriorityQueue 實現分析佇列
- Java優先順序佇列DelayedWorkQueue原理分析Java佇列