POJ 1026-Cipher(置換群-K次置換 取模迴圈節長度)
Cipher
Time Limit: 1000MS | Memory Limit: 10000K | |
Total Submissions: 21967 | Accepted: 6059 |
Description
Bob and Alice started to use a brand-new encoding scheme. Surprisingly it is not a Public Key Cryptosystem, but their encoding and decoding is based on secret keys. They chose the secret key at their last meeting in Philadelphia on February 16th, 1996. They
chose as a secret key a sequence of n distinct integers, a1 ; . . .; an, greater than zero and less or equal to n. The encoding is based on the following principle. The message is written down below the key, so that characters in the message and numbers in
the key are correspondingly aligned. Character in the message at the position i is written in the encoded message at the position ai, where ai is the corresponding number in the key. And then the encoded message is encoded in the same way. This process is
repeated k times. After kth encoding they exchange their message.
The length of the message is always less or equal than n. If the message is shorter than n, then spaces are added to the end of the message to get the message with the length n.
Help Alice and Bob and write program which reads the key and then a sequence of pairs consisting of k and message to be encoded k times and produces a list of encoded messages.
The length of the message is always less or equal than n. If the message is shorter than n, then spaces are added to the end of the message to get the message with the length n.
Help Alice and Bob and write program which reads the key and then a sequence of pairs consisting of k and message to be encoded k times and produces a list of encoded messages.
Input
The input file consists of several blocks. Each block has a number 0 < n <= 200 in the first line. The next line contains a sequence of n numbers pairwise distinct and each greater than zero and less or equal than n. Next lines contain integer number k and
one message of ascii characters separated by one space. The lines are ended with eol, this eol does not belong to the message. The block ends with the separate line with the number 0. After the last block there is in separate line the number 0.
Output
Output is divided into blocks corresponding to the input blocks. Each block contains the encoded input messages in the same order as in input file. Each encoded message in the output file has the lenght n. After each block there is one empty line.
Sample Input
10 4 5 3 7 2 8 1 6 10 9 1 Hello Bob 1995 CERC 0 0
Sample Output
BolHeol b C RCE
Source
題目意思:
給出N個數構成的置換群,長度不大於N的字串,輸出K次置換之後的串。
解題思路:
據(巨巨)說:
發現每個字母經過一定次數變換
後一定會回到原來的位置,且這個變換次數肯定不會大於N。
所以我們可以找出每個迴圈節的長度,用K對其取模之後再計算置換的情況。
#include<iostream>
#include<cstdio>
#include<iomanip>
#include<cmath>
#include<cstdlib>
#include<cstring>
#include<map>
#include<algorithm>
#include<vector>
#include<queue>
using namespace std;
#define INF 0xfffffff
#define MAXN 300
int a[MAXN],cir[MAXN];
char c[MAXN],ans[MAXN];
int main()
{
#ifdef ONLINE_JUDGE
#else
freopen("G:/cbx/read.txt","r",stdin);
//freopen("G:/cbx/out.txt","w",stdout);
#endif
int n;
while(~scanf("%d",&n))
{
if(n==0) break;
memset(c,'\0',sizeof(c));
memset(ans,'\0',sizeof(ans));
memset(cir,0,sizeof(cir));
for(int i=0; i<n; ++i)
{
scanf("%d",&a[i]);
--a[i];
}
int cnt=0,res=1;//注意本身就算是1個
for(int i=0; i<n; ++i)
{
int temp=a[i];
while(1)//求置換群中每個迴圈節長度
{
if(i==temp)
{
cir[cnt++]=res;
res=1;
break;
}
++res;
temp=a[temp];
}
}
int k;
while(~scanf("%d",&k))
{
if(k==0) break;
char ch=getchar();//先吃掉k後面的空格
gets(c);
int len=strlen(c);
while(len<=n) c[len++]=' ';//長度不足要用空格補齊
c[len]='\0';
//cout<<"/"<<c<<"/"<<endl;
for(int i=0; i<n; i++)
{
int temp=k%cir[i];
int t=i;
while(temp--)//交換
t=a[t];
ans[t]=c[i];
}
//cout<<strlen(ans)<<endl;
printf("%s\n",ans);
}
printf("\n");//PE的罪惡之源…哭/(ㄒoㄒ)/~~
}
return 0;
}
相關文章
- 置換,群論初探
- 抽象代數-06-置換群抽象
- 置換矩陣矩陣
- 置換密碼密碼
- 迴圈群
- 關於一類最優解存在長度為 $k$ 的迴圈節的問題
- 利用單向迴圈連結串列結構實現如下記憶體頁置換策略CLOCK Algorithm記憶體Go
- 如何透過裝置基站獲取裝置經緯度
- 【作業系統】頁面置換演算法(最佳置換演算法)(C語言實現)作業系統演算法C語言
- InnoDB Buffer Pool改進LRU頁面置換
- O(1)緯度減少迴圈次數
- 物聯網路卡能不能更換裝置
- python3迴圈中如何加入換行符?Python
- Linux裝置節點Linux
- 使用世界變換的逆轉置矩陣對法線進行變換矩陣
- Profinet轉ModbusTCP:從站裝置轉換與整合案例TCP
- 頁面置換演算法你學會了嗎?演算法
- Sellcell:2021年電子裝置以舊換新趨勢
- AD模數轉換&DA數模轉換
- 蘋果更新iPad mini 6售後政策:只更換電池 不再更換整個裝置蘋果iPad
- 網路裝置配置與管理————17、網路地址轉換NAT
- 2020年虛擬轉換器博覽會必看的裝置
- 第八小節 for 迴圈
- 實用的 IEC61850 裝置裝置模擬器
- Vue mock模擬獲取資料 迴圈遍歷檢視VueMock
- 裝置CSV檔案匯入,型別轉換加try...catch...型別
- LRU(Least Recently Used)最近未使用置換演算法--c實現AST演算法
- 溫度轉換
- for 迴圈的一些細節
- PHP 獲取裝置型別PHP型別
- 順序表應用4:元素位置互換之逆置演算法演算法
- 裝置元件檔案轉換為EVE-NG環境的支援元件元件
- 交換機通過Loopback Detection檢測(裝置所在網路環路)OOP
- 2K解析度下1070TI更換2080S能有多大提升,值得換嗎?
- 經緯度轉換
- win10怎麼切換主機正面背面音響_win10切換前後置音響的方法Win10
- 車置寶&脈脈:職場人群換車需求分析報告(附下載)
- 『忘了再學』Shell基礎 — 21、變數的測試與內容置換變數
- 最近最久未使用(LRU)頁面置換演算法 C語言實現演算法C語言