POJ 1026-Cipher(置換群-K次置換 取模迴圈節長度)

kewlgrl發表於2017-04-18
Cipher
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 21967   Accepted: 6059

Description

Bob and Alice started to use a brand-new encoding scheme. Surprisingly it is not a Public Key Cryptosystem, but their encoding and decoding is based on secret keys. They chose the secret key at their last meeting in Philadelphia on February 16th, 1996. They chose as a secret key a sequence of n distinct integers, a1 ; . . .; an, greater than zero and less or equal to n. The encoding is based on the following principle. The message is written down below the key, so that characters in the message and numbers in the key are correspondingly aligned. Character in the message at the position i is written in the encoded message at the position ai, where ai is the corresponding number in the key. And then the encoded message is encoded in the same way. This process is repeated k times. After kth encoding they exchange their message. 

The length of the message is always less or equal than n. If the message is shorter than n, then spaces are added to the end of the message to get the message with the length n. 

Help Alice and Bob and write program which reads the key and then a sequence of pairs consisting of k and message to be encoded k times and produces a list of encoded messages. 

Input

The input file consists of several blocks. Each block has a number 0 < n <= 200 in the first line. The next line contains a sequence of n numbers pairwise distinct and each greater than zero and less or equal than n. Next lines contain integer number k and one message of ascii characters separated by one space. The lines are ended with eol, this eol does not belong to the message. The block ends with the separate line with the number 0. After the last block there is in separate line the number 0.

Output

Output is divided into blocks corresponding to the input blocks. Each block contains the encoded input messages in the same order as in input file. Each encoded message in the output file has the lenght n. After each block there is one empty line.

Sample Input

10
4 5 3 7 2 8 1 6 10 9
1 Hello Bob
1995 CERC
0
0

Sample Output

BolHeol  b
C RCE

Source

Central Europe 1995


題目意思:

給出N個數構成的置換群,長度不大於N的字串,輸出K次置換之後的串。


解題思路:

據(巨巨)說:

發現每個字母經過一定次數變換
後一定會回到原來的位置,且這個變換次數肯定不會大於N。

所以我們可以找出每個迴圈節的長度,用K對其取模之後再計算置換的情況。


#include<iostream>
#include<cstdio>
#include<iomanip>
#include<cmath>
#include<cstdlib>
#include<cstring>
#include<map>
#include<algorithm>
#include<vector>
#include<queue>
using namespace std;
#define INF 0xfffffff
#define MAXN 300
int a[MAXN],cir[MAXN];
char c[MAXN],ans[MAXN];
int main()
{
#ifdef ONLINE_JUDGE
#else
    freopen("G:/cbx/read.txt","r",stdin);
    //freopen("G:/cbx/out.txt","w",stdout);
#endif
    int n;
    while(~scanf("%d",&n))
    {
        if(n==0) break;
        memset(c,'\0',sizeof(c));
        memset(ans,'\0',sizeof(ans));
        memset(cir,0,sizeof(cir));
        for(int i=0; i<n; ++i)
        {
            scanf("%d",&a[i]);
            --a[i];
        }
        int cnt=0,res=1;//注意本身就算是1個
        for(int i=0; i<n; ++i)
        {
            int temp=a[i];
            while(1)//求置換群中每個迴圈節長度
            {
                if(i==temp)
                {
                    cir[cnt++]=res;
                    res=1;
                    break;
                }
                ++res;
                temp=a[temp];
            }
        }
        int k;
        while(~scanf("%d",&k))
        {
            if(k==0) break;
            char ch=getchar();//先吃掉k後面的空格
            gets(c);
            int len=strlen(c);
            while(len<=n) c[len++]=' ';//長度不足要用空格補齊
            c[len]='\0';
            //cout<<"/"<<c<<"/"<<endl;
            for(int i=0; i<n; i++)
            {
                int temp=k%cir[i];
                int t=i;
                while(temp--)//交換
                    t=a[t];
                ans[t]=c[i];
            }
            //cout<<strlen(ans)<<endl;
            printf("%s\n",ans);
        }
        printf("\n");//PE的罪惡之源…哭/(ㄒoㄒ)/~~
    }
    return 0;
}


相關文章