1128 N Queens Puzzle (20分)

baixiaofei567發表於2020-11-12

The “eight queens puzzle” is the problem of placing eight chess queens on an 8×8 chessboard so that no two queens threaten each other. Thus, a solution requires that no two queens share the same row, column, or diagonal. The eight queens puzzle is an example of the more general N queens problem of placing N non-attacking queens on an N×N chessboard. (From Wikipedia - “Eight queens puzzle”.)

Here you are NOT asked to solve the puzzles. Instead, you are supposed to judge whether or not a given configuration of the chessboard is a solution. To simplify the representation of a chessboard, let us assume that no two queens will be placed in the same column. Then a configuration can be represented by a simple integer sequence (Q
​1
​​ ,Q
​2
​​ ,⋯,Q
​N
​​ ), where Q
​i
​​ is the row number of the queen in the i-th column. For example, Figure 1 can be represented by (4, 6, 8, 2, 7, 1, 3, 5) and it is indeed a solution to the 8 queens puzzle; while Figure 2 can be represented by (4, 6, 7, 2, 8, 1, 9, 5, 3) and is NOT a 9 queens’ solution.

在這裡插入圖片描述
在這裡插入圖片描述

Figure 1 Figure 2
Input Specification:
Each input file contains several test cases. The first line gives an integer K (1<K≤200). Then K lines follow, each gives a configuration in the format "N Q
​1
​​ Q
​2
​​ … Q
​N
​​ ", where 4≤N≤1000 and it is guaranteed that 1≤Q
​i
​​ ≤N for all i=1,⋯,N. The numbers are separated by spaces.

Output Specification:
For each configuration, if it is a solution to the N queens problem, print YES in a line; or NO if not.

Sample Input:
4
8 4 6 8 2 7 1 3 5
9 4 6 7 2 8 1 9 5 3
6 1 5 2 6 4 3
5 1 3 5 2 4
Sample Output:
YES
NO
NO
YES

每次詢問,就定義一個陣列來存放棋子位置,寫一個judge函式,判斷是否在同一斜行。
兩層for迴圈遍歷,判斷當前點和後面的點是否在同一斜行且是否相等,如果在同一斜行or相等(同一行),就false

#include<iostream>
#include<vector>
#include<cmath>
using namespace std;

bool judge(int x1, int y1, int x2, int y2){
    if(abs(x1 - x2) != abs(y1 - y2)){
        return true;
    }
    return false;
}

int main(){
    int n, k;
    vector<int> v;
    cin>>n;
    for(int i = 0; i < n; i++){
        cin>>k;
        v.resize(k+2);
        v.clear();
        for(int j = 1; j <= k; j++){
            cin>>v[j];
        }
        bool noFlag = true;
        for(int j = 1; j <= k; j++){
            for(int m = j +1; m <= k; m++){
                if(judge(j,v[j],m,v[m]) == false || v[j] == v[m]){
                    noFlag = false;
                    break;
                }
            }
        }
        if(noFlag == false) cout<<"NO\n";
        else cout<<"YES\n";
    }
    return 0;
}

相關文章