kuangbin——QS Network - Preliminary Round
Sunny Cup 2003 - Preliminary Round
April 20th, 12:00 - 17:00
Problem E: QS Network
In the planet w-503 of galaxy cgb, there is a kind of intelligent creature named QS. QScommunicate with each other via networks. If two QS want to get connected, they need to buy two network adapters (one for each QS) and a segment of network cable. Please be advised that ONE NETWORK ADAPTER CAN ONLY BE USED IN A SINGLE CONNECTION.(ie. if a QS want to setup four connections, it needs to buy four adapters). In the procedure of communication, a QS broadcasts its message to all the QS it is connected with, the group of QS who receive the message broadcast the message to all the QS they connected with, the procedure repeats until all the QS’s have received the message.
A sample is shown below:
A sample QS network, and QS A want to send a message.
Step 1. QS A sends message to QS B and QS C;
Step 2. QS B sends message to QS A ; QS C sends message to QS A and QS D;
Step 3. the procedure terminates because all the QS received the message.
Each QS has its favorate brand of network adapters and always buys the brand in all of its connections. Also the distance between QS vary. Given the price of each QS’s favorate brand of network adapters and the price of cable between each pair of QS, your task is to write a program to determine the minimum cost to setup a QS network.
Input
The 1st line of the input contains an integer t which indicates the number of data sets.
From the second line there are t data sets.
In a single data set,the 1st line contains an interger n which indicates the number of QS.
The 2nd line contains n integers, indicating the price of each QS’s favorate network adapter.
In the 3rd line to the n+2th line contain a matrix indicating the price of cable between ecah pair of QS.
Constrains:
all the integers in the input are non-negative and not more than 1000.
Output
for each data set,output the minimum cost in a line. NO extra empty lines needed.
Sample Input
1
3
10 20 30
0 100 200
100 0 300
200 300 0
Sample Output
370
最小生成樹的模板題,注意邊長 = 線路花費 + 頂點路由器花費
#include <iostream>
#include <algorithm>
#include <cstring>
using namespace std;
const int N = 1e3 + 10;
struct edge { int x, y, w; }e[N * N];
int num[N + 1], sum, f[N + 1], n, book, cost;
bool cmp(edge a, edge b) { return a.w < b.w; }
int getf(int x) { return (f[x] == x) ? x : f[x] = getf(f[x]); }
int merge(int a, int b)
{
int f1 = getf(a), f2 = getf(b);
if (f1 == f2) return 0;
else { f[f2] = f1; return 1; }
}
void dij()
{
sort(e, e + book, cmp);
int cnt = 0;
for (int i = 0; i < book; i++)
{
if (e[i].x == e[i].y) continue;
if (merge(e[i].x, e[i].y))
{
cost += e[i].w;
cnt++;
}
if (cnt == n - 1) break;
}
}
int main()
{
int times;
cin >> times;
while (times--)
{
for (int i = 0; i <= N; i++) f[i] = i;
memset(e, 0, sizeof(e));
memset(num, 0, sizeof(num));
book = 0, cost = 0;
cin >> n;
for (int i = 0; i < n; i++) { int temp; cin >> temp; num[i] = temp; }
for(int i = 0; i < n; i++)
for (int j = 0; j < n; j++)
{
e[book].x = i; e[book].y = j; cin >> e[book].w;
e[book].w = e[book].w + num[i] + num[j];
book++;
}
dij();
cout << cost << endl;
}
return 0;
}
相關文章
- POJ - 2236 Wireless Network (kuangbin - 簡單搜尋)
- [20190530]sqlplus preliminary connection.txtSQL
- npm qs 模組(中文)NPM
- 跟著糰子學SAP QM-主檢驗特性(MIC)的基本設定 QS21/QS22/QS23
- Large language models as surrogate models in evolutionary algorithms: A preliminary studyGo
- kuangbin——Hamburgers(二分答案)
- 2020年QS世界大學排名
- 專題五 並查集【Kuangbin】並查集
- QS:2023年QS世界大學排名出爐 北大、清華創歷史新高 全球前20
- Networking POJ - 1287(kuangbin最小生成樹)
- kuangbin 數學訓練一 IP Checking
- 專題六 最小生成樹【Kuangbin】
- 專題十七 AC自動機【Kuangbin】
- 2023年QS世界大學學科排名
- 專題十六 KMP & 擴充套件KMP & Manacher【Kuangbin】KMP套件
- QS:新冠病毒與高等教育的未來
- SAP QM初階之事務程式碼QS28
- Simple Neural Network
- Set介面_network
- GJ Round
- SAP中QM檢驗特性清單功能QS28
- <node.js學習筆記(3)>url,fs,qs,cryptoNode.js筆記
- [kuangbin帶你飛]專題五 並查集 題解並查集
- docker network之 noneDockerNone
- The Network Diagram on the PVE system
- Network sniffing and identity authenticationIDE
- Siamese network總結
- Network(POJ-1144)
- POJ 1861 Network (Kruskal)
- Network Embedding_LINE
- network xxx was found but has incorrect label com.docker.compose.network set to "xxx"Docker
- Codeforces Round 955
- Codeforces Round 977 (Div. 2, based on COMPFEST 16 - Final Round)
- The Network Program Log Two (Scapy)
- ch21_network_programming
- 5g-network-slicing
- kubernetes CNI(Container Network Inferface)AI
- 什麼是Phala Network?