Networking POJ - 1287(kuangbin最小生成樹)
You are assigned to design network connections between certain points in a wide area. You are given a set of points in the area, and a set of possible routes for the cables that may connect pairs of points. For each possible route between two points, you are given the length of the cable that is needed to connect the points over that route. Note that there may exist many possible routes between two given points. It is assumed that the given possible routes connect (directly or indirectly) each two points in the area.
Your task is to design the network for the area, so that there is a connection (direct or indirect) between every two points (i.e., all the points are interconnected, but not necessarily by a direct cable), and that the total length of the used cable is minimal.
Input
The input file consists of a number of data sets. Each data set defines one required network. The first line of the set contains two integers: the first defines the number P of the given points, and the second the number R of given routes between the points. The following R lines define the given routes between the points, each giving three integer numbers: the first two numbers identify the points, and the third gives the length of the route. The numbers are separated with white spaces. A data set giving only one number P=0 denotes the end of the input. The data sets are separated with an empty line.
The maximal number of points is 50. The maximal length of a given route is 100. The number of possible routes is unlimited. The nodes are identified with integers between 1 and P (inclusive). The routes between two points i and j may be given as i j or as j i.
Output
For each data set, print one number on a separate line that gives the total length of the cable used for the entire designed network.
Sample Input
1 0
2 3
1 2 37
2 1 17
1 2 68
3 7
1 2 19
2 3 11
3 1 7
1 3 5
2 3 89
3 1 91
1 2 32
5 7
1 2 5
2 3 7
2 4 8
4 5 11
3 5 10
1 5 6
4 2 12
0
Sample Output
0
17
16
26
最小生成樹模板
#include <iostream>
#include <algorithm>
#include <cstring>
using namespace std;
struct edgs { int a, b, w; }e[5000];
int f[5000], n, m;
bool cmp(edgs a, edgs b) { return a.w < b.w; }
int getf(int a)
{
if (a == f[a]) return f[a];
f[a] = getf(f[a]);
return f[a];
}
int merge(int a, int b)
{
int t1 = getf(a), t2 = getf(b);
if (t1 != t2)
{
f[t2] = t1;
return 1;
}
return 0;
}
int main()
{
ios::sync_with_stdio(false), cin.tie(0), cout.tie(0);
while (cin >> n && n)
{
memset(e, 0, sizeof(e));
int sum = 0, cnt = 0;
cin >> m;
for (int i = 1; i <= m; i++) cin >> e[i].a >> e[i].b >> e[i].w;
for (int i = 1; i <= n; i++) f[i] = i;
sort(e + 1, e + m + 1, cmp); //注意這裡的排序範圍
for (int i = 1; i <= m; i++)
{
if (merge(e[i].a, e[i].b))
{
cnt++;
sum += e[i].w;
}
if (cnt == n - 1) break;
}
cout << sum << endl;
}
return 0;
}
相關文章
- 專題六 最小生成樹【Kuangbin】
- 最小生成樹
- 【模板】最小生成樹
- 最小度限制生成樹
- 【模板】最小生成樹-kruskal
- 最小生成樹專項
- 圖論 最小生成樹圖論
- 圖的最小生成樹
- 【圖論】最小生成樹圖論
- POJ - 2236 Wireless Network (kuangbin - 簡單搜尋)
- Prim 最小生成樹 圖解圖解
- prim 樸素 最小生成樹
- 最小生成樹學習筆記筆記
- 最小生成樹的演算法演算法
- 最小生成樹__Kurskal演算法演算法
- 最小生成樹__Prim演算法演算法
- 演算法-圖論-最小生成樹演算法圖論
- NOIP 複習題之最小生成樹
- 【演算法學習】最小生成樹演算法
- 一些“最小生成樹”板題
- 最小生成樹之 Prim 演算法演算法
- UVA1379——Slim Span (最小生成樹)
- bzoj3545: [ONTAK2010]Peaks(主席樹+最小生成樹)
- 最小生成樹(MinSpanTree)的Kruskal演算法演算法
- CH 6201 走廊潑水節 最小生成樹
- C135 線段樹分治 P5631 最小mex生成樹
- cf888G. Xor-MST(Boruvka最小生成樹 Trie樹)
- Boruvka求最小生成樹(菠蘿演算法)演算法
- 圖論中的最小生成樹演算法圖論演算法
- 淺談三種求最小生成樹的方法
- 北極通訊網路——最小生成樹kruskal
- 最小生成樹prim普里姆演算法演算法
- bzoj3714: [PA2014]Kuglarz(最小生成樹)
- 圖論之帶權圖「最小生成樹之Prim」圖論
- 前端必會演算法 - 最小生成樹問題前端演算法
- HDU-1875-暢通工程再續(最小生成樹)
- 最小生成樹-Prim演算法和Kruskal演算法演算法
- 最小生成樹:Kruskal演算法和Prim演算法演算法