HDU 4951 Multiplication table(找規律)

畫船聽雨發表於2014-08-26
題目大意:給出一個p進位制數的乘法表,第i行第j組(一組有兩個數)表示i*j結果的高位和低位,例如樣例中:
4
2 3 1 1 3 2 1 0
1 1 1 1 1 1 1 1
3 2 1 1 3 1 1 2
1 0 1 1 1 2 1 3
0
第二行的“2 3”表示0*0的結果為23,後面的“1 1”表示0*1的結果為11,依此類推。

寫出九九乘法表之後你會發現當i*j中,所有高位的數字為0-i-1。然後就可以雜湊統計出來高位有多少個,那這一行就是幾了啊。

Multiplication table

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 736    Accepted Submission(s): 335


Problem Description
Teacher Mai has a multiplication table in base p.

For example, the following is a multiplication table in base 4:

* 0 1 2 3
0 00 00 00 00
1 00 01 02 03
2 00 02 10 12
3 00 03 12 21


But a naughty kid maps numbers 0..p-1 into another permutation and shuffle the multiplication table.

For example Teacher Mai only can see:

1*1=11 1*3=11 1*2=11 1*0=11
3*1=11 3*3=13 3*2=12 3*0=10
2*1=11 2*3=12 2*2=31 2*0=32
0*1=11 0*3=10 0*2=32 0*0=23


Teacher Mai wants you to recover the multiplication table. Output the permutation number 0..p-1 mapped into.

It's guaranteed the solution is unique.
 

Input
There are multiple test cases, terminated by a line "0".

For each test case, the first line contains one integer p(2<=p<=500).

In following p lines, each line contains 2*p integers.The (2*j+1)-th number x and (2*j+2)-th number y in the i-th line indicates equation i*j=xy in the shuffled multiplication table.

Warning: Large IO!
 

Output
For each case, output one line.

First output "Case #k:", where k is the case number counting from 1. The following are p integers, indicating the permutation number 0..p-1 mapped into.
 

Sample Input
4 2 3 1 1 3 2 1 0 1 1 1 1 1 1 1 1 3 2 1 1 3 1 1 2 1 0 1 1 1 2 1 3 0
 

Sample Output
Case #1: 1 3 2 0
 

Author
xudyh
 

Source
 
#include <algorithm>
#include <iostream>
#include <stdlib.h>
#include <string.h>
#include <iomanip>
#include <stdio.h>
#include <string>
#include <queue>
#include <cmath>
#include <stack>
#include <map>
#include <set>
#define eps 1e-10
///#define M 1000100
///#define LL __int64
#define LL long long
///#define INF 0x7ffffff
#define INF 0x3f3f3f3f
#define PI 3.1415926535898
#define zero(x) ((fabs(x)<eps)?0:x)

using namespace std;

const int maxn = 510;

int num[maxn];
int mp[maxn][maxn][2];
int vis[maxn];
int main()
{
    int Case = 1;
    int p;
    while(~scanf("%d",&p) && p)
    {
        for(int i = 0; i < p; i++)
            for(int j = 0; j < p; j++) scanf("%d %d",&mp[i][j][1], &mp[i][j][0]);
        for(int i = 0; i < p; i++)
        {
            int cnt = 0;
            memset(vis, 0, sizeof(vis));
            for(int j = 0; j < p; j++)
            {
                if(!vis[mp[i][j][1]])
                {
                    vis[mp[i][j][1]] = 1;
                    cnt++;
                }
            }
            if(cnt == 1)
                if(mp[i][0][0] == mp[i][1][0]) cnt = 0;
            num[cnt] = i;
        }
        printf("Case #%d: ", Case++);
        for(int i = 0; i < p-1; i++) printf("%d ",num[i]);
        printf("%d\n",num[p-1]);
    }
    return 0;
}


相關文章