poj1276 多重揹包問題(二進位制解決方案)
http://poj.org/problem?id=1276
Description
A Bank plans to install a machine for cash withdrawal. The machine is able to deliver appropriate @ bills for a requested cash amount. The machine uses exactly N distinct bill denominations, say Dk, k=1,N, and for each denomination Dk the machine has a supply
of nk bills. For example,
N=3, n1=10, D1=100, n2=4, D2=50, n3=5, D3=10
means the machine has a supply of 10 bills of @100 each, 4 bills of @50 each, and 5 bills of @10 each.
Call cash the requested amount of cash the machine should deliver and write a program that computes the maximum amount of cash less than or equal to cash that can be effectively delivered according to the available bill supply of the machine.
Notes:
@ is the symbol of the currency delivered by the machine. For instance, @ may stand for dollar, euro, pound etc.
N=3, n1=10, D1=100, n2=4, D2=50, n3=5, D3=10
means the machine has a supply of 10 bills of @100 each, 4 bills of @50 each, and 5 bills of @10 each.
Call cash the requested amount of cash the machine should deliver and write a program that computes the maximum amount of cash less than or equal to cash that can be effectively delivered according to the available bill supply of the machine.
Notes:
@ is the symbol of the currency delivered by the machine. For instance, @ may stand for dollar, euro, pound etc.
Input
The program input is from standard input. Each data set in the input stands for a particular transaction and has the format:
cash N n1 D1 n2 D2 ... nN DN
where 0 <= cash <= 100000 is the amount of cash requested, 0 <=N <= 10 is the number of bill denominations and 0 <= nk <= 1000 is the number of available bills for the Dk denomination, 1 <= Dk <= 1000, k=1,N. White spaces can occur freely between the numbers in the input. The input data are correct.
cash N n1 D1 n2 D2 ... nN DN
where 0 <= cash <= 100000 is the amount of cash requested, 0 <=N <= 10 is the number of bill denominations and 0 <= nk <= 1000 is the number of available bills for the Dk denomination, 1 <= Dk <= 1000, k=1,N. White spaces can occur freely between the numbers in the input. The input data are correct.
Output
For each set of data the program prints the result to the standard output on a separate line as shown in the examples below.
Sample Input
735 3 4 125 6 5 3 350 633 4 500 30 6 100 1 5 0 1 735 0 0 3 10 100 10 50 10 10
Sample Output
735 630 0 0
Hint
The first data set designates a transaction where the amount of cash requested is @735. The machine contains 3 bill denominations: 4 bills of @125, 6 bills of @5, and 3 bills of @350. The machine can deliver the exact amount of requested cash.
In the second case the bill supply of the machine does not fit the exact amount of cash requested. The maximum cash that can be delivered is @630. Notice that there can be several possibilities to combine the bills in the machine for matching the delivered cash.
In the third case the machine is empty and no cash is delivered. In the fourth case the amount of cash requested is @0 and, therefore, the machine delivers no cash.
題目大意:給定揹包的容量V,和n中物品,每種物品的數量、重量、價值分別為num,w,v。求揹包可以獲得的最大價值。
In the second case the bill supply of the machine does not fit the exact amount of cash requested. The maximum cash that can be delivered is @630. Notice that there can be several possibilities to combine the bills in the machine for matching the delivered cash.
In the third case the machine is empty and no cash is delivered. In the fourth case the amount of cash requested is @0 and, therefore, the machine delivers no cash.
解題思路:一道多重揹包的問題,一開始採用了以前用過的方法,結果超時了,趁機重讀《揹包九講》,豁然開朗,去年怎麼也看不懂的二進位制做法,而今看來是這麼的容易==詳見《揹包九講》
#include <stdio.h>
#include <string.h>
#include <iostream>
#include <algorithm>
using namespace std;
const int maxn=200100;
int v,n,T,c[maxn],dp[maxn];
int main()
{
while(~scanf("%d",&v))
{
scanf("%d",&T);
n=0;
memset(c,0,sizeof(c));
while(T--)
{
int x,y;
scanf("%d%d",&x,&y);
int k=0;
while(x-(1<<(k+1))+1>0)k++;
for(int i=0;i<k;i++)
{
c[++n]=y*(1<<i);
}
c[++n]=y*(x+1-(1<<k));
}
memset(dp,0,sizeof(dp));
for(int i=1;i<=n;i++)
{
for(int j=v;j>=c[i];j--)
{
dp[j]=max(dp[j],dp[j-c[i]]+c[i]);
}
}
printf("%d\n",dp[v]);
}
return 0;
}
相關文章
- 多重揹包二進位制分解思想講解
- 二進位制方式解決 power 問題
- 01揹包、完全揹包、多重揹包詳解
- 01揹包問題的解決
- C++二進位制相容問題及解決方法C++
- 多重揹包問題的單調佇列優化佇列優化
- 揹包問題(01揹包與完全揹包)
- 二維費用揹包問題
- JavaScript 揹包問題詳解JavaScript
- UVA 674 01揹包 2進位制優化 DP優化
- 進位制詳解:二進位制、八進位制和十六進位制
- 揹包問題
- git .gitignore 檔案 解決二進位制檔案衝突問題Git
- 揹包問題解題方法總結
- Windows系統上安裝pycrypto的二進位制解決方案Windows
- 負數的二進位制數問題
- Mysql二進位制包安裝MySql
- 圖解二維完全揹包問題——降維打擊圖解
- 進位制之間的轉換之“十六進位制 轉 十進位制 轉 二進位制 方案”
- ACM 揹包問題ACM
- 01揹包問題
- javascript演算法基礎之01揹包,完全揹包,多重揹包實現JavaScript演算法
- 窮舉法解決0/1揹包問題——pythonPython
- Java中關於十進位制數取反問題解決Java
- TCP 粘包 - 拆包問題及解決方案TCP
- 二進位制與二進位制運算
- 揹包問題大合集
- 二進位制修復中文亂碼的問題
- 前端axios請求二進位制資料流轉換生成PDF檔案空白問題(終極解決方案)前端iOS
- Java 之 Map 的鍵,值多重排序問題解決方案Java排序
- JavaScript 二進位制、八進位制與十六進位制JavaScript
- 從【零錢兌換】問題看01揹包和完全揹包問題
- 使用二進位制包來安裝MySQLMySql
- Go 釋出二進位制包的方法Go
- 【Redis】原始碼編譯二進位制包Redis原始碼編譯
- leetcode題解(0-1揹包問題)LeetCode
- (二進位制)
- 二進位制