BestCoder-四條邊是否能組成四邊形

kewlgrl發表於2016-04-05

CA Loves Stick

Accepts: 381
Submissions: 3204
Time Limit: 2000/1000 MS (Java/Others)
Memory Limit: 262144/262144 K (Java/Others)
Problem Description

CA loves to play with sticks.One day he receives four pieces of sticks, he wants to know these sticks can spell a quadrilateral.(What is quadrilateral? Click here:https://en.wikipedia.org/wiki/Quadrilateral)

Input

First line contains TTT denoting the number of testcases.TTT testcases follow. Each testcase contains four integers a,b,c,da,b,c,da,b,c,d in a line, denoting the length of sticks.1≤T≤1000, 0≤a,b,c,d≤263−11 \le T \le 1000,~0 \le a,b,c,d \le 2^{63}-11T1000, 0a,b,c,d2631

Output

For each testcase, if these sticks can spell a quadrilateral, output "Yes"; otherwise, output "No" (without the quotation marks).

Sample Input
2
1 1 1 1
1 1 9 2
Sample Output
Yes
No

四條邊能組成四邊形:最長邊小於其餘三條邊的和

#include<iostream>
#include<cstring>
#include<cstdio>
#include<malloc.h>
#include<algorithm>
using namespace std;

int main()
{
    int ca,i;
    scanf("%d",&ca);
    unsigned long long a[4];
    while(ca--)
    {
        for(i=0; i<4; ++i)
            cin>>a[i];
        sort(a,a+4);
        if((a[0]>a[3]-a[2]-a[1])&&a[0]!=0&&a[1]!=0&&a[2]!=0&&a[3]!=0)//最大邊大於剩下三邊之和,注意longlong相加會超長度!!還有注意邊長為0的情況!!
            printf("Yes\n");
        else printf("No\n");
    }
    return 0;
}


相關文章