ensp VRRP實驗搭建

苦逼運維小白 發表於 2020-11-21
VR

VRRP的概述

VRRP(虛擬閘道器冗餘協議)主要解決網路中因為閘道器出現故障,而導致主機不能夠訪問外網出現的問題,VRRP主要是通過在網路中多新增幾臺路由器虛擬出來一臺虛擬路由器,以此達到備份的效果,然後把主機的閘道器配置在虛擬路由器上,即是單個路由器出現了故障,虛擬路由器也能夠正常的工作。
通常在網路中也會存在一個master 主路由器以及多個slave 備份路由器,master 和 slave 的選舉:優先順序(預設100)和埠的編號(誰大誰優先順序最大)

VRRP負載分擔
這個和MSTP類似,VRRP可以將同一個網段或者不同網段的放在一個組,這樣就分出來了多個組,每一個組都是一個單獨的虛擬路由器,每一個組都設定得有對應網段的閘道器,每一個組都可以指定對應的主路由器,以及備份路由器,如一個組的主路由器為A,可能對於其他組來說,這個A就有可能為備份路由器以及主路由器。這個根據網路的結構來定。
每一個組之間都是沒有關聯的,這樣不僅實現了負載分擔,也確保了每一條鏈路上都有流量通過

VRRP搶佔模式
當master 路由器出現了故障,備份路由器會接替master的工作,如果master路由恢復了,就會啟用搶佔模式,搶佔的時間為0秒,只要一恢復,就立即進入原來的狀態 (華為裝置搶佔模式 預設是開啟的)

VRRP監視埠的功能
防止路由器上的其他埠出現故障,而導致資料不能夠及時轉發
所以一般在master路由器上開啟對應埠的監視功能,如果當檢測到埠出現故障,就會自動將本路由器的優先順序下調30,然後重新選擇主備路由器

VRRP埠狀態

  1. master (主)
  2. backup (備)
  3. initialize (初始狀態 只要在埠執行shutdown都是這個狀態)

VRRP實驗搭建

實驗要求
最短訪問路徑為優,配置單臂路由讓 PC1 和 PC2 互通,192.168.1.0/24 對應VRID 10,192.168.2.0/24 對應 VRID 20 ,AR2 為VRID 10 的 master 路由器,AR3 為 VRID 20 的 master 路由器,配置埠檢測功能,防止 埠出現故障而導致網路訪問不了。全網互通

網路拓撲圖
在這裡插入圖片描述

IP地址、單臂路由、vlan劃分、靜態路由的配置

LSW1交換機的配置

[LSW1]vlan batch 10 20    //建立vlan 10 20 
[LSW1]int g0/0/1
[LSW1-GigabitEthernet0/0/1]port link-type access 
[LSW1-GigabitEthernet0/0/1]port default vlan 10
[LSW1-GigabitEthernet0/0/1]int g0/0/2
[LSW1-GigabitEthernet0/0/2]port link-type access 
[LSW1-GigabitEthernet0/0/2]port default vlan 20
[LSW1-GigabitEthernet0/0/2]int g0/0/3
[LSW1-GigabitEthernet0/0/3]port link-type trunk 	
[LSW1-GigabitEthernet0/0/3]port trunk allow-pass vlan all 
[LSW1-GigabitEthernet0/0/3]int g0/0/4
[LSW1-GigabitEthernet0/0/4]port link-type trunk 	
[LSW1-GigabitEthernet0/0/4]port trunk allow-pass vlan all 

AR1路由器的配置

[AR1]int g0/0/0
[AR1-GigabitEthernet0/0/0]ip address 11.1.1.1 24 
[AR1-GigabitEthernet0/0/0]int g0/0/1
[AR1-GigabitEthernet0/0/1]ip address 12.1.1.1 24 
[AR1-GigabitEthernet0/0/1]q
[AR1]int LoopBack 0    //建立一個迴環介面用於測試
[AR1-LoopBack0]ip address 9.9.9.9 24
配置靜態路由,發往內網網段的
[AR1]ip route-static 192.168.1.0 24 11.1.1.2 
[AR1]ip route-static 192.168.1.0 24 12.1.1.2
[AR1]ip route-static 192.168.2.0 24 12.1.1.2
[AR1]ip route-static 192.168.2.0 24 11.1.1.2

AR2路由器的配置

[AR2]int g0/0/0
[AR2-GigabitEthernet0/0/0]ip address 11.1.1.2 24 
[AR2-GigabitEthernet0/0/0]int g0/0/2.10
單臂路由的配置
[AR2-GigabitEthernet0/0/2.10]ip address 192.168.1.100 24
[AR2-GigabitEthernet0/0/2.10]dot1q termination vid 10    //使用dot1q來封裝vlan10
[AR2-GigabitEthernet0/0/2.10]arp broadcast enable   //開啟arp 廣播 
[AR2-GigabitEthernet0/0/2.10]int g0/0/2.20
[AR2-GigabitEthernet0/0/2.20]ip address 192.168.2.100 24 	
[AR2-GigabitEthernet0/0/2.20]dot1q termination vid 20
[AR2-GigabitEthernet0/0/2.20]arp broadcast enable 
[AR2-GigabitEthernet0/0/2.20]q
[AR2]ip route-static 0.0.0.0 0.0.0.0 11.1.1.1   //配置預設路由,發往外網,因為內網存在多個網段,所有配置預設比較方便一點

AR3路由器 配置

[AR3]int g0/0/1
[AR3-GigabitEthernet0/0/1]ip address 12.1.1.2 24 
單臂路由的配置
[AR3-GigabitEthernet0/0/1]int g0/0/2.10
[AR3-GigabitEthernet0/0/2.10]ip address 192.168.1.200 24 
[AR3-GigabitEthernet0/0/2.10]dot1q termination vid 10
[AR3-GigabitEthernet0/0/2.10]arp broadcast enable 
[AR3-GigabitEthernet0/0/2.10]int g0/0/2.20
[AR3-GigabitEthernet0/0/2.20]ip address 192.168.2.200 24
[AR3-GigabitEthernet0/0/2.20]dot1q termination vid 20
[AR3-GigabitEthernet0/0/2.20]arp broadcast enable 
[AR3-GigabitEthernet0/0/2.20]q
[AR3]ip route-static 0.0.0.0 0.0.0.0 12.1.1.1 

VRRP的配置

AR2路由器的配置

[AR2]int g0/0/2.10	//進入子介面
[AR2-GigabitEthernet0/0/2.10]vrrp vrid 10 virtual-ip 192.168.1.2  //設定虛擬閘道器 閘道器IP地址為1.0網段的主機的閘道器
[AR2-GigabitEthernet0/0/2.10]vrrp vrid 10 priority 120   //設定組10 的優先順序為120 這樣VRID 10 的主路由器就是AR2了
[AR2-GigabitEthernet0/0/2.10]vrrp vrid 10 track interface g0/0/0 reduced 30  //開啟埠監測模式,如果出現故障,自動下調30
[AR2-GigabitEthernet0/0/2.10]int g0/0/2.20   //進入另外一個網段的子介面
[AR2-GigabitEthernet0/0/2.20]vrrp vrid 20 virtual-ip 192.168.2.2   //只需配置虛擬閘道器IP地址即可

AR3路由器的配置

[AR3]int g0/0/2.10  //進入子介面
[AR3-GigabitEthernet0/0/2.10]vrrp vrid 10 virtual-ip 192.168.1.2    //配置虛擬閘道器
[AR3-GigabitEthernet0/0/2.10]int g0/0/2.20
[AR3-GigabitEthernet0/0/2.20]vrrp vrid 20 virtual-ip 192.168.2.2  
[AR3-GigabitEthernet0/0/2.20]vrrp vrid 20 priority 120 
[AR3-GigabitEthernet0/0/2.20]vrrp vrid 20 track interface g0/0/1 reduced 30

檢視配置的狀態分別在(AR2 和 AR3上進行檢視)
AR2路由器檢視
從下圖可以看出AR2路由器為192.168.1.0/24網段的主路由器,虛擬閘道器為192.168.1.2,。AR2路由器為192.168.2.0/24網段的備份路由器,虛擬閘道器的IP地址為192.168.2.2
在這裡插入圖片描述
AR3路由器檢視
從下圖我們可以看出和 AR2截然相反
在這裡插入圖片描述
連通測試
PC1 ping PC2
在這裡插入圖片描述
PC1 ping AR1上的 lookback口
在這裡插入圖片描述

故障測試

預設狀態下,如果PC1主機要訪問9.9.9.9,那麼走的路線為 LS1—AR2—AR1 ,現在我們將AR2的g0/0/0埠down 掉,看看PC1還能否訪問9.9.9.9

AR2路由器的配置

[AR2]int G0/0/0    //進入埠
[AR2-GigabitEthernet0/0/0]shutdown   //執行關閉命令
[AR2-GigabitEthernet0/0/0]dis vrrp br 
我們檢視狀態,當前路由器裡面變為了備份狀態了,因為我們開啟了埠監視功能,出現故障,優先順序自動下降30
Total:2     Master:0     Backup:2     Non-active:0      
VRID  State        Interface                Type     Virtual IP     
----------------------------------------------------------------
10    Backup       GE0/0/2.10               Normal   192.168.1.2    
20    Backup       GE0/0/2.20               Normal   192.168.2.2   

再次連通測試
在這裡插入圖片描述
我們在把埠的狀態調回來,然後vrrp就啟用搶佔功能,馬上又變為了master狀態了

[AR2]int g0/0/0
[AR2-GigabitEthernet0/0/0]undo shutdown 
[AR2-GigabitEthernet0/0/0]dis vrrp br 
Total:2     Master:1     Backup:1     Non-active:0      
VRID  State        Interface                Type     Virtual IP     
----------------------------------------------------------------
10    Master       GE0/0/2.10               Normal   192.168.1.2    
20    Backup       GE0/0/2.20               Normal   192.168.2.2    

整個實驗搭建完成,效果實現!!!!!