1126 Eulerian Path (25分)
In graph theory, an Eulerian path is a path in a graph which visits every edge exactly once. Similarly, an Eulerian circuit is an Eulerian path which starts and ends on the same vertex. They were first discussed by Leonhard Euler while solving the famous Seven Bridges of Konigsberg problem in 1736. It has been proven that connected graphs with all vertices of even degree have an Eulerian circuit, and such graphs are called Eulerian. If there are exactly two vertices of odd degree, all Eulerian paths start at one of them and end at the other. A graph that has an Eulerian path but not an Eulerian circuit is called semi-Eulerian. (Cited from https://en.wikipedia.org/wiki/Eulerian_path)
Given an undirected graph, you are supposed to tell if it is Eulerian, semi-Eulerian, or non-Eulerian.
Input Specification:
Each input file contains one test case. Each case starts with a line containing 2 numbers N (≤ 500), and M, which are the total number of vertices, and the number of edges, respectively. Then M lines follow, each describes an edge by giving the two ends of the edge (the vertices are numbered from 1 to N).
Output Specification:
For each test case, first print in a line the degrees of the vertices in ascending order of their indices. Then in the next line print your conclusion about the graph – either Eulerian, Semi-Eulerian, or Non-Eulerian. Note that all the numbers in the first line must be separated by exactly 1 space, and there must be no extra space at the beginning or the end of the line.
Sample Input 1:
7 12
5 7
1 2
1 3
2 3
2 4
3 4
5 2
7 6
6 3
4 5
6 4
5 6
Sample Output 1:
2 4 4 4 4 4 2
Eulerian
Sample Input 2:
6 10
1 2
1 3
2 3
2 4
3 4
5 2
6 3
4 5
6 4
5 6
Sample Output 2:
2 4 4 4 3 3
Semi-Eulerian
Sample Input 3:
5 8
1 2
2 5
5 4
4 1
1 3
3 2
3 4
5 3
Sample Output 3:
3 3 4 3 3
Non-Eulerian
所有頂點的度都為偶數且連通,就是尤拉圖
僅有兩個頂點的度為奇數且連通,就是半尤拉圖
其餘就是非尤拉圖
用一個二維陣列來存每個頂點的度數,如果該頂點的度為奇數,就···。然後還需要判斷連通圖,來一個vis陣列,dfs任意一個點,只dfs一次,如果dfs後,還有頂點未被訪問,證明不連通。
dfs為遞迴函式,如果當前頂點已被訪問就返回,反之將其設為已訪問,然後遍歷其相鄰結點
#include<iostream>
#include<vector>
using namespace std;
vector<int> Adj[505];//Adj[1]存放的是1號頂點的連通頂點
bool visit[505] = {false};
void dfs(int v){
if(visit[v] == true) return;
visit[v] = true;
for(int i = 0; i < Adj[v].size(); i++){
dfs(Adj[v][i]);
}
}
int main(){
int n,m;
int u,v;
bool euLer = true;
bool connect = true;
int oddDgree = 0;
cin>>n>>m;
for(int i = 1; i <= m; i++){
cin>>u>>v;
Adj[u].push_back(v);
Adj[v].push_back(u);
}
for(int i = 1; i <= n; i++){
if(Adj[i].size() % 2!=0){
oddDgree++;
euLer = false;
}
}
dfs(1);
for(int i = 1; i <= n; i++){
if(visit[i] == false){
connect = false;
}
}
for(int i = 1; i <= n; i++){
if(i!=1) cout<<" ";
cout<<Adj[i].size();
}
cout<<endl;
if(euLer==false && connect == true && oddDgree == 2){
cout<<"Semi-Eulerian";
}
else if(euLer == true && connect == true){
cout<<"Eulerian";
}
else cout<<"Non-Eulerian";
return 0;
}
相關文章
- RV1126 分割槽教程
- RV1126 快速啟動
- PAT甲級1126~1130|C++實現C++
- Flutter Path(二) : Path 進階Flutter
- Flutter Path(一) : Path 與 CustomPainterFlutterAI
- [BUG反饋]defined('ADDON_PATH') or define('ADDON_PATH', APP_PATH.'Addon');APP
- crontab on raspberry pi, full path, not relative path, is needed.
- Python(Path().name)Python
- Path Sum III
- Leetcode Path SumLeetCode
- Path-sum
- Longest Univalue Path
- __dirname, __filename, path.resolve, path.join, process.cwd
- mac下的LD_LIBRARY_PATH是DYLD_LIBRARY_PATHMac
- The Staff Engineer’s Path
- DriveInfo類,Path類
- os.path.split
- Cookie path 屬性Cookie
- CSS clip-pathCSS
- Leetcode 71 Simplify PathLeetCode
- 112-Path Sum
- python技巧-使用os.path.join和os.path.sep.joinPython
- POJ3126-Prime Path
- WPF Path LineGeometry,RectangleGeometry,EllipseGeometry
- 環境變數path變數
- Path 突破Canvas極限Canvas
- os.path()模組
- Please provide a valid cache pathIDE
- LeetCode 112. Path SumLeetCode
- SVG <path> 路徑元素SVG
- node之path模組
- 64. Minimum Path Sum
- 687-Longest Univalue Path
- 437-Path Sum III
- 113-Path Sum II
- NodeJS之path模組NodeJS
- LeetCode 71. Simplify PathLeetCode
- Multi-path handling for asmASM