(UVA - 10976)Fractions Again?!(技巧,暴力列舉)

feng_zhiyu發表於2017-08-12

It is easy to see that for every fraction in the form 1
k
(k > 0), we can always find two positive integers
x and y, x ≥ y, such that:
1/k=1/x+1/y
Now our question is: can you write a program that counts how many such pairs of x and y there
are for any given k?
Input
Input contains no more than 100 lines, each giving a value of k (0 < k ≤ 10000).
Output
For each k, output the number of corresponding (x, y) pairs, followed by a sorted list of the values of
x and y, as shown in the sample output.

Sample Input
2
12
Sample Output
2
1/2 = 1/6 + 1/3
1/2 = 1/4 + 1/4
8
1/12 = 1/156 + 1/13
1/12 = 1/84 + 1/14
1/12 = 1/60 + 1/15
1/12 = 1/48 + 1/16
1/12 = 1/36 + 1/18
1/12 = 1/30 + 1/20
1/12 = 1/28 + 1/21
1/12 = 1/24 + 1/24

題意:給定正整數k(0<k<=10000),找到所有的正整數x>=y 使1/k=1/x+1/y輸出等式

分析:x>=y -> 1/x<=1/y
又1/x=1/k-1/y -> 1/k-1/y<=1/y -> 1/k<=2/y -> y<=2k
等式中隱含條件 y>=k
故列舉 k<=y<=2k,當然x不能列舉,直接計算出來是否滿足等式,列舉的話TLE

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int N=1e3+5;
int a[N],b[N];
int main()
{
    int k;
    while(~scanf("%d",&k))
    {
        int y,cnt=0;
        for(y=k;y<=2*k;y++)
        {
            double x=1.0*k*y/(y-k);
            if(x==(int)x)
            {
                a[cnt]=(int)x;
                b[cnt]=y;
                cnt++;
            }
        }
        printf("%d\n",cnt);
        for(int i=0;i<cnt;i++)
            printf("1/%d = 1/%d + 1/%d\n",k,a[i],b[i]);
    }
    return 0;
}

相關文章