POJ 3259-Wormholes(簡單判負環)

大白QQly成長日記發表於2018-09-11

While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way path that delivers you to its destination at a time that is BEFORE you entered the wormhole! Each of FJ's farms comprises N (1 ≤ N ≤ 500) fields conveniently numbered 1..N, M (1 ≤ M ≤ 2500) paths, and W (1 ≤ W ≤ 200) wormholes.

As FJ is an avid time-traveling fan, he wants to do the following: start at some field, travel through some paths and wormholes, and return to the starting field a time before his initial departure. Perhaps he will be able to meet himself :) .

To help FJ find out whether this is possible or not, he will supply you with complete maps to F (1 ≤ F ≤ 5) of his farms. No paths will take longer than 10,000 seconds to travel and no wormhole can bring FJ back in time by more than 10,000 seconds.

Input

Line 1: A single integer, F. F farm descriptions follow.
Line 1 of each farm: Three space-separated integers respectively: N, M, and W
Lines 2..M+1 of each farm: Three space-separated numbers (S, E, T) that describe, respectively: a bidirectional path between S and E that requires T seconds to traverse. Two fields might be connected by more than one path.
Lines M+2..M+W+1 of each farm: Three space-separated numbers (S, E, T) that describe, respectively: A one way path from S to E that also moves the traveler back T seconds.

Output

Lines 1..F: For each farm, output "YES" if FJ can achieve his goal, otherwise output "NO" (do not include the quotes).

Sample Input

2
3 3 1
1 2 2
1 3 4
2 3 1
3 1 3
3 2 1
1 2 3
2 3 4
3 1 8

Sample Output

NO
YES

題目大意:給出n個點,m條費用邊,k條穿越邊。費用邊即為走過時需要的時間,穿越邊即為走過時可時間返回的一定數值的邊。

思路:如此清晰的思路,就是一個簡單的判負環問題。但之前一直沒有遇到過,算是第一次做負環問題。判負環通常是使用spfa來直接判,但是,能判負環的實質是BF演算法,spfa是BF演算法加上佇列優化的結果,所以有必要去了解一下BF演算法。至於spfa的再優化就暫時擱置一下吧。

BF演算法:簡單來說就是鬆弛所有的點,遍歷所有點,再遍歷所有邊,進行鬆弛,因為若有負環存在,那麼鬆弛時就永遠鬆弛不完的,那麼利用這一點,進行判環。時間複雜度(VE)

加佇列優化:即不斷進隊出隊,從而實現優化,時間複雜度為(KE   k為入隊次數)若加上前向星儲存方式還能優化,還能優化,詳情暫時不知。

程式碼如下:

#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>
#include <vector>
#include <queue>
#include <set>
#include <map>
#include <string>
#include <cmath>
#include <cstdlib>
#include <ctime>
using namespace std;
const int maxn=1010;
const int maxv=5000;
const int INF=1<<29;
struct node{
    int a;
    int b;
    int cost;
}p[maxv];
int d[maxn];
int N,M,W;
int n;
int bf(int s) 
{
    for(int i=1;i<=N;i++) d[i]=INF;
    d[s]=0;
    for(int i=0;i<N;i++) //所有點
    {
        int fag=0;
        for(int j=0;j<n;j++) //所有邊
	{
            node p1=p[j];
            if(d[p1.a]!=INF&&d[p1.b]>d[p1.a]+p1.cost) //鬆弛 
	    {
                d[p1.b]=d[p1.a]+p1.cost;
                fag=1;
                if(i==N-1) return 1;  //鬆弛次數超過邊數即為有負環
            }
        }
        if(!fag) break;
    }
    return 0;
}
int main()
{
    int F,a,b,c;
    scanf("%d",&F);
    while(F--) 
    {
        scanf("%d%d%d",&N,&M,&W);
        n=0;
        for(int i=0;i<M;++i) 
	{  
            scanf("%d%d%d",&a,&b,&c);
            p[n].b=a;p[n].a=b;p[n++].cost=c;
            p[n].b=b;p[n].a=a;p[n++].cost=c;
        }
        for(int i=0;i<W;++i) 
	{  
            scanf("%d%d%d",&a,&b,&c);
            p[n].a=a;p[n].b=b;p[n++].cost=-c;
        }
        int fag=bf(1);
        if(fag==1) printf("YES\n");
        else printf("NO\n");
    }
    return 0;
}  

 

 

相關文章