POJ2240 Arbitrage【判斷正環的存在】
Arbitrage
Time Limit: 1000MS | Memory Limit: 65536K | |
Total Submissions: 28447 | Accepted: 11926 |
Description
Arbitrage is the use of discrepancies in currency exchange rates to transform one unit of a currency into more than one unit of the same currency. For example, suppose that 1 US Dollar buys 0.5 British pound, 1 British pound buys 10.0 French francs, and 1 French franc buys 0.21 US dollar. Then, by converting currencies, a clever trader can start with 1 US dollar and buy 0.5 * 10.0 * 0.21 = 1.05 US dollars, making a profit of 5 percent.
Your job is to write a program that takes a list of currency exchange rates as input and then determines whether arbitrage is possible or not.
Input
The input will contain one or more test cases. Om the first line of each test case there is an integer n (1<=n<=30), representing the number of different currencies. The next n lines each contain the name of one currency. Within a name no spaces will appear. The next line contains one integer m, representing the length of the table to follow. The last m lines each contain the name ci of a source currency, a real number rij which represents the exchange rate from ci to cj and a name cj of the destination currency. Exchanges which do not appear in the table are impossible.
Test cases are separated from each other by a blank line. Input is terminated by a value of zero (0) for n.
Output
For each test case, print one line telling whether arbitrage is possible or not in the format "Case case: Yes" respectively "Case case: No".
Sample Input
3
USDollar
BritishPound
FrenchFranc
3
USDollar 0.5 BritishPound
BritishPound 10.0 FrenchFranc
FrenchFranc 0.21 USDollar
3
USDollar
BritishPound
FrenchFranc
6
USDollar 0.5 BritishPound
USDollar 4.9 FrenchFranc
BritishPound 10.0 FrenchFranc
BritishPound 1.99 USDollar
FrenchFranc 0.09 BritishPound
FrenchFranc 0.19 USDollar
0
Sample Output
Case 1: Yes
Case 2: No
Source
問題連結:POJ2240 Arbitrage
問題描述 :假設:1美元可以換0.5英鎊,1英鎊可以換10法郎,1法郎可以換0.21美元。那麼1美元經過交換1*0.5*10*0.21=1.05。比本金多了,現在給你n中貨幣,m種兌換方法,如果存在上述情況則返回YES,否則返回NO。
解題思路:判斷是否有正環,使用Bellman_ford演算法,只要修改鬆弛條件和初始化就可以了
AC的C++程式:
#include<iostream>
#include<cstring>
#include<string>
#include<map>
using namespace std;
const int N=10000;
double dist[35];
int n,m;
struct Edge{
int start,end;
double w;
}edge[N];
//判斷是否有負環 n個結點,m條邊
bool Bellman_ford()
{
memset(dist,0,sizeof(dist));
dist[1]=1;
//進行n-1次鬆弛
for(int i=1;i<n;i++)
for(int j=0;j<m;j++)
if(dist[edge[j].end]<dist[edge[j].start]*edge[j].w)
dist[edge[j].end]=dist[edge[j].start]*edge[j].w;
//判斷是否有正環
for(int j=0;j<m;j++)
if(dist[edge[j].end]<dist[edge[j].start]*edge[j].w)
return true;
return false;
}
int main()
{
string s,from,to;
int cnt=0;
double c;
map<string,int>id;
while(cin>>n&&n){
for(int i=1;i<=n;i++){
cin>>s;
id[s]=i;
}
cin>>m;
for(int i=0;i<m;i++){
cin>>from>>c>>to;
edge[i].start=id[from],edge[i].end=id[to],edge[i].w=c;
}
cout<<"Case "<<++cnt<<": ";
if(Bellman_ford())
cout<<"Yes"<<endl;
else
cout<<"No"<<endl;
}
return 0;
}
相關文章
- 判斷存在與否
- 正規化判斷
- JavaScript 判斷函式是否存在JavaScript函式
- golang判斷檔案是否存在Golang
- MySQL判斷表名是否存在MySql
- QJsonObject判斷欄位是否存在JSONObject
- postgresql如何判斷表是否存在SQL
- python 判斷檔案是否存在Python
- 判斷單連結串列中是否存在環,並輸出環入口節點。
- JQuery 判斷 正整數jQuery
- 如何判斷FMEA的存在是否還有意義?
- Laravel 5 判斷條件是否存在Laravel
- 判斷objectStore物件倉庫是否存在Object物件
- jQuery 判斷使用者是否存在jQuery
- 怎麼判斷mysql表是否存在MySql
- js判斷dom節點是否存在JS
- 判斷負環模板
- 判斷金額的正規表示式
- sh指令碼判斷路徑是否存在指令碼
- map判斷值是否存在需要注意的問題
- java判斷mysql中資料庫是否存在JavaMySql資料庫
- mysql如何判斷是否存在某個欄位MySql
- jquery怎麼樣判斷檔案是否存在jQuery
- 如何判斷FMEA是否以正確的方式完成?
- VBA判斷指定的資料夾或檔案是否存在
- bash函式應用之:判斷函式是否存在函式
- 判斷Map集合中是否存在某一個key
- shell判斷系統路徑中是否存在空格
- sqlserver判斷欄位值是否存在某個字元SQLServer字元
- POJ1860 Currency Exchange【Bellman_ford演算法:判斷是否有正環】演算法
- C語言判斷檔案是否存在,判斷檔案可讀可寫可執行C語言
- 判斷環境使用 Laravel Page SpeedLaravel
- 記一次判斷值是否存在遇到的神奇問題
- 如果透過python的sdk pymilvus 判斷一個 collection 是否存在?Python
- XamarinEssentials教程首選項Preferences判斷專案是否存在
- 如何判斷一個js物件是否存在迴圈引用JS物件
- 動態生成表-判斷表是否存在效能對比
- C語言判斷檔案存在和建立檔案C語言