POJ2240 Arbitrage【判斷正環的存在】
Arbitrage
Time Limit: 1000MS | Memory Limit: 65536K | |
Total Submissions: 28447 | Accepted: 11926 |
Description
Arbitrage is the use of discrepancies in currency exchange rates to transform one unit of a currency into more than one unit of the same currency. For example, suppose that 1 US Dollar buys 0.5 British pound, 1 British pound buys 10.0 French francs, and 1 French franc buys 0.21 US dollar. Then, by converting currencies, a clever trader can start with 1 US dollar and buy 0.5 * 10.0 * 0.21 = 1.05 US dollars, making a profit of 5 percent.
Your job is to write a program that takes a list of currency exchange rates as input and then determines whether arbitrage is possible or not.
Input
The input will contain one or more test cases. Om the first line of each test case there is an integer n (1<=n<=30), representing the number of different currencies. The next n lines each contain the name of one currency. Within a name no spaces will appear. The next line contains one integer m, representing the length of the table to follow. The last m lines each contain the name ci of a source currency, a real number rij which represents the exchange rate from ci to cj and a name cj of the destination currency. Exchanges which do not appear in the table are impossible.
Test cases are separated from each other by a blank line. Input is terminated by a value of zero (0) for n.
Output
For each test case, print one line telling whether arbitrage is possible or not in the format "Case case: Yes" respectively "Case case: No".
Sample Input
3
USDollar
BritishPound
FrenchFranc
3
USDollar 0.5 BritishPound
BritishPound 10.0 FrenchFranc
FrenchFranc 0.21 USDollar
3
USDollar
BritishPound
FrenchFranc
6
USDollar 0.5 BritishPound
USDollar 4.9 FrenchFranc
BritishPound 10.0 FrenchFranc
BritishPound 1.99 USDollar
FrenchFranc 0.09 BritishPound
FrenchFranc 0.19 USDollar
0
Sample Output
Case 1: Yes
Case 2: No
Source
問題連結:POJ2240 Arbitrage
問題描述 :假設:1美元可以換0.5英鎊,1英鎊可以換10法郎,1法郎可以換0.21美元。那麼1美元經過交換1*0.5*10*0.21=1.05。比本金多了,現在給你n中貨幣,m種兌換方法,如果存在上述情況則返回YES,否則返回NO。
解題思路:判斷是否有正環,使用Bellman_ford演算法,只要修改鬆弛條件和初始化就可以了
AC的C++程式:
#include<iostream>
#include<cstring>
#include<string>
#include<map>
using namespace std;
const int N=10000;
double dist[35];
int n,m;
struct Edge{
int start,end;
double w;
}edge[N];
//判斷是否有負環 n個結點,m條邊
bool Bellman_ford()
{
memset(dist,0,sizeof(dist));
dist[1]=1;
//進行n-1次鬆弛
for(int i=1;i<n;i++)
for(int j=0;j<m;j++)
if(dist[edge[j].end]<dist[edge[j].start]*edge[j].w)
dist[edge[j].end]=dist[edge[j].start]*edge[j].w;
//判斷是否有正環
for(int j=0;j<m;j++)
if(dist[edge[j].end]<dist[edge[j].start]*edge[j].w)
return true;
return false;
}
int main()
{
string s,from,to;
int cnt=0;
double c;
map<string,int>id;
while(cin>>n&&n){
for(int i=1;i<=n;i++){
cin>>s;
id[s]=i;
}
cin>>m;
for(int i=0;i<m;i++){
cin>>from>>c>>to;
edge[i].start=id[from],edge[i].end=id[to],edge[i].w=c;
}
cout<<"Case "<<++cnt<<": ";
if(Bellman_ford())
cout<<"Yes"<<endl;
else
cout<<"No"<<endl;
}
return 0;
}
相關文章
- Linux Shell 判斷環境變數 是否存在Linux變數
- 判斷存在與否
- 41:判斷元素是否存在
- iOS正則判斷iOS
- 正規化判斷
- JavaScript 判斷函式是否存在JavaScript函式
- postgresql如何判斷表是否存在SQL
- golang判斷檔案是否存在Golang
- vc判斷檔案是否存在
- jQuery如何判斷元素是否存在jQuery
- iOS判斷是否存在網路iOS
- 如何判斷Javascript物件是否存在JavaScript物件
- MySQL判斷表名是否存在MySql
- 判斷單連結串列是否存在環,判斷兩個連結串列是否相交問題詳解
- JQuery 判斷 正整數jQuery
- 判斷負環模板
- 判斷objectStore物件倉庫是否存在Object物件
- js判斷dom節點是否存在JS
- 怎麼判斷mysql表是否存在MySql
- jQuery 判斷使用者是否存在jQuery
- Laravel 5 判斷條件是否存在Laravel
- python 判斷檔案是否存在Python
- jQuery 判斷頁面元素是否存在jQuery
- js如何判斷指定的檔案是否存在JS
- iOS 常用的正規表示式判斷iOS
- java判斷mysql中資料庫是否存在JavaMySql資料庫
- jQuery如何判斷一個元素是否存在jQuery
- 如何判斷一個jquery物件是否存在jQuery物件
- 如何利用jQuery判斷指定元素是否存在jQuery
- javascript判斷一個變數是否存在JavaScript變數
- js如何判斷一個物件是否存在JS物件
- JavaScript中判斷是否存在某屬性JavaScript
- QTP中如何判斷Excel程式是否存在?QTExcel
- sh指令碼判斷路徑是否存在指令碼
- c# winform 判斷資料夾是否存在,新建資料夾,判斷資料夾存不存在C#ORM
- JavaScript判斷數字正負數JavaScript
- js如何判斷指定名稱的函式是否存在JS函式
- Python 判斷檔案是否存在的三種方法Python