A+B for Input-Output Practice (IV) (sdut oj)

SwordsMan98發表於2017-01-25



A+B for Input-Output Practice (IV)

Time Limit: 1000MS Memory Limit: 65536KB



Problem Description

Your task is to Calculate the sum of some integers.


Input

Input contains multiple test cases. Each test case contains a integer N, and then N integers follow in the same line. A test case starting with 0 terminates the input and this test case is not to be processed.


Output

For each group of input integers you should output their sum in one line, and with one line of output for each line in input.


Example Input

4 1 2 3 4
5 1 2 3 4 5
0


Example Output

10
15


Hint

 

Author

HDOJ







參考程式碼


#include<stdio.h>
int main()
{
    int n;
    int num;
    int sum;
    while(scanf("%d",&n) != EOF)
    {
        sum = 0;
        if(n == 0)
            break;
        else
            while(n--)
            {
                scanf("%d",&num);
                sum += num;
            }
        printf("%d\n",sum);
    }
    return 0;
}


相關文章