A+B for Input-Output Practice (IV) (sdut oj)
A+B for Input-Output Practice (IV)
Time Limit: 1000MS Memory Limit: 65536KB
Problem Description
Your task is to Calculate the sum of some integers.
Input
Input contains multiple test cases. Each test case contains a integer N, and then N integers follow in the same line. A test case starting with 0 terminates the input and this test case is not to be processed.
Output
For each group of input integers you should output their sum in one line, and with one line of output for each line in input.
Example Input
4 1 2 3 4 5 1 2 3 4 5 0
Example Output
10 15
Hint
Author
HDOJ
參考程式碼
#include<stdio.h>
int main()
{
int n;
int num;
int sum;
while(scanf("%d",&n) != EOF)
{
sum = 0;
if(n == 0)
break;
else
while(n--)
{
scanf("%d",&num);
sum += num;
}
printf("%d\n",sum);
}
return 0;
}
相關文章
- HDOJ 1094 A+B for Input-Output Practice (VI)
- 分段函式 (sdut oj)函式
- 計算題 (sdut oj)
- 計算組合數 (sdut oj)
- C語言實驗——素數 (sdut oj)C語言
- C語言實驗——最值 (sdut oj)C語言
- C語言實驗——整數位 (sdut oj)C語言
- C語言實驗——分割整數 (sdut oj)C語言
- 汽車加油問題 SDUT OJ 貪心演算法演算法
- 小鑫の日常系列故事(五)——卡片遊戲 (sdut oj)遊戲
- 山東理工大學SDUT - ACM OJ 題: Python程式碼 及分析ACMPython
- C語言實驗——for迴圈列印圖形(迴圈結構)(sdut oj)C語言
- C/C++經典程式訓練5---圖形列印問題 (sdut oj)C++
- C語言實驗——一元二次方程Ⅰ (sdut oj)C語言
- C/C++程式訓練6---歌德巴赫猜想的證明 (sdut oj)C++
- C/C++經典程式訓練2---斐波那契數列 (sdut oj)C++
- C/C++練習7---求某個範圍內的所有素數 (sdut oj)C++
- Practice
- SDUT---OJ《資料結構與演算法》實踐能力專題訓練2 連結串列資料結構演算法
- airflow practiceAI
- scientifically practice DP
- shell practice 04
- shell practice 06
- shell practice 03
- shell practice 05
- shell practice 07
- Practice| 流程控制
- Best Practice in Writing
- Java加密之IVJava加密
- OJ搭建
- IV. Mip-NeRF
- [Algorithm] 1. A+B ProblemGo
- “Docker Practice”讀書筆記Docker筆記
- yolov5s ncnn practiceYOLOCNN
- IV.2 解析數論
- Delphi物件模型(Part IV) (轉)物件模型
- A+B 演算法問題演算法
- Spring Boot In Practice (0):基礎Spring Boot