POJ 3107 Godfather(樹形dp)
題意是找大哥,是大哥的條件是:刪除這個節點之後最大聯通的點最少。
第一遍dfs找到每個節點有多少子節點,第二遍dfs求出刪掉每個環節點之後會剩餘多少個聯通的節點,並求出最大聯通節點的個數。
Time Limit: 2000MS | Memory Limit: 65536K | |
Total Submissions: 4544 | Accepted: 1539 |
Description
Last years Chicago was full of gangster fights and strange murders. The chief of the police got really tired of all these crimes, and decided to arrest the mafia leaders.
Unfortunately, the structure of Chicago mafia is rather complicated. There are n persons known to be related to mafia. The police have traced their activity for some time, and know that some of them are communicating with each other. Based on the data collected, the chief of the police suggests that the mafia hierarchy can be represented as a tree. The head of the mafia, Godfather, is the root of the tree, and if some person is represented by a node in the tree, its direct subordinates are represented by the children of that node. For the purpose of conspiracy the gangsters only communicate with their direct subordinates and their direct master.
Unfortunately, though the police know gangsters’ communications, they do not know who is a master in any pair of communicating persons. Thus they only have an undirected tree of communications, and do not know who Godfather is.
Based on the idea that Godfather wants to have the most possible control over mafia, the chief of the police has made a suggestion that Godfather is such a person that after deleting it from the communications tree the size of the largest remaining connected component is as small as possible. Help the police to find all potential Godfathers and they will arrest them.
Input
The first line of the input file contains n — the number of persons suspected to belong to mafia (2 ≤ n ≤ 50 000). Let them be numbered from 1 to n.
The following n − 1 lines contain two integer numbers each. The pair ai, bi means that the gangster ai has communicated with the gangster bi. It is guaranteed that the gangsters’ communications form a tree.
Output
Print the numbers of all persons that are suspected to be Godfather. The numbers must be printed in the increasing order, separated by spaces.
Sample Input
6 1 2 2 3 2 5 3 4 3 6
Sample Output
2 3
#include <algorithm>
#include <iostream>
#include <stdlib.h>
#include <string.h>
#include <iomanip>
#include <stdio.h>
#include <string>
#include <queue>
#include <cmath>
#include <stack>
#include <map>
#include <set>
#define eps 1e-8
#define M 1000100
//#define LL __int64
#define LL long long
#define INF 0x3f3f3f3f
#define PI 3.1415926535898
const int maxn = 50010;
using namespace std;
int head[maxn];
int t;
int Max;
int sum[maxn];
int p[maxn];
int n;
struct node
{
int to;
int next;
} f[2*maxn];
void init()
{
t = 0;
Max = INF;
memset(head, -1, sizeof(head));
}
void add(int x, int y)
{
f[t].to = y;
f[t].next = head[x];
head[x] = t++;
f[t].to = x;
f[t].next = head[y];
head[y] = t++;
}
void dfs1(int x, int fa)
{
sum[x] = 1;
for(int i = head[x]; i != -1; i = f[i].next)
{
int v = f[i].to;
if(v == fa)
continue;
dfs1(v, x);
sum[x] += sum[v];
}
}
void dfs2(int x, int fa)
{
int &ans = p[x] = n-sum[x];
for(int i = head[x]; i != -1; i = f[i].next)
{
int v = f[i].to;
if(v == fa)
continue;
dfs2(v, x);
ans = max(ans, sum[v]);
}
Max = min(Max, ans);
}
int main()
{
while(~scanf("%d",&n))
{
int u, v;
init();
for(int i = 0; i < n-1; i++)
{
scanf("%d %d",&u, &v);
add(u,v);
}
dfs1(1, -1);
dfs2(1, -1);
int flag = 0;
for(int i = 1; i <= n; i++)
{
if(p[i] == Max)
{
if(!flag)
{
flag = 1;
printf("%d",i);
}
else
printf(" %d",i);
}
}
printf("\n");
}
return 0;
}
相關文章
- POJ3107Godfather[樹形DP 樹的重心]Go
- POJ 2486 Apple Tree(樹形dp)APP
- 【樹形dp】poj 1947 Rebuilding RoadsRebuild
- 樹形DP
- 樹形DP!
- POJ 1947 Rebuilding Roads(基礎的樹形dp)Rebuild
- 樹上染色(樹形dp)
- [筆記]樹形dp筆記
- 樹形DP二三知識
- CCF之網路延時(樹形dp)
- HDU 5326 Work (基礎樹形dp)
- hdu 4123 樹形DP+RMQMQ
- 【動態規劃】樹形DP完全詳解!動態規劃
- poj2486Apple Tree[樹形揹包!!!]APP
- ZROJ#398. 【18提高7】隨機遊走(期望dp 樹形dp)隨機
- Puzzles CodeForces 696B 樹形DP 期望計算
- hdu4313 貪心並查集 || 樹形dp並查集
- Codevs1378選課[樹形DP|兩種做法(多叉轉二叉|樹形DP+分組揹包)---(▼皿▼#)----^___^]dev
- Luogu P3177 樹上染色 [ 藍 ] [ 樹形 dp ] [ 貢獻思維 ]
- POJ1745Divisibility(dp)
- POJ2955 Brackets (區間DP)Racket
- Codeforces 461B. Appleman and Tree[樹形DP 方案數]APP
- 樹形dp - Codeforces Round #322 (Div. 2) F Zublicanes and Mumocrates
- POJ 1925 Spiderman(線性dp)IDE
- POJ 3744 概率dp+矩陣矩陣
- CF 1029E Tree with Small Distances 樹形DP or 貪心
- BZOJ1864[ZJOI2006]三色二叉樹[樹形DP]二叉樹
- E73 樹形DP P3177 [HAOI2015] 樹上染色
- POJ1849Two[DP|樹的直徑](擴充套件HDU4003待辦)套件
- POJ1160 Post Office[序列DP]
- 【dp】POJ 1015 Jury CompromisePromise
- POJ 3249-Test for Job(拓撲排序&&DP)排序
- POJ 3017 單調佇列dp佇列
- POJ 3691 DNA repair (AC自動機 + dp)AI
- URAL 1018 Binary Apple Tree(樹形dp入門題)APP
- CF1039D You Are Given a Tree (樹形 dp + 貪心 + 根號分治)
- poj 2481 樹狀陣列陣列
- 二叉搜尋樹 [四邊形不等式優化區間dp]優化