字串-字元統計1

HowieLee59發表於2019-03-18

Problem Description

給出一串字元,要求統計出裡面的字母、數字、空格以及其他字元的個數。
字母:A, B, ..., Z、a, b, ..., z組成
數字:0, 1, ..., 9 
空格:" "(不包括引號) 
剩下的可列印字元全為其他字元。

Input

測試資料有多組。
每組資料為一行(長度不超過100000)。
資料至檔案結束(EOF)為止。

Output

每組輸入對應一行輸出。
包括四個整數a b c d,分別代表字母、數字、空格和其他字元的個數。

Sample Input

A0 ,

Sample Output

1 1 1 1
#include<stdio.h>
#include<stdlib.h>
#include<string.h>

int main(){
    char str[1001];
    int a,b,c,d;
    while(gets(str)){
        int len = strlen(str);
        a = 0;
        b = 0;
        c = 0;
        d = 0;
        for(int i = 0 ; i < len ; i++){
            if((str[i] >= 'a' && str[i] <= 'z')||(str[i] >= 'A' && str[i] <= 'Z')){
                a++;
            }else if(str[i] >= '0' && str[i] <= '9'){
                b++;
            }else if(str[i] == ' '){
                c++;
            }else{
                d++;
            }
        }
        printf("%d %d %d %d\n",a,b,c,d);
    }
    return 0;
}

 

相關文章