字串-刪除指定字元

HowieLee59發表於2019-03-18

Problem Description

從鍵盤輸入一個字串給str和一個字元給c,刪除str中的所有字元c並輸出刪除後的字串str。

Input

第一行是一個字串,不超過100個字元;
第二行是一個字元。

Output

刪除指定字元後的字串。

Sample Input

sdf$$$sdf$$
$

Sample Output

sdfsdf
#include<stdio.h>
#include<stdlib.h>
#include<string.h>

int main(){
    char p[1001];
    char a;
    gets(p);
    scanf("%c",&a);
    for(int i = 0 ; p[i] != '\0' ; i++){
        if(p[i] != a){
            printf("%c",p[i]);
        }
    }
    printf("\n");
    return 0;
}

 

相關文章