字串-字元統計2

HowieLee59發表於2019-03-18

Problem Description

輸入英文句子,輸出該句子中除了空格外出現次數最多的字元及其出現的次數。

Input

輸入資料包含多個測試例項,每個測試例項是一個長度不超過100的英文句子,佔一行。

Output

逐行輸出每個句子中出現次數最多的字元及其出現的次數(如果有多個字元的次數相同,只輸出ASCII碼最小的字元)。

Sample Input

I am a student
a good programming problem
ABCD abcd ABCD abcd

Sample Output

a 2
o 4
A 2
#include<stdio.h>
#include<stdlib.h>
#include<string.h>

int main(){
    char str[1001];
    int len;
    while(gets(str)){
        int str1[1001] = {0};
        int count = 0;
        char flag;
        len = strlen(str);
        for(int i = 0 ; i < len; i++){
            if((str[i] >= 'A' && str[i] <= 'Z') || (str[i] >= 'a' && str[i] <= 'z')){
                str1[str[i]]++;
            }
        }
        for(int i = 65 ; i <= 122; i++){
            if(str1[(char)i] > count){
                count = str1[(char)i];
                flag = (char)i;
            }
        }
        printf("%c %d\n",flag,count);
    }
    return 0;
}

 

相關文章