指標-小泉的難題

HowieLee59發表於2019-03-16

Problem Description

機械實驗班有個同學叫小泉,有一天數學老師給小泉佈置了一道個人作業,給小泉M(M<=100)組資料,每組資料有N個正整數(N<=100)讓他把每組的N個數按升序排成一行,但由於數的數目比較多,人工做很費時,於是小泉就想到了喜歡程式設計序的你,請你幫他解決這個問題,可不要讓他失望噢。

Input

輸入包括M+1行,第一行是兩個正整數M、N;M表示總共多少組資料,下面M行每行包含N個正整數。(輸入資料之間會用空格隔開)

Output

輸出包括M行,每行分別對應輸入中M組資料的升序序列,數與數之間用一個空格隔開。

Sample Input

2 3
1 3 2
4 2 6

Sample Output

1 2 3
2 4 6

Hint

#include<stdio.h>
#include<stdlib.h>

void swap(int *pt1,int *pt2){
    int temp;
    temp = *pt1;
    *pt1 = *pt2;
    *pt2 = temp;
}

int main(){
    int a,b;
    int d[100];
    scanf("%d %d",&a,&b);
    while(a--){
        for(int i = 0 ;i < b;i++){
            scanf("%d",&d[i]);
        }
        for(int i = 0 ; i < b - 1;i++){
            for(int j = i + 1;j < b ;j++){
                if(d[j] < d[i]){
                    swap(&d[j],&d[i]);
                }
            }
        }
        for(int i = 0 ; i < b - 1;i++){
            printf("%d ",d[i]);
        }
        if(a != 0)
            printf("%d\n",d[b - 1]);
        else
            printf("%d",d[b - 1]);
    }
    return 0;
}

 

相關文章