HDU 1060 Leftmost Digit

淡定的小魚發表於2014-07-28

Leftmost Digit

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 12985    Accepted Submission(s): 4973


Problem Description
Given a positive integer N, you should output the leftmost digit of N^N.
 

Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains a single positive integer N(1<=N<=1,000,000,000).
 

Output
For each test case, you should output the leftmost digit of N^N.
 

Sample Input
2 3 4
 

Sample Output
2 2
Hint
In the first case, 3 * 3 * 3 = 27, so the leftmost digit is 2. In the second case, 4 * 4 * 4 * 4 = 256, so the leftmost digit is 2.
 



解釋不好,就不解釋了

要了解 log的用法、pow函式的用法



#include<stdio.h>
#include<math.h>
int main()
{
	int T,a;
	double m;
	scanf("%d",&T);
	while(T--)
	{
		__int64 N;
		double a;
		scanf("%I64d",&N);
		m=N*log10((double)N)-(__int64)(N*log10((double)N));
		a=pow(10.0,m);
		printf("%d\n",(int)a);
	}
	return 0;




相關文章