homestead 多版本 編譯安裝swoole

sanxiao 發表於 2021-12-01
Swoole
git clone https://gitee.com/swoole/swoole.git
cd swoole
phpize &&  ./configure --with-php-config=/usr/bin/php-config7.3 &&  make && sudo make install
在對應php版本的php.ini檔案 新增  extension=swoole.so
我的是在    /etc/php/7.3/cli/目錄  因為專案需要7.3的php版本
sudo service php7.3-fpm restart
php -m

homestead 多版本 編譯安裝swoole

最後: homestead安裝后里面 會有很多PHP版本
我們直接安裝的話會預設安裝到最新的版本
所以按照需求使用編譯安裝

本作品採用《CC 協議》,轉載必須註明作者和本文連結

相關文章