1149 Dangerous Goods Packaging (25分)
When shipping goods with containers, we have to be careful not to pack some incompatible goods into the same container, or we might get ourselves in serious trouble. For example, oxidizing agent (氧化劑) must not be packed with flammable liquid (易燃液體), or it can cause explosion.
Now you are given a long list of incompatible goods, and several lists of goods to be shipped. You are supposed to tell if all the goods in a list can be packed into the same container.
Input Specification:
Each input file contains one test case. For each case, the first line gives two positive integers: N (≤10
4
), the number of pairs of incompatible goods, and M (≤100), the number of lists of goods to be shipped.
Then two blocks follow. The first block contains N pairs of incompatible goods, each pair occupies a line; and the second one contains M lists of goods to be shipped, each list occupies a line in the following format:
K G[1] G[2] … G[K]
where K (≤1,000) is the number of goods and G[i]'s are the IDs of the goods. To make it simple, each good is represented by a 5-digit ID number. All the numbers in a line are separated by spaces.
Output Specification:
For each shipping list, print in a line Yes if there are no incompatible goods in the list, or No if not.
Sample Input:
6 3
20001 20002
20003 20004
20005 20006
20003 20001
20005 20004
20004 20006
4 00001 20004 00002 20003
5 98823 20002 20003 20006 10010
3 12345 67890 23333
Sample Output:
No
Yes
Yes
一開始用map來存,然後全錯,仔細看題發現居然每個物品可能有多種不相容的物品,所以用二維陣列來存。輸入ship陣列後,for迴圈判斷即可,有一組不相容就false
#include<iostream>
#include<vector>
using namespace std;
int main(){
int n,m;
vector<int> bad[100000];//bad[1]是一個vector,下面存了它不能共存的物品
cin>>n>>m;
int u,v;
for(int i = 0; i < n; i++){
cin>>u>>v;
bad[u].push_back(v);
bad[v].push_back(u);
}
int k;
int ship[1005];
for(int i = 0; i < m; i++){
cin>>k;
bool flag = true;
for(int j = 0; j < k; j++){
cin>>ship[j];
}
for(int j = 0; j < k; j++){
for(int l = j + 1; l < k; l++){
for(int p = 0; p <bad[ship[j]].size(); p++){
if(bad[ship[j]][p] == ship[l]) flag = false;
}
}
}
if(flag == false) cout<<"No\n";
else cout<<"Yes\n";
}
return 0;
}
相關文章
- PAT (Advanced Level) Practice 1149 Dangerous Goods Packaging (25分)Go
- goodsGo
- 【Scala】Scala之Packaging and ImportsImport
- A potentially dangerous Request.Form value was detected from the clientORMclient
- SCM605--Free GoodsGo
- IN GST(Goods and Service Tax) localization requirementGoUIREM
- FAQ: Goods Receipt sd 問題Go
- ecshop /goods.php SQL Injection VulGoPHPSQL
- Oracle ADR packaging incidents(打包事件)OracleIDE事件
- BAPI_GOODSMVT_CREATE to post Goods MovementAPIGo
- SAP BAPI BAPI_GOODSMVT_CREATE Goods movementAPIGo
- MIGO error:"Goods receipt for purch. order" is not allowedGoError
- solaris Application Packaging 編寫的小工具APP
- 【洛谷OJ】【JAVA】P1149 火柴棒等式Java
- CF1149D Abandoning Roads 題解
- wp7 toolkit編譯錯誤 Xap packaging failed編譯AI
- how to handl price differences in Purchase Order, Goods Receipts and Vendor InvoiceGo
- Oracle EBS R12 Packaging File 和MakeCD 終於完成..Oracle
- 先做Post Goods Issue,還是先做shipment cost?Go
- SAP MM 物料主資料裡的‘Packaging Material Type'欄位
- SAP SD基礎知識之免費貨物(Free Goods)Go
- POJ 1149-PIGS(Ford-Fulkerson 標號法求網路最大流)
- Packaging.DebUOS 專門為 dotnet 應用製作 UOS 安裝包
- Salesforce Consumer Goods Cloud 淺談篇一之基礎介紹SalesforceGoCloud
- Salesforce Consumer Goods Cloud 淺談篇二之門店產品促銷的配置SalesforceGoCloud
- Salesforce Consumer Goods Cloud 淺談篇三之 行動計劃(Action Plan)相關配置SalesforceGoCloud
- Salesforce Consumer Goods Cloud 淺談篇四之店內拜訪的建立和執行SalesforceGoCloud
- 關於在執行 SAP ERP MM 模組 Post Goods Issue 時修改 Material Cost 的討論Go
- Core Image框架詳細解析(十六) —— 包裝和載入影像單元 Packaging and Loading Image Units...框架
- Inside Virtual Goods:2012年美國手機遊戲中虛擬商品交易額達5億美元IDEGo遊戲
- Inside Virtual Goods:2012年美國虛擬商品市場規模將達到29億美元IDEGo
- M7093 Fld selectn for mvmt type 501 / acct 14030201 differs for Vendor goods movement (014)Go