1149 Dangerous Goods Packaging (25分)
When shipping goods with containers, we have to be careful not to pack some incompatible goods into the same container, or we might get ourselves in serious trouble. For example, oxidizing agent (氧化劑) must not be packed with flammable liquid (易燃液體), or it can cause explosion.
Now you are given a long list of incompatible goods, and several lists of goods to be shipped. You are supposed to tell if all the goods in a list can be packed into the same container.
Input Specification:
Each input file contains one test case. For each case, the first line gives two positive integers: N (≤10
4
), the number of pairs of incompatible goods, and M (≤100), the number of lists of goods to be shipped.
Then two blocks follow. The first block contains N pairs of incompatible goods, each pair occupies a line; and the second one contains M lists of goods to be shipped, each list occupies a line in the following format:
K G[1] G[2] … G[K]
where K (≤1,000) is the number of goods and G[i]'s are the IDs of the goods. To make it simple, each good is represented by a 5-digit ID number. All the numbers in a line are separated by spaces.
Output Specification:
For each shipping list, print in a line Yes if there are no incompatible goods in the list, or No if not.
Sample Input:
6 3
20001 20002
20003 20004
20005 20006
20003 20001
20005 20004
20004 20006
4 00001 20004 00002 20003
5 98823 20002 20003 20006 10010
3 12345 67890 23333
Sample Output:
No
Yes
Yes
一開始用map來存,然後全錯,仔細看題發現居然每個物品可能有多種不相容的物品,所以用二維陣列來存。輸入ship陣列後,for迴圈判斷即可,有一組不相容就false
#include<iostream>
#include<vector>
using namespace std;
int main(){
int n,m;
vector<int> bad[100000];//bad[1]是一個vector,下面存了它不能共存的物品
cin>>n>>m;
int u,v;
for(int i = 0; i < n; i++){
cin>>u>>v;
bad[u].push_back(v);
bad[v].push_back(u);
}
int k;
int ship[1005];
for(int i = 0; i < m; i++){
cin>>k;
bool flag = true;
for(int j = 0; j < k; j++){
cin>>ship[j];
}
for(int j = 0; j < k; j++){
for(int l = j + 1; l < k; l++){
for(int p = 0; p <bad[ship[j]].size(); p++){
if(bad[ship[j]][p] == ship[l]) flag = false;
}
}
}
if(flag == false) cout<<"No\n";
else cout<<"Yes\n";
}
return 0;
}
相關文章
- PAT (Advanced Level) Practice 1149 Dangerous Goods Packaging (25分)Go
- CF1149D Abandoning Roads 題解
- SAP BAPI BAPI_GOODSMVT_CREATE Goods movementAPIGo
- 【洛谷OJ】【JAVA】P1149 火柴棒等式Java
- SAP MM 物料主資料裡的‘Packaging Material Type'欄位
- SAP SD基礎知識之免費貨物(Free Goods)Go
- Salesforce Consumer Goods Cloud 淺談篇一之基礎介紹SalesforceGoCloud
- Packaging.DebUOS 專門為 dotnet 應用製作 UOS 安裝包
- 習題 8-1 裝箱(Bin Packing, SWERC 2005, UVa1149)
- 騰訊All in新基建,Q2收入1149億再創歷史新高
- Salesforce Consumer Goods Cloud 淺談篇二之門店產品促銷的配置SalesforceGoCloud
- Salesforce Consumer Goods Cloud 淺談篇三之 行動計劃(Action Plan)相關配置SalesforceGoCloud
- Salesforce Consumer Goods Cloud 淺談篇四之店內拜訪的建立和執行SalesforceGoCloud
- 關於在執行 SAP ERP MM 模組 Post Goods Issue 時修改 Material Cost 的討論Go