Web Navigation(stack棧的運用)
Standard web browsers contain features to move backward and forward among the pages recently visited. One way to implement these features is to use two stacks to keep track of the pages that can be reached by moving backward and forward. In this problem, you are asked to implement this.
The following commands need to be supported:
BACK: Push the current page on the top of the forward stack. Pop the page from the top of the backward stack, making it the new current page. If the backward stack is empty, the command is ignored.
FORWARD: Push the current page on the top of the backward stack. Pop the page from the top of the forward stack, making it the new current page. If the forward stack is empty, the command is ignored.
VISIT : Push the current page on the top of the backward stack, and make the URL specified the new current page. The forward stack is emptied.
QUIT: Quit the browser.
Assume that the browser initially loads the web page at the URL http://www.acm.org/
Input
Input is a sequence of commands. The command keywords BACK, FORWARD, VISIT, and QUIT are all in uppercase. URLs have no whitespace and have at most 70 characters. You may assume that no problem instance requires more than 100 elements in each stack at any time. The end of input is indicated by the QUIT command.
Output
For each command other than QUIT, print the URL of the current page after the command is executed if the command is not ignored. Otherwise, print "Ignored". The output for each command should be printed on its own line. No output is produced for the QUIT command.
Sample Input
VISIT http://acm.ashland.edu/ VISIT http://acm.baylor.edu/acmicpc/ BACK BACK BACK FORWARD VISIT http://www.ibm.com/ BACK BACK FORWARD FORWARD FORWARD QUIT
Sample Output
http://acm.ashland.edu/ http://acm.baylor.edu/acmicpc/ http://acm.ashland.edu/ http://www.acm.org/ Ignored http://acm.ashland.edu/ http://www.ibm.com/ http://acm.ashland.edu/ http://www.acm.org/ http://acm.ashland.edu/ http://www.ibm.com/ Ignored
import java.util.Scanner;
import java.util.Stack;
public class Main {
public static void main(String[] args) {
Scanner sc = new Scanner(System.in);
Stack<String>forward = new Stack();
Stack<String>back = new Stack();
String input;
String url;
char []str = new char[100];
back.push("http://www.acm.org/");
while(sc.hasNextLine())
{
input=sc.next();
str = input.toCharArray();
if(str[0]=='Q')break;
else if(str[0]=='V'){
url=sc.next();
back.push(url);
System.out.println(url);
while(!forward.isEmpty()){//如果新訪問一個網頁,就不能再forward;
forward.pop();
}
}
else if(str[0]=='B'){
if(back.size()>1){
forward.push(back.peek());
back.pop();
System.out.println(back.peek());
}
else{
System.out.println("Ignored");
}
}
else if(str[0]=='F'){
if(!forward.isEmpty()){
back.push(forward.peek());
System.out.println(forward.peek());
forward.pop();
}
else{
System.out.println("Ignored");
}
}
}
}
}
相關文章
- Java之Stack --- 棧Java
- 棧Stack——遞迴替身?遞迴
- docker stack滾動更新web應用DockerWeb
- 堆(heap)和棧(stack)的區別
- [CareerCup] 3.6 Sort Stack 棧排序排序
- The Stack and the Heap棧與堆__RustRust
- C++ STL stack容器——棧C++
- js資料結構--棧(stack)JS資料結構
- JAVA棧操作 Stack——不可不知的操作Java
- 使用棧實現表示式求值,運用棧計算
- 看動畫學演算法之:棧stack動畫演算法
- Dragon_Knight_CTF-stack(棧遷移)Go
- 棧的應用——計算器的四則運算
- 棧(Stack) --- C# 自定義和微軟官方的區別C#微軟
- java集合類——Stack棧類與Queue佇列Java佇列
- 【資料結構】棧(Stack)和佇列(Queue)資料結構佇列
- 【Android】任務和返回棧(tasks and back stack)Android
- 棧(2)--棧的應用
- Leetcode 225. Implement Stack using Queues 用佇列實現棧LeetCode佇列
- LeetCode 225 Implement Stack using Queues(用佇列來實現棧)(*)LeetCode佇列
- 《Learning ELK Stack》1 ELK技術棧介紹
- Lc 895. Maximum Frequency Stack 最大頻率棧 JSJS
- LeetCode Monotone Stack Summary 單調棧小結LeetCodeMono
- 程式的記憶體分配:棧區(stack)堆區(heap)。。。(轉載)記憶體
- Kernel Stack棧溢位攻擊及保護繞過
- Stack and Queue in JavaScript(Javascript中的資料結構之棧和佇列)JavaScript資料結構佇列
- 棧的應用
- ABAP webdynpro的view navigation和WebUI的view navigationWebViewNavigationUI
- 演算法與資料結構-棧(Stack)-Java實現演算法資料結構Java
- [二進位制漏洞]棧(Stack)溢位漏洞 Linux篇Linux
- 基於JavaScript的現代Web應用全棧開發:MEANJavaScriptWeb全棧
- 《Web全棧實用程式設計》一書徵集意見Web全棧程式設計
- 一個小時搭建一個全棧 Web 應用框架全棧Web框架
- 一條微博引發的思考——再談“Software Stack”之“軟體棧”譯法!
- WEB應用是如何運用Spring的?#①Spring的IOC容器如何在WEB中建立?WebSpring
- 用“MEAN”技術棧開發web應用(一)AngularJs前端架構WebAngularJS前端架構
- 全棧 – 10 資料庫 用MAMP和WAMP搭建Web環境全棧資料庫Web
- 全棧工程師如何快速構建一個Web應用全棧工程師Web