1、基本命令
switch> 使用者模式
switch>enable 進入特權模式
switch# 特權模式
switch#configure terminal 進入配置模式
switch(config)# 配置模式
switch(config)#enable password [需要設定的密碼] 設定特權模式密碼為[需要設定的密碼]
switch(config)#enable secret [需要設定的密碼] 設定特權模式密碼為加密的密碼[需要設定的密碼]
switch(config)#hostname sw1 設定主機名為sw1
sw1(config)# 主機名變為sw1
sw1(config)#end 退回到特權模式
sw1# 特權模式
sw1#exit 退回到上一個模式
sw1> 使用者模式
2、常用命令
switch(config)#enable password 密碼 配置交換機進入特權模式密碼
switch(config)#no enable secret 取消特權模式加密密碼
switch#show version 檢視系統中的所有版本資訊
switch#show ip int b 檢視各介面狀態
switch#show vlan 10 檢視交換機有關vlan10配置資訊
switch#show vlan int b 檢視交換機所有vlan資訊
switch#show running-configure 檢視交換機當前起作用的配置資訊
switch#show interface fastethernet0/1 檢視交換機介面1具體配置和統計資訊
switch#show mac address-table 檢視mac地址轉發表
switch#write 儲存配置資訊(寫入配置資訊)
switch#show vtp 檢視vtp配置資訊
switch#show run 檢視當前配置資訊
switch#show vlan brief 檢視vlan配置資訊
switch#show interface brief 檢視埠資訊
switch#show int f0/0 檢視指定埠資訊
switch#copy running-config startup-config 儲存交換機配置
switch(config-if)#speed 100 設定速率
switch(config-if)#duplex full 設定該埠為全雙工,full全雙工 half半雙工 auto為自動
switch#show ip route 檢視是否有路由表,是否開啟路由功能
在配置模式中無法使用show命令,如果要使用的話show前必須加do和空格例:do show ip int b
3、交換機恢復出廠配置
switch> enable
switch# erase startup-configure
switch# write erase
switch# reload
4、telnet 遠端登入設定
switch>enable
switch#configure terminal
swich(conf)#enable password abc123 abc123特權模式密碼(明文加密)
swich(conf)#enable secret abc123 密文加密
swich(conf)#interface vlan 1 以vlan 1埠作為遠端登入的介面,其他埠亦可
swich(conf-if)#ip address 192.168.1.1 255.255.255.0
swich(conf-if)#no shut
swich(conf-if)#exit
swich(conf)line vty 0 4 設定0-4個使用者可以telnet 遠端登陸
swich(conf-line)#password 123456
swich(conf-line)#login 設定完成後使用
5、交換機VLAN設定
(1)新增,刪除 vlan
switch#vlan database 進入vlan設定
switch(vlan)#vlan 2 建立vlan2
switch(vlan)#no vlan 2 刪除vlan 2
(2)命名vlan
switch(config)# valn 2
switch(config-vlan)# name 名字
(3)將埠加入vlan
switch(config)# interface range fastethernet 0/1 - 5 進入同種型別多埠配置
switch(config)#interface range fastethernet 0/1 - 5,gigabitethernet 0/1 - 2 進入不同型別多埠配置
switch(config-if)#switchport access vlan 2 當前埠加入vlan 2
6、交換機設定VLAN IP地址
switch(config)#interface vlan 1 進入vlan 1
switch(config-if)#ip address ip地址 設定IP地址
switch(config-if)#exit
switch(config)#ip default-gateway 閘道器地址 設定交換機預設閘道器,telnet交換機時可以使用vlan ip地址連線
7、Trunk的配置
switch(config-if)#switchport trunk encap dot1q 設定vlan中繼執行的協議
switch(config-if)#switchport mode trunk 將介面設定為中繼
switch(config-if)#switchport trunk allowed vlan 1,2 設定允許透過的vlan
switch(config-if)#switchport trunk allowed vlan remove vlan號 禁止trunk中某個VLAN的傳輸
8、乙太網通道配置(二層口)
switch1(config)#int range f0/1 -2 進入介面f0/1和f0/2
switch1(config-if-range)#channel-group 1 mode on 繫結
switch#show etherchannel summary 檢視繫結的介面
9、乙太網通道配ip地址(三層口)
switch1(config)#int port-channel 1
switch1(config-if)#ip add ip地址 子網掩碼
10、VTP的配置
sw1(config)#vtp domain 域名 設定域名
sw1(config)#vtp mode server或client或transparent 設定交換機VTP模式
sw1(config)#vtp password 密碼 設定伺服器密碼,需要同步vtp的交換機需要設相同的密碼
VTP修剪
sw1(config)#vtp pruning 啟動VTP修剪
sw1(config)#vtp version 2 配置VTP版本,預設1
sw1(config)#switchport trunk pruning vlan remove vlan號 從可修剪列表中去除某VLAN
例:switchport trunk pruning vlan remove 2-4,6,8
sw1#show interface pruning 檢視哪些介面以及哪幾個vlan被修剪了
sw1#show vtp status 檢視vtp配置資訊
11、三層交換機配置
(1)配置虛擬介面IP地址
switch(config)# interface vlan vlan號
switch(config-if)# ip address ip地址 子網掩碼
switch(config-if)# no shutdown
(2)配置物理介面IP地址
switch(config)#ip routing 啟用路由功能
switch(config)# interface f0/1
switch(config-if)#no switchport 將物理二層介面轉換為物理三層介面
switch(config-if)#ip address ip地址 子網掩碼
switch(config-if)# no shutdown
(3)配置DHCP中繼
switch(config)#service dhcp 開啟DHCP服務
switch(config-if)#ip helper-address dhcp伺服器ip地址
12、STP生成樹配置
啟用stp生成樹switch(config)#spanning-tree vlan vlan號
設定網橋優先順序,值小的優先順序高switch(config)#spanning-tree vlan vlan號 priority 32768{預設32768,範圍0~65535}
指定根網橋switch(config)#spanning-tree vlan vlan號 root primary (primary優先順序為24576,secondary優先順序為28672)
指定埠成本switch(config-if)#spanning-tree vlan vlan號 cost 成本
指定交換機埠優先順序switch(config-if)#spanning-tree vlan vlan號 port-prioty 優先順序 {優先順序0~255,預設128}
配置速埠switch(config-if)#spanning-tree portfast
檢視生成樹配置資訊switch#show spanning-tree
檢視詳細生成樹配置資訊switch#show spanning-tree vlan detail
檢視詳細生成樹埠配置資訊switch#show spanning-tree interface f0/1 detail
檢視某個VLAN生成樹配置資訊switch#show spanning-tree vlan vlan號 brief
13、HSRP(熱備份)配置
sw1(config)#int vlan 10
sw1(config-if)#ip add 192.168.10.1 255.255.255.0
sw1(config-if)#standby hsrp組號{組號預設0,範圍0~255} ip 網段閘道器地址 配置為hsrp成員
sw1(config-if)#standby hsrp組號 priority 200{預設100,範圍0~255} 配置埠優先順序
sw1(config-if)#standby hsrp組號 preempt 配置搶佔權
sw1(config-if)#standby hsrp組號 track 埠型別 埠號 優先順序 配置埠跟蹤和減去的優先順序
例:sw1(config-if)#standby 10 track fastethernet 1/1 100
sw1#show standby brief 檢視hsrp的狀態
sw1#show standby 埠型別 埠號 hsrp組號 brief 檢視指定埠hsrp的狀態
思科交換機巡檢命令
show interface stats #檢視交換機所有介面當前介面流量。
show running-config #檢視當前裝置配置。
show version #檢視IOS版本資訊及裝置正常執行時間
show clock #檢視裝置時鐘資訊
show vtp status #檢視交換機vtp配置模式
show vtp password #檢視交換機vtp配置口令
show environment 檢視裝置環境
show environment temperature --查裝置溫度
show environment fans --檢視裝置風扇
show cpu usage 檢視CPU利用率
show memory 檢視記憶體
show perfmon 檢視效能
show logging --查日誌
show version --檢視系統中的所有版本資訊
show processes cpu-usage --查CPU詳細程序
show processes memory --查記憶體詳細程序
show route --查路由表
show failover 查備援助線路
show nameif 檢視介面
show int ip brief 檢視介面狀態
show vlan --檢視vlan資訊
show inventory #調取裝置內部板卡出廠模組型號及序列號
show spanning-tree root #檢視交換機生成樹根位置
show cdp neighbors #檢視鄰接cisco裝置基本資訊
show cdp neighbors detail #檢視鄰接cisco裝置詳細資訊
show interface status #檢視交換機介面狀態是否存在error disable介面disable介面
show interface summary #檢視交換機所有介面當前介面流量
show interface |ierrors|FastEthernet|GigabitEthernet #檢視介面是否存在大量input或output errors包錯誤
show processes cpu #檢視裝置cpu負載
show processes mem #檢視裝置mem負載
show access-list #檢視訪問控制列表配置及匹配資料包數量
show logging #檢視本機內部日誌記錄情況
show ip route #檢視路由表
show firewall #檢查防火牆的工作模式
show conn count #檢查防火牆併發數
show xlate count #檢查防火牆nat工作狀態