POJ-1363 Rails-堆疊入門
Rails
Time Limit: 1000MS | Memory Limit: 10000K | |
Total Submissions: 28286 | Accepted: 10992 |
Description
There is a famous railway station in PopPush City. Country there is incredibly hilly. The station was built in last century. Unfortunately, funds were extremely limited that time. It was possible to establish only a surface track.
Moreover, it turned out that the station could be only a dead-end one (see picture) and due to lack of available space it could have only one track.
The local tradition is that every train arriving from the direction A continues in the direction B with coaches reorganized in some way. Assume that the train arriving from the direction A has N <= 1000 coaches numbered in increasing order 1, 2, ..., N. The chief for train reorganizations must know whether it is possible to marshal coaches continuing in the direction B so that their order will be a1, a2, ..., aN. Help him and write a program that decides whether it is possible to get the required order of coaches. You can assume that single coaches can be disconnected from the train before they enter the station and that they can move themselves until they are on the track in the direction B. You can also suppose that at any time there can be located as many coaches as necessary in the station. But once a coach has entered the station it cannot return to the track in the direction A and also once it has left the station in the direction B it cannot return back to the station.
The local tradition is that every train arriving from the direction A continues in the direction B with coaches reorganized in some way. Assume that the train arriving from the direction A has N <= 1000 coaches numbered in increasing order 1, 2, ..., N. The chief for train reorganizations must know whether it is possible to marshal coaches continuing in the direction B so that their order will be a1, a2, ..., aN. Help him and write a program that decides whether it is possible to get the required order of coaches. You can assume that single coaches can be disconnected from the train before they enter the station and that they can move themselves until they are on the track in the direction B. You can also suppose that at any time there can be located as many coaches as necessary in the station. But once a coach has entered the station it cannot return to the track in the direction A and also once it has left the station in the direction B it cannot return back to the station.
Input
The input consists of blocks of lines. Each block except the last describes one train and possibly more requirements for its reorganization. In the first line of the block there is the integer N described above. In each of the
next lines of the block there is a permutation of 1, 2, ..., N. The last line of the block contains just 0.
The last block consists of just one line containing 0.
The last block consists of just one line containing 0.
Output
The output contains the lines corresponding to the lines with permutations in the input. A line of the output contains Yes if it is possible to marshal the coaches in the order required on the corresponding line of the input. Otherwise
it contains No. In addition, there is one empty line after the lines corresponding to one block of the input. There is no line in the output corresponding to the last ``null'' block of the input.
Sample Input
5 1 2 3 4 5 5 4 1 2 3 0 6 6 5 4 3 2 1 0 0
Sample Output
Yes No Yes
Source
Central Europe 1997
這道題的意思是,車只有兩種開的方向:A入站、站出B。
自由移動的意思是指,車子可以開進站不立即出去,也可以開進去就開出去。
要模擬出入站,看看是否滿足給定的順序。
這道題的意思是,車只有兩種開的方向:A入站、站出B。
自由移動的意思是指,車子可以開進站不立即出去,也可以開進去就開出去。
要模擬出入站,看看是否滿足給定的順序。
//AC1
#include<stdio.h>
int main()
{
int a[1005],b[1005],i,j,k,n;
while(scanf("%d",&n),n)
{
while(scanf("%d",&b[0]),b[0])
{
for(j=1; j<n; j++)
scanf("%d",&b[j]);
for(i=1,j=0,k=0; i<=n&&j<n; i++,k++)
{
a[k]=i;
while(a[k]==b[j])
{
if(k>0)k--;
else
{
a[k]=0,k--;
}
j++;
if(k==-1)break;
}
}
if(j==n)printf("Yes\n");
else printf("No\n");
}
printf("\n");
}
}
//AC2
#include<stdio.h>
int main()
{
int input[1005],output[1005],k,j,i,n;
while(scanf("%d",&n),n)
{
while(scanf("%d",&output[0]),output[0])
{
for(j=1; j<n; j++)
scanf("%d",&output[j]);
for(k=1,j=0,i=0; k<=n;i++,k++)
{
input[i]=k;
while(input[i]==output[j])
{
i--;
j++;
if(i==-1)
break;
}
}
if(j==n)
printf("Yes\n");
else
printf("No\n");
}
printf("\n");
}
}
//超時
#include <cstdio>
#include <cstring>
#include <iostream>
using namespace std;
const int maxn=1000+10;
int main()
{
int n,p[maxn];
cin>>n;
while(n)
{
int x,max=0,i,j;
cin>>x;
while(x)
{
memset(p,0,sizeof(p));
bool valid=true;
for(i=0; i<n; ++i)
{
if(valid)
{
bool ok=true;
for(j=x+1; j<=max; ++j)
if(p[j]==1)
{
ok=false;
break;
}
if(!ok)
valid=false;
else
{
max=(max>x?max:x);
p[x]=2;
for(j=x-1; j>0&&!p[j]; --j)
p[j]=1;
}
}
if(i<n)
cin>>x;
}
cout<<(valid?"Yes":"No")<<endl;
cin>>x;
}
cout<<endl;
cin>>n;
}
}
相關文章
- JS 堆疊JS
- 平衡堆疊
- 堆疊圖
- python資料視覺化-matplotlib入門(5)-餅圖和堆疊圖Python視覺化
- C#堆疊(Stack)C#
- [golang]如何看懂呼叫堆疊Golang
- 益智補劑:Stamets堆疊
- Thrift的網路堆疊
- bzoj2253 紙箱堆疊
- 什麼是網路堆疊?
- junkman 遠端堆疊監控
- iOS crash 日誌堆疊解析iOS
- (js佇列,堆疊) (FIFO,LIFO)JS佇列
- StackOverflowError堆疊溢位錯誤Error
- 華為裝置堆疊原理
- 作業系統---在核心中重新載入GDT和堆疊作業系統
- Python實現堆疊與佇列Python佇列
- 【matplotlib 實戰】--堆疊面積圖
- JS 資料型別和堆疊JS資料型別
- QT分局管理:堆疊窗體(三)QT
- CSS之定位和堆疊屬性CSS
- echarts 堆疊面積階梯圖Echarts
- SQL隱碼攻擊-堆疊注入SQL
- Java堆疊的區別有哪些Java
- 資料結構的概念、堆疊資料結構
- golang: 返回錯誤時列印堆疊Golang
- Java之String和StringBuffer堆疊圖分析Java
- C中關於堆疊的總結
- 不一樣的 Android 堆疊抓取方案Android
- information_schema.innodb_trx 查詢堆疊ORM
- android 解碼混淆過的堆疊資訊Android
- 堆疊溢位報錯引發的思考
- 堆疊的實現(1)--靜態陣列陣列
- JS中堆疊記憶體的練習JS記憶體
- windows核心程式設計--記憶體堆疊Windows程式設計記憶體
- 三探堆疊欺騙之Custom Call Stacks
- thinkphp console 命令列列印錯誤呼叫堆疊PHP命令列
- 初探堆疊欺騙之靜態欺騙
- 如何利用執行緒堆疊定位問題執行緒