YT04-貪心課堂練習-1005—Wooden Sticks-(6.14日-煙臺大學ACM預備隊解題報告)

kewlgrl發表於2015-06-21

Wooden Sticks

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 19   Accepted Submission(s) : 7

Font: Times New Roman | Verdana | Georgia

Font Size:  

Problem Description

There is a pile of n wooden sticks. The length and weight of each stick are known in advance. The sticks are to be processed by a woodworking machine in one by one fashion. It needs some time, called setup time, for the machine to prepare processing a stick. The setup times are associated with cleaning operations and changing tools and shapes in the machine. The setup times of the woodworking machine are given as follows: 

(a) The setup time for the first wooden stick is 1 minute. 
(b) Right after processing a stick of length l and weight w , the machine will need no setup time for a stick of length l' and weight w' if l<=l' and w<=w'. Otherwise, it will need 1 minute for setup. 

You are to find the minimum setup time to process a given pile of n wooden sticks. For example, if you have five sticks whose pairs of length and weight are (4,9), (5,2), (2,1), (3,5), and (1,4), then the minimum setup time should be 2 minutes since there is a sequence of pairs (1,4), (3,5), (4,9), (2,1), (5,2).

Input

The input consists of T test cases. The number of test cases (T) is given in the first line of the input file. Each test case consists of two lines: The first line has an integer n , 1<=n<=5000, that represents the number of wooden sticks in the test case, and the second line contains n 2 positive integers l1, w1, l2, w2, ..., ln, wn, each of magnitude at most 10000 , where li and wi are the length and weight of the i th wooden stick, respectively. The 2n integers are delimited by one or more spaces.

Output

The output should contain the minimum setup time in minutes, one per line.

Sample Input

3 
5 
4 9 5 2 2 1 3 5 1 4 
3 
2 2 1 1 2 2 
3 
1 3 2 2 3 1

Sample Output

2
1
3

Source

Asia 2001, Taejon (South Korea)


145  王忠

•I)Sort函式有三個引數:
•(1)第一個是要排序的陣列的起始地址。
•(2)第二個是結束的地址(最後一位要排序的地址)
•(3)第三個引數是排序的方法,可以是從大到小也可是從小到大,還可以不寫第三個引數,此時預設的排序方法是從小到大排序


#include <iostream>
#include <stdio.h>
#include <algorithm>
using namespace std;
struct node
{
    int l,w;
} a[10001],flag[10001];
bool cmp(node x,node y)
{
    return x.l!=y.l ? x.l<y.l : x.w<y.w ;
}
int main()
{
    int t,n,m,i,j;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        for(i=0; i<n; i++)
        {
            scanf("%d %d",&a[i].l,&a[i].w);
        }
        sort(a,a+n,cmp);   //按l升序排
        m=0;
        flag[m]=a[0];   //結構體既然可以直接=
        for(i=1; i<n; i++)
        {
            for(j=0; j<=m; j++) //在flag中w小的總是在後面,所以不用再根據w排序
            {
                if(flag[j].w<=a[i].w)   //更新原有資料
                {
                    flag[j]=a[i];
                    break;
                }
            }
            if(j>m)   //加入新資料
            {
                flag[++m]=a[i];
            }
        }
        printf("%d\n",m+1);
    }
    return 0;
}


相關文章