字串*-全字母句

HowieLee59發表於2019-03-18

Problem Description

全字母句 (pangram) 指包含字母表中全部 26 種英文字母(不區分大小寫)的句子,其常被用於展示英文字型的顯示效果。

現在,bLue 得到了很多句子,他想知道哪些句子是全字母句。

Input

輸入資料有多組(資料組數不超過 100),到 EOF 結束。

每組資料包含一行長度不超過 100 的字串。

Output

對於每組資料,輸出一行。

如果是全字母句則輸出 "Yes",否則輸出 "No"(不包括引號)。

Sample Input

The quick brown fox jumps over the lazy dog.
The 6th ACM Funny Programming For/While Contest

Sample Output

Yes
No
#include<stdio.h>
#include<stdlib.h>
#include<string.h>

int main(){
    char str[1001];
    int i,len;
    while(gets(str)){
        int str1[1001] = {0};
        len = strlen(str);
        for(int i = 0 ; i < len ; i++){
            if(str[i] >= 'a' && str[i] <= 'z'){
                str[i] = str[i] - 32;
            }
            if(str[i] >= 'A' && str[i] <= 'Z'){
                str1[str[i]]++;
            }
        }
        int flag = 0;
        for(i = 65 ; i <= 90; i++){
            if(str1[(char)i] == 0){
                flag = 1;
                break;
            }
        }
        if(flag==0)printf("Yes\n");
        else printf("No\n");
    }
    return 0;
}


 

相關文章