DP--m處理器問題- m processors(FZU - 1442)

retrogogogo發表於2020-11-06

DP–m處理器問題- m processors(FZU - 1442)

Description

There are n data packets and m processors in a network communication system. In this problem, you need to distribute the n data packets to the m processors so that the workload of each processor is as balance as possible.
在這裡插入圖片描述

INPUT:
There are several test cases. Each case contains two lines. There are two integers n and m in the first line. n is the length of the sequence, and m is the number of subsequence you have to divide into. The following line contains n integers representing the sequence. (1<=m,n<=100)

OUTPUT:
Output one real number with two decimal digits in the fraction that represents the expected result for each case.

Sample Input
6 3
2 2 12 3 6 11
Sample Output
12.32

題目解析

1.題目意思:
有n個連續資料包(a1,a2,a3,…,an,ai表示第i個資料包的大小),依次分給m個處理器,每個處理器便相應得到一個規定負載量 f(i,j)(如若a1,a2,a3給第一個處理器,那麼第一個處理器的負載量就是 sqrt(a1^2 + a2^2+ a3^2) , 即f(1,3) ),那總會存在一個或多個處理器使其負載量在所有處理器中是最大的,我們設其為Max,我們就要去求在所有分配情況中,Max最小的值為多少,即最優負載量。

2.題目思路:
這裡介紹一個類似的題目:DP–鄉村郵局問題-Post Office(POJ-1160)
這倆道題目的dp遞推很像,可以參照著看,能夠更好地理解。

  • 我們這裡定義一個二維陣列dp[][],其中dp[i][j]表示前 i 個資料包分給 j 個處理器的最優負載量。

  • 對於一個子結構dp[i][j],即 i包分給j個處理器的最優負載量,我們可以這麼求:

  • 我們先定義一箇中間值k,在確定dp[k][j-1]的情況下

  • 我們可以得到i包分給j個處理器的最優負載量為:前k包給j-1個處理器,k+1到i包給1個處理器的最優負載量,即:

dp[i][j] = max(dp[k][j - 1], f(k + 1,i)) ----其中(j-1<= k <i)

參考程式碼:
注意我的做法是先不管負載量的開方,先利用平方號內的值dp最後再開方。

#include<iostream>
#include<cstring>
#include<cmath>
#include<algorithm>
#include<iomanip>
#include<cstdio>
typedef long long ll;
using namespace std;
ll load[110];
ll bload[110][110];//存放從i到j的負載量的值(即題目中的f(i,j)未開平方前的值 )
ll dp[110][110];//前i包分給j個處理器
int main()
{
	int n, m;
	while (cin >> n >> m) {
		memset(bload, 0, sizeof(bload));
		memset(dp, 0, sizeof(dp));

		for (int i = 1; i <= n; i++) {
			cin >> load[i];
			bload[1][i] = bload[1][i - 1] + load[i] * load[i];//這裡也是動態規劃的思想
			dp[i][1] = bload[1][i];//這裡順便初始化只有一個處理器的值,這很重要,算是邊界值了
			for (int j = 2; j <= i; j++) {
				bload[j][i] = bload[1][i] - bload[1][j - 1];//其實可以用字首和做,但這樣更加清晰點應該。
			}
		}
		for (int j = 2; j <= m && j <= n; j++) {//j為處理器數
			for (int i = j; i <= n; i++) {//i為包數
				dp[i][j] = 0x3f3f3f3f;
				for (int k = j - 1; k < i; k++) {//前k包給j-1個處理器,k+1到i包給1以處理器
					dp[i][j] = min(dp[i][j], max(dp[k][j - 1], bload[k + 1][i]));//最大負載的最小值
				}
			}
		}
		
		if (m > n)
			m = n;
		cout << fixed << setprecision(2);
		double ans = sqrt((double)dp[n][m]);//算出來後再開平方
		ans = floor(ans * 100.0) / 100.0;//題目中要求不四捨五入,這樣可以達到這個效果
		cout << ans << endl;
	}

	return 0;
}

相關文章