數獨問題(DFS+回溯)

@Solomon發表於2020-10-15

文章目錄

題目

數獨遊戲的規則是這樣的:在一個9x9的方格中,你需要把數字1-9填寫到空格當中,並且使方格的每一行和每一列中都包含1-9這九個數字。同時還要保證,空格中用粗線劃分成9個3x3的方格也同時包含1-9這九個數字。比如有這樣一個題,大家可以仔細觀察一下,在這裡面每行、每列,以及每個3x3的方格都包含1-9這九個數字。

樣例


Sample Input
7 1 2 ? 6 ? 3 5 8
? 6 5 2 ? 7 1 ? 4
? ? 8 5 1 3 6 7 2
9 2 4 ? 5 6 ? 3 7
5 ? 6 ? ? ? 2 4 1
1 ? 3 7 2 ? 9 ? 5
? ? 1 9 7 5 4 8 6
6 ? 7 8 3 ? 5 1 9
8 5 9 ? 4 ? ? 2 3
 

Sample Output
7 1 2 4 6 9 3 5 8
3 6 5 2 8 7 1 9 4
4 9 8 5 1 3 6 7 2
9 2 4 1 5 6 8 3 7
5 7 6 3 9 8 2 4 1
1 8 3 7 2 4 9 6 5
2 3 1 9 7 5 4 8 6
6 4 7 8 3 2 5 1 9
8 5 9 6 4 1 7 2 3

程式碼

#include<iostream>
#include <cstring>
#include <algorithm>

using namespace std;

struct node {
    int x, y;
};
node arr[105];
char ch;
int Map[10][10];
int N = 0;

bool judge(int num, int x, int y) {
    for (int i = 0; i < 9; ++i) {
        if (Map[i][y] == num || Map[x][i] == num)
            return false;
    }
    x = x / 3 * 3;
    y = y / 3 * 3;
    for (int i = x; i < x + 3; ++i) {
        for (int j = y; j < y + 3; ++j) {
            if (Map[i][j] == num)
                return false;
        }
    }
    return true;
}

void dfs(int dept) {
    if (dept == N) {
        for (int i = 0; i < 9; ++i) {
            for (int j = 0; j < 9; ++j) {
                if (j == 8)
                    cout << Map[i][j];
                else
                    cout << Map[i][j] << " ";
            }
            cout << endl;
        }
        return;
    }
    for (int i = 1; i <= 9; ++i) {
        if (judge(i, arr[dept].x, arr[dept].y)) {
            Map[arr[dept].x][arr[dept].y] = i;
            dfs(dept + 1);
            Map[arr[dept].x][arr[dept].y] = 0;
        }
    }
}

int line = 0;

int main() {
    while (cin >> ch) {
        N = 0;
        if (ch == '?') {
            Map[0][0] = 0;
            arr[N].x = 0;
            arr[N].y = 0;
            N++;
        } else
            Map[0][0] = ch - '0';

        for (int i = 0; i < 9; ++i) {
            for (int j = 0; j < 9; ++j) {
                if (i == 0 && j == 0)
                    continue;
                cin >> ch;
                if (ch == '?') {
                    Map[i][j] = 0;
                    arr[N].x = i;
                    arr[N].y = j;
                    N++;
                } else
                    Map[i][j] = ch - '0';
            }
        }

        if (line++)
            cout << endl;
        dfs(0);
    }
    return 0;
}


相關文章