POJ 1129 Channel Allocation (暴力搜尋)
Channel Allocation
Description
When a radio station is broadcasting over a very large area, repeaters are used to retransmit the signal so that every receiver has a strong signal. However, the channels used by each repeater must be carefully chosen so that nearby repeaters do not interfere
with one another. This condition is satisfied if adjacent repeaters use different channels.
Since the radio frequency spectrum is a precious resource, the number of channels required by a given network of repeaters should be minimised. You have to write a program that reads in a description of a repeater network and determines the minimum number of channels required. Input
The input consists of a number of maps of repeater networks. Each map begins with a line containing the number of repeaters. This is between 1 and 26, and the repeaters are referred to by consecutive upper-case letters of the alphabet starting with A. For example,
ten repeaters would have the names A,B,C,...,I and J. A network with zero repeaters indicates the end of input.
Following the number of repeaters is a list of adjacency relationships. Each line has the form: A:BCDH which indicates that the repeaters B, C, D and H are adjacent to the repeater A. The first line describes those adjacent to repeater A, the second those adjacent to B, and so on for all of the repeaters. If a repeater is not adjacent to any other, its line has the form A: The repeaters are listed in alphabetical order. Note that the adjacency is a symmetric relationship; if A is adjacent to B, then B is necessarily adjacent to A. Also, since the repeaters lie in a plane, the graph formed by connecting adjacent repeaters does not have any line segments that cross. Output
For each map (except the final one with no repeaters), print a line containing the minumum number of channels needed so that no adjacent channels interfere. The sample output shows the format of this line. Take care that channels is in the singular form when
only one channel is required.
Sample Input 2 A: B: 4 A:BC B:ACD C:ABD D:BC 4 A:BCD B:ACD C:ABD D:ABC 0 Sample Output 1 channel needed. 3 channels needed. 4 channels needed. Source |
有連線的都要設定不同的訊號。(無向圖染色)也是暴力搜尋過了。
根據題意模擬了一遍:遍歷一個頂點,給他與直接相聯的頂點不同的最小值。
有幾種值,就是答案。注意n=1,ans=0。還有單詞加不加s。
#include <iostream>
#include <string.h>
#include <stdio.h>
#include <queue>
#include <algorithm>
#include <math.h>
using namespace std;
int mp[33][33];
int main()
{
int n;
while(~scanf("%d",&n)&&n)
{
memset(mp,0,sizeof mp);
for(int j=1;j<=n;j++)
{
string s;
cin>>s;
char c=s[0];
for(int i=2;i<s.length();i++)
{
mp[c-'A'+1][s[i]-'A'+1]=1;
}
}
int flag[33];
int num[33];
memset(num,0,sizeof num);
for(int i=1;i<=n;i++)
{
memset(flag,0,sizeof flag);
for(int j=1;j<=n;j++)
{
if(mp[i][j]==1)
{
flag[num[j]]=1;
}
}
for(int j=1;;j++)
{
if(!flag[j])
{
num[i]=j;
break;
}
}
}
int ans=0;
memset(flag,0,sizeof flag);
for(int i=1;i<=n;i++)
{
if(flag[num[i]]==0)
{
flag[num[i]]=1;
ans++;
}
}
if(n==1) ans=0;
if(ans==1||ans==0) printf("1 channel needed.\n");
else printf("%d channels needed.\n",ans);
}
}
相關文章
- 【簡單搜尋】POJ 2251 Dugeon MasterAST
- POJ - 2236 Wireless Network (kuangbin - 簡單搜尋)
- Pots POJ – 3414 (搜尋+記錄路徑)
- POJ1915,雙向寬度優先搜尋
- 【譯】Swift演算法俱樂部-暴力字串搜尋Swift演算法字串
- 演算法學習筆記-暴力搜尋和分治法演算法筆記
- 暴力搜尋演算法的典型應用——24點遊戲演算法遊戲
- WeetCode3 暴力遞迴->記憶化搜尋->動態規劃遞迴動態規劃
- 1129
- 最佳路徑搜尋(二):啟發式搜尋(代價一致搜尋(Dijkstra search),貪心搜尋,A*搜尋)
- 海量資料搜尋---搜尋引擎
- 搜尋
- 搜尋引擎-03-搜尋引擎原理
- 搜尋引擎es-分詞與搜尋分詞
- 點選搜尋框清空搜尋提示文字
- 直播系統程式碼,常用搜尋中搜尋歷史,搜尋推薦功能
- 搜尋策略
- vim搜尋
- 搜尋功能
- 搜尋技巧
- 20240713總結(搜尋專題,但是不想搜尋)
- Elasticsearch(ES)的高階搜尋(DSL搜尋)(上篇)Elasticsearch
- Elasticsearch(ES)的高階搜尋(DSL搜尋)(下篇)Elasticsearch
- 搜尋的未來是精品搜尋 | a16z
- 直播開發app,實時搜尋、搜尋引擎框APP
- 谷歌搜尋用上BERT,10%搜尋結果將改善谷歌
- 人肉搜尋、網路暴力、隱私洩露!國產工作室把這些做成遊戲遊戲
- mysql 1129處理MySql
- 啟發式搜尋的方式(深度優先,廣度優先)和 搜尋方法(Dijkstra‘s演算法,代價一致搜尋,貪心搜尋 ,A星搜尋)演算法
- Python之 常用查詢演算法:最小項搜尋、順序搜尋、二分搜尋Python演算法
- 搜尋插入位置
- 搜尋/查詢
- Google搜尋技巧Go
- Elasticsearch 向量搜尋Elasticsearch
- Elasticsearch常用搜尋Elasticsearch
- 貪心+搜尋
- elasticsearch搜尋商品Elasticsearch
- 單詞搜尋