演算法學習之路|SpellItRight
Given a non-negative integer N, your task is to compute the sum of all the digits of N, and output every digit of the sum in English.
Input Specification:
Each input file contains one test case. Each case occupies one line which contains an N (<= 10100).
Output Specification:
For each test case, output in one line the digits of the sum in English words. There must be one space between two consecutive words, but no extra space at the end of a line.
Sample Input:
12345
Sample Output:
one five
解題思路:
給出一個非負數N,求出各個位置的數字之和,並用one ,two表示出來,直接模擬即可。
#include<cstdio>
#include<iostream>
#include<vector>
#include<cstring>
using namespace std;
int main(){
string k;
string a[15]={"zero","one","two","three","four","five","six","seven","eight","nine"};
int sum=0;
cin>>k;
for(int i=0;i<k.length();i++){
sum+=k[i]-`0`;
}
vector <int>v;
while(sum){
v.push_back(sum%10);
sum/=10;
}
if(v.size()==0){
cout<<"zero";
}
else {
cout<<a[v[v.size()-1]];
}
for(int i=v.size()-2;i>=0;i--){
cout<<" "<<a[v[i]];
}
return 0;
}
相關文章
- 強化學習之路一 QLearning 演算法強化學習演算法
- 小白機器學習基礎演算法學習必經之路(下)機器學習演算法
- eggjs學習之路JS
- java學習之路Java
- Pytest學習之路
- 機器學習&深度學習之路機器學習深度學習
- 付費學習之路
- 產品學習之路
- vue-學習之路Vue
- 信安學習之路
- web前端學習之路Web前端
- linux學習之路(1)Linux
- 凡人學習Linux之路Linux
- Python 學習之路(下)Python
- go學習之路 --- 起步Go
- FPGA 學習之路:verilog學習第5天FPGA
- golang學習之路 之mapGolang
- 人工智慧學習之路人工智慧
- Android開發學習之路Android
- javaweb學習之路(3)CookieJavaWebCookie
- javaweb學習之路(1)requestJavaWeb
- 學習之路 / handle請求
- Java學習之路 -- Java怎麼學?Java
- 拿下史丹佛和劍橋雙offer,00後的演算法學習之路演算法
- RxJS學習之路四(Operators(1))JS
- MySql 學習之路-高階2MySql
- Python學習之路5-字典Python
- Python學習之路8.1-類Python
- Android開發學習之路03Android
- Jeecg-Cloud學習之路(一)Cloud
- Kotlin協程學習之路【一】Kotlin
- 學習WCF之路,長期更新
- python學習之路—day1Python
- 演算法學習演算法
- BFS洛谷P1135 奇怪的電梯(我的演算法學習之路)演算法
- SpringCloud學習之路(一)- 走進SpringCloudSpringGCCloud
- Python學習之路3-操作列表Python
- Python學習之路35-協程Python
- Hadoop學習之路(六)HDFS基礎Hadoop