Andy's First Dictionary
Andy, 8, has a dream - he wants to produce his very own dictionary. This is not an easy task for him, as the number of words that he knows is, well, not quite enough. Instead of thinking up all the words himself, he has a briliant idea. From his bookshelf he would pick one of his favourite story books, from which he would copy out all the distinct words. By arranging the words in alphabetical order, he is done! Of course, it is a really time-consuming job, and this is where a computer program is helpful.
You are asked to write a program that lists all the different words in the input text. In this problem, a word is defined as a consecutive sequence of alphabets, in upper and/or lower case. Words with only one letter are also to be considered. Furthermore, your program must be CaSe InSeNsItIvE. For example, words like "Apple", "apple" or "APPLE" must be considered the same.
Input
The input file is a text with no more than 5000 lines. An input line has at most 200 characters. Input is terminated by EOF.
Output
Your output should give a list of different words that appears in the input text, one in a line. The words should all be in lower case, sorted in alphabetical order. You can be sure that he number of distinct words in the text does not exceed 5000.
Sample Input
Adventures in Disneyland
Two blondes were going to Disneyland when they came to a fork in the road. The sign read: "Disneyland Left."
So they went home.
Sample Output
a
adventures
blondes
came
disneyland
fork
going
home
in
left
read
road
sign
so
the
they
to
two
went
were
when
/*輸入一個文字,找出所有不同的單詞(連續的字母序列),
按照字典序從小到大輸出單詞不區分大小寫*/
//ps 對於縮寫 I'm 去除'後為I和m兩個單詞
#include<iostream>
#include<string>
#include<set>
using namespace std;
set<string>s;
int main()
{
string str,str1;
while(cin>>str)
{
for(int i=0;i<str.length();i++)
{
if(isalpha(str[i]))//isalpha()判斷字元是否為英文字母,若為英文字母,返回非0(小寫字母為2,大寫字母為1)。若不是字母,返回0
{
str[i]=tolower(str[i]);//tolower()功能是把字母字元轉換成小寫,非字母字元不做出處理
str1+=str[i];
}
else
{
if(str1.length())
{
s.insert(str1);
str1.clear();
}
}
}
if(str1.length())
{
s.insert(str1);
str1.clear();
}
}
set<string>::iterator it=s.begin();
while(it!=s.end())
{//遍歷輸出
cout<<*it<<endl;
it++;
}
return 0;
}
isalpha():判斷字元是否為英文字母,若為英文字母,返回非0(小寫字母為2,大寫字母為1)。若不是字母,返回0
tolower():功能是把字母字元轉換成小寫,非字母字元不做出處理
相關文章
- school dictionary, kids dictionary, children dictionary
- Third season first episode,Ross‘s sex fantasy!!!ROS
- SAP S4HANA LTMC Practice - the first shot!
- ARABIC-ENGLISH DICTIONARY: THE HANS WEHR DICTIONARY OF MODERN WRITTEN ARABIC
- Dictionary<string, object>Object
- 深入解讀Dictionary
- Dictionary application using SwingAPP
- Python 3 字典(Dictionary)Python
- First Blog
- 7.93 FIRST
- 953. Verifying an Alien Dictionary
- O7_Dictionary_Accessibility
- C#:Dictionary轉DataTableC#
- 字典 dictionary c# 0104C#
- :first-child與:first-of-type 區別
- My first blog!
- my first demo
- First steps with Incus
- My First Blog
- [LeetCode] 953. Verifying an Alien DictionaryLeetCode
- c# Dictionary<TKey,TValue>.TryAddC#
- 【重要論文】The dictionary and the language learner
- DotNet Dictionary 實現簡介
- python中的list、tuple和dictionaryPython
- python比較json/dictionary的庫PythonJSON
- .net原始碼分析 – Dictionary泛型原始碼泛型
- 【C#】-Dictionary的詳細用法C#
- C# 6.0的Dictionary語法C#
- 【EF Core】Code first
- 7.94 FIRST_VALUE
- Head First Python (一)Python
- oracle O7_DICTIONARY_ACCESSIBILITY 引數Oracle
- [LeetCode] 524. Longest Word in Dictionary through DeletingLeetCode
- 從Dictionary原始碼看雜湊表原始碼
- 遍歷 Dictionary,你會幾種方式?
- 英文單詞縮寫----DXNRY – Dictionary 字典
- CSS E::first-letterCSS
- FIRST_ROWS_n(轉)