Andy's First Dictionary

韓小妹發表於2018-08-12

  Andy, 8, has a dream - he wants to produce his very own dictionary. This is not an easy task for him, as the number of words that he knows is, well, not quite enough. Instead of thinking up all the words himself, he has a briliant idea. From his bookshelf he would pick one of his favourite story books, from which he would copy out all the distinct words. By arranging the words in alphabetical order, he is done! Of course, it is a really time-consuming job, and this is where a computer program is helpful.

  You are asked to write a program that lists all the different words in the input text. In this problem, a word is defined as a consecutive sequence of alphabets, in upper and/or lower case. Words with only one letter are also to be considered. Furthermore, your program must be CaSe InSeNsItIvE. For example, words like "Apple", "apple" or "APPLE" must be considered the same.

Input

The input file is a text with no more than 5000 lines. An input line has at most 200 characters. Input is terminated by EOF.

Output

Your output should give a list of different words that appears in the input text, one in a line. The words should all be in lower case, sorted in alphabetical order. You can be sure that he number of distinct words in the text does not exceed 5000.

Sample Input

Adventures in Disneyland 

Two blondes were going to Disneyland when they came to a fork in the road. The sign read: "Disneyland Left." 

So they went home.

Sample Output

a
adventures 
blondes 
came 
disneyland 
fork 
going 
home 
in 
left 
read 
road 
sign 
so 
the 
they 
to 
two 
went 
were 
when
/*輸入一個文字,找出所有不同的單詞(連續的字母序列),
按照字典序從小到大輸出單詞不區分大小寫*/
//ps 對於縮寫 I'm 去除'後為I和m兩個單詞
#include<iostream>
#include<string>
#include<set>
using namespace std;
set<string>s;
int main()
{
	string str,str1;
	while(cin>>str)
	{
		for(int i=0;i<str.length();i++)
		{
			if(isalpha(str[i]))//isalpha()判斷字元是否為英文字母,若為英文字母,返回非0(小寫字母為2,大寫字母為1)。若不是字母,返回0
			{
				str[i]=tolower(str[i]);//tolower()功能是把字母字元轉換成小寫,非字母字元不做出處理
				str1+=str[i];	
			}
			else
			{
				if(str1.length()) 
				{
					s.insert(str1);
					str1.clear();
				}
			}
		}
		if(str1.length()) 
		{
			s.insert(str1);
			str1.clear();
		}
	}
	set<string>::iterator it=s.begin();
	while(it!=s.end())
	{//遍歷輸出 
		cout<<*it<<endl;
		it++;
	}
	return 0;
 } 

isalpha():判斷字元是否為英文字母,若為英文字母,返回非0(小寫字母為2,大寫字母為1)。若不是字母,返回0

tolower():功能是把字母字元轉換成小寫,非字母字元不做出處理

 

相關文章