HDU 1004 Let the Balloon Rise(STL初體驗之map)

王仁杰njupt發表於2018-04-16
Problem Description
Contest time again! How excited it is to see balloons floating around. But to tell you a secret, the judges' favorite time is guessing the most popular problem. When the contest is over, they will count the balloons of each color and find the result.

This year, they decide to leave this lovely job to you. 
 

Input
Input contains multiple test cases. Each test case starts with a number N (0 < N <= 1000) -- the total number of balloons distributed. The next N lines contain one color each. The color of a balloon is a string of up to 15 lower-case letters.

A test case with N = 0 terminates the input and this test case is not to be processed.
 

Output
For each case, print the color of balloon for the most popular problem on a single line. It is guaranteed that there is a unique solution for each test case.
 

Sample Input
5 green red blue red red 3 pink orange pink 0
 

Sample Output
red pink

題目大意:如題

思路:建立一個map<string, int>, 通過cnt["string"]=int的方法儲存值,學習其中關於“找a是否存在,不存在就先讓它為0,再加1,存在就直接加一”

程式碼如下

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<iostream>
#include<string>
#include<set>
#include<map>
#include<queue>
#include<cmath>
#include<stdlib.h>
typedef long long ll;
typedef unsigned long long ull;
using namespace std;
const int maxn = 1e5 + 100;
double eps = 1e-8;
map<string, int> cnt;
int main(){
	int n;
	while(scanf("%d", &n) && n){
		cnt.clear();
		string a;
		int ans =0;
		string anss;
		for(int i = 0; i < n ; i++){
			cin >> a;
			if(!cnt.count(a))cnt[a]=0;
			cnt[a]++;
			if(cnt[a]>ans){
				ans =cnt[a];
				anss = a;
			}
		}
		cout << anss << endl;
		
	}
	
    return 0;
}