HDU4941Magical Forest(map)
Problem Description
There is a forest can be seen as N * M grid. In this forest, there is some magical fruits, These fruits can provide a lot of energy, Each fruit has its location(Xi, Yi) and the energy can be provided Ci.
However, the forest will make the following change sometimes:
1. Two rows of forest exchange.
2. Two columns of forest exchange.
Fortunately, two rows(columns) can exchange only if both of them contain fruits or none of them contain fruits.
Your superior attach importance to these magical fruit, he needs to know this forest information at any time, and you as his best programmer, you need to write a program in order to ask his answers quick every time.
However, the forest will make the following change sometimes:
1. Two rows of forest exchange.
2. Two columns of forest exchange.
Fortunately, two rows(columns) can exchange only if both of them contain fruits or none of them contain fruits.
Your superior attach importance to these magical fruit, he needs to know this forest information at any time, and you as his best programmer, you need to write a program in order to ask his answers quick every time.
Input
The input consists of multiple test cases.
The first line has one integer W. Indicates the case number.(1<=W<=5)
For each case, the first line has three integers N, M, K. Indicates that the forest can be seen as maps N rows, M columns, there are K fruits on the map.(1<=N, M<=2*10^9, 0<=K<=10^5)
The next K lines, each line has three integers X, Y, C, indicates that there is a fruit with C energy in X row, Y column. (0<=X<=N-1, 0<=Y<=M-1, 1<=C<=1000)
The next line has one integer T. (0<=T<=10^5)
The next T lines, each line has three integers Q, A, B.
If Q = 1 indicates that this is a map of the row switching operation, the A row and B row exchange.
If Q = 2 indicates that this is a map of the column switching operation, the A column and B column exchange.
If Q = 3 means that it is time to ask your boss for the map, asked about the situation in (A, B).
(Ensure that all given A, B are legal. )
The first line has one integer W. Indicates the case number.(1<=W<=5)
For each case, the first line has three integers N, M, K. Indicates that the forest can be seen as maps N rows, M columns, there are K fruits on the map.(1<=N, M<=2*10^9, 0<=K<=10^5)
The next K lines, each line has three integers X, Y, C, indicates that there is a fruit with C energy in X row, Y column. (0<=X<=N-1, 0<=Y<=M-1, 1<=C<=1000)
The next line has one integer T. (0<=T<=10^5)
The next T lines, each line has three integers Q, A, B.
If Q = 1 indicates that this is a map of the row switching operation, the A row and B row exchange.
If Q = 2 indicates that this is a map of the column switching operation, the A column and B column exchange.
If Q = 3 means that it is time to ask your boss for the map, asked about the situation in (A, B).
(Ensure that all given A, B are legal. )
Output
For each case, you should output "Case #C:" first, where C indicates the case number and counts from 1.
In each case, for every time the boss asked, output an integer X, if asked point have fruit, then the output is the energy of the fruit, otherwise the output is 0.
In each case, for every time the boss asked, output an integer X, if asked point have fruit, then the output is the energy of the fruit, otherwise the output is 0.
Sample Input
1
3 3 2
1 1 1
2 2 2
5
3 1 1
1 1 2
2 1 2
3 1 1
3 2 2
Sample Output
Case #1:
1
2
1
交換的時候用map記錄行、列交換後的位置;
#include <iostream>
#include <stdio.h>
#include <string.h>
#include <map>
using namespace std;
int main(){
int t,n,m,k,cnt=1;
scanf("%d",&t);
while(t--){
scanf("%d%d%d",&n,&m,&k);
map<pair<int ,int >,int > mp;
map<int ,int > x;
map<int ,int > y;
int a,b,c;
for(int i=0;i<k;i++){
scanf("%d%d%d",&a,&b,&c);
mp[make_pair(a,b)]=c;
}
printf("Case #%d:\n",cnt++);
int q,ord ,l,r;
scanf("%d",&q);
while(q--){
scanf("%d%d%d",&ord,&a,&b);
if(ord==1){
if(!x[a]) l=a;
if(!x[b]) r=b;
x[a]=r,x[b]=l;
}
if(ord==2){
if(!y[a]) l=a;
if(!y[b]) r=b;
y[a]=r,y[b]=l;
}
if(ord==3){
if(x[a]) l=x[a];
else l=a;
if(y[b]) r=y[b];
else r=b;
printf("%d\n",mp[make_pair(l,r)]);
}
}
}
return 0;
}
相關文章
- HDU - 6736 F - Forest ProgramREST
- Machine Learning(13)- Random ForestMacrandomREST
- 1118. Birds in Forest (25)REST
- 第九篇:隨機森林(Random Forest)隨機森林randomREST
- Segmentation of retinal OCT images using a random forest classifierSegmentationrandomREST
- CF1092E Minimal Diameter ForestREST
- Map
- 白話異常檢測演算法Isolation Forest演算法REST
- ML《決策樹(四)Bagging 和 Random Forest》randomREST
- Paper Reading: Cost-sensitive deep forest for price predictionREST
- Java 中的map - The Map Interface.Java
- Causal Inference理論學習篇-Tree Based-Causal ForestREST
- JavaScript map()JavaScript
- jQuery map()jQuery
- Google MapGo
- java mapJava
- Map集合
- c++ map和unordered_map比較C++
- java Map及Map.Entry詳解Java
- java中Map根據Map的value取keyJava
- 詳解map、multimap、unordered_map、unordered_multimap
- Map get() 方法
- Map delete() 方法delete
- Go(4 [Map])Go
- JavaScript map()方法JavaScript
- SCSS map物件CSS物件
- Map.getOrDefault()
- 特徵提取-map特徵
- map切片排序排序
- jQuery.map()jQuery
- Scala操作Map
- Map總結
- map 對比
- Class-map
- map/ multimap容器
- 04.Map
- 林軒田機器學習技法課程學習筆記10 — Random Forest機器學習筆記randomREST
- Causal Inference理論學習篇-Tree Based-From Uplift Tree to Uplift ForestREST