HDU - 1702 - ACboy needs your help again!

不凡_發表於2018-02-13
ACboy was kidnapped!! 
he miss his mother very much and is very scare now.You can't image how dark the room he was put into is, so poor :(. 
 As a smart ACMer, you want to get ACboy out of the monster's labyrinth.But when you arrive at the gate of the maze, the monste say :" I have heard that you are very clever, but if can't solve my problems, you will die with ACboy." 
The problems of the monster is shown on the wall: 
 Each problem's first line is a integer N(the number of commands), and a word "FIFO" or "FILO".(you are very happy because you know "FIFO" stands for "First In First Out", and "FILO" means "First In Last Out"). 
and the following N lines, each line is "IN M" or "OUT", (M represent a integer). 
 and the answer of a problem is a passowrd of a door, so if you want to rescue ACboy, answer the problem carefully!
InputThe input contains multiple test cases. 
The first line has one integer,represent the number oftest cases. 
And the input of each subproblem are described above.OutputFor each command "OUT", you should output a integer depend on the word is "FIFO" or "FILO", or a word "None" if you don't have any integer.Sample Input
4
4 FIFO
IN 1
IN 2
OUT
OUT
4 FILO
IN 1
IN 2
OUT
OUT
5 FIFO
IN 1
IN 2
OUT
OUT
OUT
5 FILO
IN 1
IN 2
OUT
IN 3
OUT
Sample Output
1
2
2
1
1
2
None
2

3

這道題就是理解棧和佇列的異同 棧是先進後出FILO 隊是先進先出FIFO

隊或棧 都為空時輸出None

#include<stdio.h>  
#include<string.h>  
int main()  
{  
    int t,n,i,j,num,a[10000];  
    char str[10],mark[10];  
    scanf("%d",&t);  
    while(t--)  
    {  
        scanf("%d%s",&n,str);  
        if(strcmp(str,"FIFO")==0)//佇列   
        {  
            i=j=0;//i為進佇列數,j為出佇列數   
            while(n--)  
            {  
                scanf("%s",mark);  
                if(strcmp(mark,"IN")==0)  
                {  
                    scanf("%d",&num);  
                    a[i++]=num;//進佇列   
                }  
                else  
                {  
                    if(j>=i)//判斷佇列是否為空   
                       printf("None\n");  
                    else  
                       printf("%d\n",a[j++]);//出佇列   
                }  
            }  
        }  
        else if(strcmp(str,"FILO")==0)//棧   
        {  
            i=0;  
            while(n--)  
            {  
                scanf("%s",mark);  
                if(strcmp(mark,"IN")==0)  
                {  
                    scanf("%d",&num);  
                    a[i++]=num;//進棧,注意此處i值在a[i]賦值後自增1,即此處後a[i]是沒有被賦值的   
                }  
                else  
                {  
                    if(i<1)//若a[0]已經被賦值,i必等於1   
                       printf("None\n");  
                    else  
                       printf("%d\n",a[--i]);//出棧,先自減再經行運算   
                }  
            }  
        }  
    }  
    return 0;  
}  

相關文章