字串-簡單字串比較

HowieLee59發表於2019-03-18

Problem Description

請使用字串比較函式,比較兩個字串的大小,並按要求輸出比較後的結果。字串最長不超過15個字元。
輸入兩個字串str1和str2,如果第一個字串與第二個字串相等,輸出str1=str2,如果第一個字串大於第二個字串,輸出str1>str2,如果第一個字串小於第二個字串,輸出str1 < str2。

Input

第1行為第一個字串。
第2行為第二個字串。

Output

在一行輸出比較後的結果。例如"abc"與"abc"相等,輸出為abc=abc,如果"ab"小於"abc”,輸出ab < abc。

Sample Input

ab
abc

Sample Output

ab<abc
#include<stdio.h>
#include<string.h>
int main()
{
    char a[20],b[20];
    gets(a);
    gets(b);
    if(!strcmp(a,b))
    {
        printf("%s=%s",a,b);
    }
    else if(strcmp(a,b) < 0)
    {
        printf("%s<%s",a,b);
    }
    else
    {
        printf("%s>%s",a,b);
    }
    return 0;
}

 

相關文章