網路拓撲例項之交換機基於介面地址池作為DHCP伺服器(六)

南空城 發表於 2020-11-27

組網圖形

    網路拓撲例項之交換機基於介面地址池作為DHCP伺服器(六)

DHCP伺服器簡介

  • 通常使用者希望網路中的每臺終端能夠動態獲取IP地址、DNS伺服器的IP地址、路由資訊、閘道器資訊等網路引數,不需要手動配置終端的IP地址等網路引數;另外,針對一些移動終端(手機、ipad、辦公筆記本等)希望能夠即插即用,不需要每次修改終端的IP等網路引數。如果使用者網路中有這些需求,就可以在匯聚層的使用者閘道器裝置或核心層裝置上配置DHCP伺服器功能,來給終端分配IP地址等網路引數。
  • 動態主機配置協議DHCP(Dynamic Host Configuration Protocol)採用客戶端/伺服器模式對使用者的網路引數進行動態配置和集中管理。其中,DHCP伺服器通過地址池為使用者分配IP地址等網路引數。地址池分為介面地址池和全域性地址池兩種。
  • 介面地址池配置方式簡單,只能用於使用者與DHCP伺服器在同一個網段的場景,並且只能給對應介面下的使用者分配IP地址等網路引數;適用於裝置數量有限、配置以及維護量可控的小型網路。在使用者閘道器裝置上配置基於介面地址池的DHCP伺服器功能之後,對應介面下的固定主機、移動終端等都可以自動獲取IP地址等網路引數,不需要使用者手動配置修改。
  • 與介面地址池相比,全域性地址池可應用於大型網路,推薦在核心層裝置上配置基於全域性地址池的DHCP伺服器功能或在伺服器區域搭建一臺專門的DHCP伺服器統一分配IP地址等網路引數,而使用者閘道器裝置上只需要啟用簡單的DHCP中繼功能即可。

組網需求

  • 如圖1所示,某企業為辦公終端規劃了兩個網段,網段10.1.1.0/24內PC為員工固定辦公終端,網段10.1.2.0/24供企業出差人員臨時接入網路。企業希望通過DHCP方式為員工固定辦公終端和企業出差人員分配IP地址。其中,企業管理者的辦公PC(Client_1)由於業務需要,希望使用固定IP地址為10.1.1.100/24。

配置思路

  • 基於介面地址池的DHCP伺服器的配置思路如下:

  通過在閘道器裝置Switch上配置DHCP伺服器,實現為企業兩個網段內的終端動態分配IP地址。其中,網段10.1.1.0/24內的PC為員工固定辦公終端,IP地址租期配置為30天;網段10.1.2.0/24供企業出差人員臨時接入網路,IP地址租期配置為1天。

說明: 
二層交換機LSW_1和LSW_2上,需要配置介面的鏈路型別和加入的VLAN,實現二層互通。

 操作步驟

  • 1.使能DHCP服務,預設未使能
<HUAWEI> system-view
[HUAWEI] sysname Switch
[Switch] dhcp enable
  •  2.配置介面加入VLAN

  # 配置GE0/0/1介面加入VLAN10。

[Switch] vlan batch 10 to 11
[Switch] interface gigabitethernet 0/0/1
[Switch-GigabitEthernet0/0/1] port link-type access
[Switch-GigabitEthernet0/0/1] port default vlan 10
[Switch-GigabitEthernet0/0/1] quit

   # 配置GE0/0/2加介面入VLAN11。

[Switch] interface gigabitethernet 0/0/2
[Switch-GigabitEthernet0/0/2] port link-type access
[Switch-GigabitEthernet0/0/2] port default vlan 11
[Switch-GigabitEthernet0/0/2] quit
  •  3.配置VLANIF介面IP地址

  # 配置VLANIF10介面地址。

[Switch] interface vlanif 10
[Switch-Vlanif10] ip address 10.1.1.1 24  //企業為固定辦公終端的網段
[Switch-Vlanif10] quit

   # 配置VLANIF11介面地址。

[Switch] interface vlanif 11
[Switch-Vlanif11] ip address 10.1.2.1 24  //企業為出差人員分配的網段
[Switch-Vlanif11] quit
  •  4.配置介面地址池

  # 配置VLANIF10介面下的終端從介面地址池中獲取IP地址。

[Switch] interface vlanif 10
[Switch-Vlanif10] dhcp select interface  //使能介面採用介面地址池的DHCP伺服器功能,預設未使能
[Switch-Vlanif10] dhcp server lease day 30  //租期的預設值為1天,修改租期為30天
[Switch-Vlanif10] dhcp server static-bind ip-address 10.1.1.100 mac-address 286e-d488-b684  //為Client_1分配固定的IP地址
[Switch-Vlanif10] quit

   # 配置VLANIF11介面下的終端從介面地址池中獲取IP地址。租期採用預設值1天(不需配置)。

[Switch] interface vlanif 11
[Switch-Vlanif11] dhcp select interface  //使能介面採用介面地址池的DHCP伺服器功能,預設未使能
[Switch-Vlanif11] quit
  •  5.配置DHCP資料儲存功能,裝置發生故障時,可以在系統重啟後,執行命令dhcp server database recover,從儲存裝置檔案恢復DHCP資料。
[Switch] dhcp server database enable
  •  6.配置各終端自動獲取IP地址(以作業系統為Windows 7的PC為例)
  1. 右擊桌面“網路”,單擊“屬性”,進入“網路和共享中心”視窗。
  2. 單擊“本地連線”,進入“本地連線 狀態”視窗。
  3. 單擊“屬性”,進入“本地連結 屬性”視窗。
  4. 選擇“Internet 協議版本 4(TCP/IPv4)”,點選“屬性”,進入“Internet 協議版本 4(TCP/IPv4)屬性”視窗,選擇“自動獲得 IP 地址”,單擊“確定”。
  • 7.驗證配置結果

  在Switch上執行命令display ip pool檢視介面地址池VLANIF10和VLANIF11的配置資訊。假設企業員工固定辦公終端有100個,出差人員接入3個。

[Switch] display ip pool interface vlanif10
  Pool-name        : Vlanif10
  Pool-No          : 0
  Lease            : 30 Days 0 Hours 0 Minutes
  Domain-name      : -
  DNS-server0      : -
  NBNS-server0     : -
  Netbios-type     : -
  Position         : Interface       Status             : Unlocked
  Gateway-0        : 10.1.1.1
  Network          : 10.1.1.0
  Mask             : 255.255.255.0
  VPN instance     : --
  Logging          : Disable
  Conflicted address recycle interval: -
  Address Statistic: Total       :253       Used        :100
                     Idle        :153       Expired     :0
                     Conflict    :0         Disable     :0

 -------------------------------------------------------------------------------
  Network section
         Start           End       Total    Used Idle(Expired) Conflict Disabled
 -------------------------------------------------------------------------------
        10.1.1.1      10.1.1.254     253     100        153(0)       0     0
 -------------------------------------------------------------------------------
[Switch] display ip pool interface vlanif11
  Pool-name        : Vlanif11
  Pool-No          : 1
  Lease            : 1 Days 0 Hours 0 Minutes
  Domain-name      : -
  DNS-server0      : -
  NBNS-server0     : -
  Netbios-type     : -
  Position         : Interface       Status             : Unlocked
  Gateway-0        : 10.1.2.1
  Network          : 10.1.2.0
  Mask             : 255.255.255.0
  VPN instance     : --
  Logging          : Disable
  Conflicted address recycle interval: -
  Address Statistic: Total       :253       Used        :3
                     Idle        :250       Expired     :0
                     Conflict    :0         Disable     :0

 -------------------------------------------------------------------------------
  Network section
         Start           End       Total    Used Idle(Expired) Conflict Disabled
 -------------------------------------------------------------------------------
        10.1.2.1      10.1.2.254     253     3          250(0)       0     0
 -------------------------------------------------------------------------------

   在Client_1(作業系統以Windows 7為例)上檢視IP地址資訊,可以看到Client_1已經獲取到IP地址10.1.1.100/24。

C:\Documents and Settings\Administrator>ipconfig

Windows IP Configuration


Ethernet adapter Local Area Connection 2:

   Connection-specific DNS Suffix  . :
   IPv4 Address. . . . . . . . . . . : 10.1.1.100
   Subnet Mask . . . . . . . . . . . : 255.255.254.0
   Default Gateway . . . . . . . . . : 10.1.1.1

   在其他DHCP客戶端(以10.1.1.0/24網段中作業系統為Windows 7的某終端為例)上檢視IP地址資訊,可以看到已經成功獲取到IP地址。

C:\Documents and Settings\Administrator>ipconfig

Windows IP Configuration


Ethernet adapter Local Area Connection 2:

   Connection-specific DNS Suffix  . :
   IPv4 Address. . . . . . . . . . . : 10.1.1.51
   Subnet Mask . . . . . . . . . . . : 255.255.254.0
   Default Gateway . . . . . . . . . : 10.1.1.1