1129 Recommendation System (25分)
Recommendation system predicts the preference that a user would give to an item. Now you are asked to program a very simple recommendation system that rates the user’s preference by the number of times that an item has been accessed by this user.
Input Specification:
Each input file contains one test case. For each test case, the first line contains two positive integers: N (≤ 50,000), the total number of queries, and K (≤ 10), the maximum number of recommendations the system must show to the user. Then given in the second line are the indices of items that the user is accessing – for the sake of simplicity, all the items are indexed from 1 to N. All the numbers in a line are separated by a space.
Output Specification:
For each case, process the queries one by one. Output the recommendations for each query in a line in the format:
query: rec[1] rec[2] … rec[K]
where query is the item that the user is accessing, and rec[i] (i=1, … K) is the i-th item that the system recommends to the user. The first K items that have been accessed most frequently are supposed to be recommended in non-increasing order of their frequencies. If there is a tie, the items will be ordered by their indices in increasing order.
Note: there is no output for the first item since it is impossible to give any recommendation at the time. It is guaranteed to have the output for at least one query.
Sample Input:
12 3
3 5 7 5 5 3 2 1 8 3 8 12
Sample Output:
5: 3
7: 3 5
5: 3 5 7
5: 5 3 7
3: 5 3 7
2: 5 3 7
1: 5 3 2
8: 5 3 1
3: 5 3 1
8: 3 5 1
12: 3 5 8
題目都看不懂
#include<iostream>
#include<set>
using namespace std;
int book[50001] = {0};
struct node{
int val,cnt;
node(int a, int b):val(a),cnt(b){}
bool operator < (const node& a) const{
return(cnt != a.cnt) ? cnt > a.cnt : val < a.val;
}
};
int main(){
int n,k,num;
cin>>n>>k;
set<node> s;
for(int i = 0; i < n; i++){
cin>>num;
if(i!=0){
cout<<num<<":";
int tempCnt = 0;
for(auto it = s.begin();tempCnt < k && it != s.end(); it++){
cout<<" "<<it->val;
tempCnt++;
}
cout<<endl;
}
auto it = s.find(node(num,book[num]));
if(it != s.end()) s.erase(it);
book[num]++;
s.insert(node(num,book[num]));
}
return 0;
}
相關文章
- 1129
- mysql 1129處理MySql
- DataGridView控制元件 1129View控制元件
- Recommendation Systems Basic Notes
- An Analysis of Sequential Recommendation Datasets
- 草稿 9206需抄寫 1129
- POJ 1129 Channel Allocation (暴力搜尋)
- T1129 行程長度編碼行程
- DualGNN: Dual Graph Neural Network for Multimedia RecommendationGNN
- 序列推薦模型梳理(Sequential Recommendation)模型
- 【論文筆記】 Popularity Bias in Dynamic Recommendation筆記
- 【論文筆記】 Denoising Implicit Feedback for Recommendation筆記
- An Attentive Inductive Bias for Sequential Recommendation beyond the Self-Attention
- 【論文筆記】SamWalker: Social Recommendation with Informative Sampling Strategy筆記ORM
- 推薦系統入門(Top-N recommendation)
- System
- System類
- 論文解讀(NGCF)《LightGCN: Simplifying and Powering Graph Convolution Network for Recommendation》GC
- [SIGIR2020] Sequential Recommendation with Self-Attentive Multi-Adversarial Network
- 轉載:System:System.arraycopy方法詳解
- System design summary
- System Design InterviewView
- golang system callGolang
- System.arraycopy
- 1.5.2.3. SYSTEM
- System Error CodesError
- system.exit(0)和system.exit(1)的區別
- remount of /system failed: Read-only file system原因及解決REMAI
- 30-System類
- System.arraycopy(...) 用法
- operating-system structuresStruct
- The Network Diagram on the PVE system
- D. Rating System
- List of Android System PermissionsAndroid
- System Generator20201224
- Understanding System Statistics(zt)
- System.Net.HttpHTTP
- C# convert System.Drawing.Bitmap to System.Windows.Media.Imaging.BitmapImageC#WindowsAPI